Asterisk MeetMe - user introduction disabled

Hello Experts,

I'm new to Asterisk and testing the various features, while testing meetme feature I'm able to set up conf room but I'm not able to record the person name and below is the error message

- Executing [800@group1:1] MeetMe("SIP/1002-0000001d", "800,IMc") in new stack
  == Parsing '/etc/asterisk/meetme.conf':   == Found
[Apr 15 20:17:16] WARNING[3716]: channel.c:4003 ast_request: No channel type registered for 'DAHDI'
    -- Created MeetMe conference 1023 for conference '800'
[Apr 15 20:17:16] WARNING[3716]: app_meetme.c:3613 find_conf: No DAHDI channel available for conference, user introduction disabled (is chan_dahdi loaded?)


Below is my extension.conf and meetme.conf

Extension.conf

[general]
writeprotect=no
priorityjumping=yes
include => parkedcalls

[group1]

include => parkedcalls
exten => _1XXX,1,Dial(SIP/${EXTEN},10,tr)
exten => _1XXX,2, VoiceMail(${EXTEN}@voicemail_test,u,b)
exten => _1XXX,3,Playback(vm-goodbye)
exten => _1XXX,4,Hangup()
exten => 9998,1,VoiceMailMain(_1XXX@voicemail_test)

exten => 800,1,MeetMe(800,IMc)

meetme.conf

conf => 800,1111,2222

Any help appreciated.

AnanthahkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bwilks99Commented:
Hi, Found some info here about the problem.

http://voip-forum.easyofficephone.com/viewtopic.php?f=18&t=184
0
AnanthahkAuthor Commented:
Hello I have the mentioned module at  /usr/lib/asterisk/modules

[root@server2 modules]# pwd
/usr/lib/asterisk/modules
[root@server2 modules]# ls chan_dahdi.so
chan_dahdi.so

On Centos when I try to load the module I get following error message
[root@server2 modules]# insmod chan_dahdi.so
insmod: error inserting 'chan_dahdi.so': -1 Invalid module format
0
bwilks99Commented:
Hi I found this in an icr log. Hope it helps sorry I don't have the same version to test.

http://ibot.rikers.org/%23asterisk/20090422.html.gz

FATAL: Error inserting dahdi (/lib/modules/2.6.26-1-686/asterisk/dahdi/dahdi.ko): Invalid module format
Usually means it wasn't compiled for your current kernel
hmm... let me kick it about a bit..
i've installed "linux-modules-2.6.26-1-686" and "linux-headers-2.6.26-1-686"
looks like the compile is taking a little longer this time..
huzzah, it's worked..
amazing, it didn't noticeably whinge... but works now..
thanks for the pointers..
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

AnanthahkAuthor Commented:
I tried re compiling DAHDI but no good, Do I need to compile the kernel ?

Also I do not have any harwdware timing device (PRI card) since this is a lab setup, could that be any issue ?
0
bwilks99Commented:
I think what they are saying is that the kernel headers or kernel source was not installed. They installed it and recompiled DAHDI
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AnanthahkAuthor Commented:
Will have to try
0
AnanthahkAuthor Commented:
Partial solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.