Assigning a host on vCenter

Hi Peeps,

A bit of a strange for you, we have an old IBM xSeries 335 server which has vCenter installed on it. This server however, is a bit flakey, so I decided to install vCenter on to a different server which is more reliable.

I unlicensed our host which was being managed by the xSeries 335 and then uninstalled vCenter and installed on to the newer server. Installed fine, no problems, added our new ESX 4.0 host no problem,but when I try to add the first ESX 4.0 which was originally managed by the xSeries 335, it gives me this message:

"Cannot install the vCenter agent service. Not enough space on device."

I read on a vmware forum that it might be to do with the host not having enough contiguous memory and that I should try switching off the VM's and try adding again or if that fails, reboot the host. Did the above steps but still no joy!?!?!?

Oh and I also check to make sure the video adapters on the VM's were set to auto assign memory, I also read this on the vmware forum.

Please could anybody help as I am completely stumped!!

Cheers,

Jimbo
BinleysAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vmwarun - ArunCommented:
1.Where was the vCenter DB running ? Was it running on the same host or on a different server ?
2.How much swap memory had you configured when you installed ESX Host ?
3.Which method of ESX Installation did you perform ? (Normal or Scripted)
bbnp2006Commented:
log in to your esx console and do a
#df -l
does the result show any of the partitions full? or nearly full?
jakethecatukCommented:
OK...try this out: -

1. establish if the Virtual Centre agents are installed.  Login to the ESX4 host and type in the following: - 'rpm -qa | grep vpxa'.  You should get a reply similar to 'VMware-vpxa-4.0.0-162856' (the version number may be lower, but will be there)
2. assuming step 1 is correct you need to stop all the services by typing in: -
 service mgmt-vmware stop
 service vmware-vpxa stop
 service vmware-vmkauthd stop
 service xinetd restart' (this stops the management services for the service console.)
3. remove the Virtual Centre agent by typing in 'rpm -ef {and the value that was returned in step 1}.  On my machine, it would be 'rpm -ef VMware-vcpa-4.0.0-162856'
4. now remove the 'vpxuser' by typing in 'userdel vpxuser'
5. we need to restart the services by typing in: -
 service mgmt-vmware start
 service vmware-vmkauthd start
6. wait a few minutes and then type in 'vmware-cmd -l'.  If you get an error, the services are still restarting.  When you don't get an error, you can try and add it back to your Vcentre (it it's in the list of hosts, remove it)

This is a condensed set of instructions from here (http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003714).  I condensed it as there was a lot in there wasn't relevant.
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

BinleysAuthor Commented:
Hi Jake,

Does this involve powering off the VM's?

Cheers,
jakethecatukCommented:
Shouldn't make any difference.  If it was me doing this on a production environment, I'd do it out of hours though - just in case (but I am ubber cautious) :)
BinleysAuthor Commented:
@bbnp2006 - I ran that command and the /Dev/SDC5 is showing as 100% in use and is mounted on /.
BinleysAuthor Commented:
Hi Jake,

Run your commands early hours of this morning and they all ran fine, tried to add the host again and it gave me the error:

Cannot install the vCenter Server agent service.  Unknown installer error

Any ideas?  Did I not start a service that I should have?

Cheers,
bbnp2006Commented:
./dev/sdc5 could be pointing to one of your internal drive or partition, can you verify what it is? If the operation carried out during adding the host to VC is accessing that device, the operation will fail.
rvivek_2002Commented:
It seems your root partition is full.
The vmware kb lists steps to free some space on / safley.
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003564

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vmwarun - ArunCommented:
You should award points to jakethecatuk and rvivek_2002 for providing the solution and not bluntly close the question.
rvivek_2002Commented:
Hi what am I supposed to accept the points (new here, any help would be apprecciated)
BinleysAuthor Commented:
Sorry guy's, didn't realize I had closed the ticket!
bbnp2006Commented:
Glad you resolved your issue, just curious why you don't find my suggestions helpful :) since running #df command eventually suggested that you have a full partition that caused the problem? anyways, glad it worked out for you which is what we are all here for.
BinleysAuthor Commented:
The reason I chose those answers were because they both helped me fix my query.  Jakethecatuk posted a list of commands that I needed to run which unistalled the vCenter Agent from my host and rvivek2002 posted a link that showed me how to free up space on my hosts root partition.  When I cleaned my root partition I was able to add the host to my new vCenter installation.

Hope this helps!

Cheers,
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.