outlook 2003 users cannot download OAB only 2007 users

hi all,

having a problem where outlook 2003 users cant download the OAB, only users on 2007 can

i have added the authenticated users to the OAB folder in IIS
i have confirmed that the GUID matches in all exhcange folder properties

2007 users download it no problem though :S
any ideas?
LVL 1
awilderbeastAsked:
Who is Participating?
 
MegaNuk3Commented:
Assign it an OAB either through the EMC:
Organization Configuration-->Mailbox-->Database Management-->Properties on your Mailbox database/s-->Client Settings-->Offline address book

Or EMS
Get-MailboxDatabase | Set-Mailboxdatabase -offlineAddressBook "\Default Offline Address Book"
0
 
Hilal1924Commented:
In The Outlook 2003 client, Just delete the *.oab files and see if you can download the OAB.
Meanwhile what is the error that you are getting ?
Hilal
0
 
awilderbeastAuthor Commented:
where are they stored?

the error is 0x8001040F

thanks
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Hilal1924Commented:
Go to  (Or Simply search for *.oab files)
windows XP: C:\Documents and Settings\UserName\Local Settings\Microsoft\Office\Outlook\
 
Windows7 : C:\Users\username\Local Settings\Microsoft\Office\Outlook\
Here is some more Info:
http://support.microsoft.com/kb/841273 
Hilal

 
 
0
 
MarkMelansonCommented:
You don't say what version of Exchange you are running. If it is 2003 try:

Open Exchange System Manager:
Goto Recipients->Offline Address Lists->Default Offline Address list, right click and select rebuild.
0
 
awilderbeastAuthor Commented:
Sorry using exchange 2010 ive tried rebuilding the oab on the exchange server it doesn't do anything for the outlook 203 clients
0
 
Hilal1924Commented:
Hi I said delete OAB's from Clients, Not server.
Hilal
0
 
MegaNuk3Commented:
Have you enabled PF distribution of the OAB for the Outlook 2003 clients because they will not pick up the OAB over web distribution like Outlook 2007 clients...
0
 
awilderbeastAuthor Commented:
PF distribution is checked yes

also just thought, i have the public folders database but i dont have any public folders shares to open in outlook nor can i see them on the exchange al i see is a public folders address list and the public folders database

how do i create public folders for clients?

and if i get that up will that sort it?

Thanks
0
 
MegaNuk3Commented:
In Outlook press Ctrl+6 which should bring up the Folder list.

Scroll right down to the bottom and you should see "Public Folders", try and create a public folder in there, if you can it proves that your PF store is up and running.
0
 
MegaNuk3Commented:
Also see if you can browse to here:
http://pfserver/public/non_ipm_subtree/offline%20address%20book/

where pfserver is the name of your Public Folder server.
0
 
awilderbeastAuthor Commented:
browsing to http://ch-ex/public/non_ipm_subtree/offline%20address%20book/

comes back ith access denied, even though im an enterprise admin, is that normal?

i looked at the permissons in iis too my account is there with full control as default
0
 
MegaNuk3Commented:
It is Exchange permissions that will be stoppng you. Can you see the PF tree through Outlook?
0
 
awilderbeastAuthor Commented:
i have outlook 2007 on my machine and i cant see it no, how do i open it?
0
 
MegaNuk3Commented:
As I said in post: #31180611

scroll down in the navigation pane (left hand side) do you see Public Folders listed?
0
 
awilderbeastAuthor Commented:
oh wait i found it, when to folder list and its at the bottom, has nothing in i though, should it have something in it?

as a side questionhow do i add things to the public folders in ex2010, like calendars

im going to grab an users comp with outlook 2003 see if i can see the public folders in there...
0
 
MegaNuk3Commented:
You won't be able to see OABs from Outlook as they are System Folders.

If you can create folders in the "Public Folders" tree from Outlook then that proves they are online. Which also answers your side question. You can Right click in Public folders from Outlook and do Create New Folder-->and change "folder contains" to "Calendar items"

the above will create a Calendar PF item.
0
 
awilderbeastAuthor Commented:
ok i just right clicked > new folder > typed name and then error...

any ideas? :S
error.PNG
0
 
MegaNuk3Commented:
You don't have Exchange permissions on the PF folder... Check your permissions from EMC on the PFs and give yourself 'Owner' Client rights...
0
 
MegaNuk3Commented:
0
 
MegaNuk3Commented:
Give yourself the exchange "Public folder Management" role:
Add-RoleGroupMember -Identity "Public Folder Management" -Member You
0
 
MegaNuk3Commented:
You apparently can't use the EMC to give the "Public folder management" role.
0
 
awilderbeastAuthor Commented:
done that (see screen)

just tried adding a public folder through outlook again same error
im at a different site to the exchange server

should i install outlook on the exchange server?
0
 
MegaNuk3Commented:
no don't ever install Outlook on the Exchange server itself...
0
 
MegaNuk3Commented:
might take a little bit of time to replicate
0
 
MegaNuk3Commented:
Confirm the public store exists and is mounted and that the mailbox store that the Outlook clients are in has been assigned a PF store.
0
 
MegaNuk3Commented:
PF rights should have nothing to do with Outlook 2003 users downloading the OAB...
0
 
awilderbeastAuthor Commented:
see attachments

its been a while now, shouldnt of replicated by now?

still cant add a folder to the public folders
public-folders.PNG
mouted.PNG
0
 
MegaNuk3Commented:
Expand Offline address book and "Version4" an see if it is showing content or size and where it is replicating to.

Do properties on "Mailbox database 0435..." and make sure it it using the PF store from the same server.
0
 
MegaNuk3Commented:
Have a look at this article:
http://msexchangeteam.com/archive/2007/04/19/437902.aspx

And specifically check this:
RESOLUTION: Bonded offlne address list to primary storgage group; Exchange Management Console=>Server Configuration=>Mailbox=.Database Management tab=>
First Storage Group Properties (right click and select properties)=>Client Settings tab=>Offline Address Book field=>click browse button and select the respective OAB defined on the system.
0
 
awilderbeastAuthor Commented:
you cant see properties or anything on that mmc snap in, i expanded ver4 nothing in it, but i could create a folder in there, but when you create a folder in there you cant do nothing with it either

i have exchange 2010 those tabs arent there

cheers
0
 
MegaNuk3Commented:
post me the results from the following commands:
Get-OfflineAddressbook | ft identity, publicfolderdatabase
0
 
awilderbeastAuthor Commented:
[PS] C:\Windows\system32>Get-OfflineAddressbook | ft identity, publicfolderdatabase

Identity                                                    PublicFolderDatabase
--------                                                    --------------------
\Default Offline Address Book                               Public Folder Database 0500997731



they match up ok there
public.PNG
0
 
MegaNuk3Commented:
OK, what about:
get-mailboxdatabase | ft name, *public*
0
 
awilderbeastAuthor Commented:
[PS] C:\Windows\system32>get-mailboxdatabase | ft name, *public*

Name                                                        PublicFolderDatabase
----                                                        --------------------
Mailbox Database 0435330091                                 Public Folder Database 0500997731
0
 
MegaNuk3Commented:
looks OK.

try
Get-OfflineAddressbook | FL
0
 
awilderbeastAuthor Commented:
here you go



[PS] C:\Windows\system32>Get-OfflineAddressbook | FL


RunspaceId                       : cab7cd45-750f-4378-acb9-0e53c32f6957
Server                           : CH-EX
AddressLists                     : {\Default Global Address List}
Versions                         : {Version3, Version4}
IsDefault                        : True
PublicFolderDatabase             : Public Folder Database 0500997731
PublicFolderDistributionEnabled  : True
GlobalWebDistributionEnabled     : False
WebDistributionEnabled           : True
LastTouchedTime                  : 20/04/2010 06:12:27
LastNumberOfRecords              : 40
MaxBinaryPropertySize            : 32768
MaxMultivaluedBinaryPropertySize : 65536
MaxStringPropertySize            : 3400
MaxMultivaluedStringPropertySize : 65536
ConfiguredAttributes             : {OfficeLocation, ANR, ProxyAddresses, ANR, PhoneticGivenName, ANR, GivenName, ANR, P
                                   honeticSurname, ANR, Surname, ANR, Account, ANR, PhoneticDisplayName, ANR, DisplayNa
                                   meUnicode, ANR, ExternalMemberCount, Value, TotalMemberCount, Value, ModerationEnabl
                                   ed, Value, DelivContLength, Value, MailTipTranslations, Value, ObjectGuid, Value, Is
                                   Organizational, Value...}
DiffRetentionPeriod              : 30
Schedule                         : {Sun.05:00-Sun.05:15, Mon.05:00-Mon.05:15, Tue.05:00-Tue.05:15, Wed.05:00-Wed.05:15,
                                    Thu.05:00-Thu.05:15, Fri.05:00-Fri.05:15, Sat.05:00-Sat.05:15}
VirtualDirectories               : {CH-EX\OAB (Default Web Site)}
ExchangeVersion                  : 0.10 (14.0.100.0)
AdminDisplayName                 :
Name                             : Default Offline Address Book
DistinguishedName                : CN=Default Offline Address Book,CN=Offline Address Lists,CN=Address Lists Container,
                                   CN=Company Name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC
                                   =local
Identity                         : \Default Offline Address Book
Guid                             : 41d7b7f7-41bb-40af-96d6-a4d79a635b6b
ObjectCategory                   : domain.local/Configuration/Schema/ms-Exch-OAB
ObjectClass                      : {top, msExchOAB}
WhenChanged                      : 20/04/2010 06:12:40
WhenCreated                      : 10/04/2010 11:46:33
WhenChangedUTC                   : 20/04/2010 05:12:40
WhenCreatedUTC                   : 10/04/2010 10:46:33
OrganizationId                   :
OriginatingServer                : CH-DC.domain.local
IsValid                          : True

Open in new window

0
 
MegaNuk3Commented:
hmmm that looks OK too.
How were the mailboxes migrated to E2k10?

Did you try deleting the .OAB files from the client as per post #30812036?
0
 
awilderbeastAuthor Commented:
they where migrated via the below in shell

post: 30808678 i asked where they are and the subject changed to something different, if you tell me where they are ill give it go

thanks
$UserCredentials = Get-Credential
e:\move\Prepare-MoveRequest.ps1 -Identity "user@domainold.local" -RemoteForestDomainController server01.cworks.local -RemoteForestCredential $UserCredentials




$Cred = Get-Credential
New-MoveRequest -Identity "user@domainnew.local" -RemoteLegacy `
  -TargetDatabase "Mailbox Database 0435330091" `
  -RemoteGlobalCatalog "server01.domainold.local" `
  -RemoteCredential $Cred -TargetDeliveryDomain "domainnew.local"

Open in new window

0
 
MegaNuk3Commented:
Post #30812036 says where they are

what OS are your Outlook 2003 clients on? XP?
For XP the OAB files should be located in the %userprofile%\Local Settings\Application Data\Microsoft\Outlook
0
 
awilderbeastAuthor Commented:
yeah XP, the reason i didnt find them before is becuase they dont exist

theres onlt extend-DAT files and outlook-Office Data File
0
 
awilderbeastAuthor Commented:
and the error is 0x8001040F on the outlook 2003 clients says object not found, so it cant find it on the exchagne server?
0
 
MegaNuk3Commented:
Hmmm so it sounds like the Outlook 2003 clients can't see the OAB sitting in the Exchange 2010 PF store or they can't access it.

Do you have an XP/Outlook 2003 machine to test with? Can you do the following:
1.) Close Oulook on the XP machine
2.) make sure outlook.exe does not exist in Task Manger
3.) Open regedit on the XP machine, then export HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles key
4.) Delete the Profiles key from Regedit
5.) re-open Outlook and it will prompt to create a new Outlook profile
6.) try setting up a cached test mailbox with a small amount of inbox items (less to synch to the OST)

Did the OAB download successfully?
0
 
MegaNuk3Commented:
You can re-import the Profiles key to get everything back if you need to
0
 
awilderbeastAuthor Commented:
ok i had a laptop spare which i just setup and created a new account on it

so brand new profile in there, and i deleted that reg key as no profiles are needed

setup with cache
i checked the folder the OAB should be located in and its not there
i tried a send and recieve and it failed again

"an object could not be found"
0
 
awilderbeastAuthor Commented:
if it helps i went to C:\Users\username\Local Settings\Microsoft\Office\Outlook\ of my laptop and all the oab files are in there, its just these pesky 2003 boys! i have a laptop to keep testing with here now though if you have any ideas?
0
 
MegaNuk3Commented:
Just to confirm a few things because I am going to try and replicate this in my lab...
Client is XP Pro SP3? Outlook 2003 SP3?
Is the XP client a member of the same domain as the E2k10 server?

If you are bored have a look a OABInteg, which I have never really used or tested to great extent so I don't know how good it is or how easy it is to use...
http://support.microsoft.com/?id=907792
0
 
awilderbeastAuthor Commented:
client is either XP pro SP3 vista business Sp2 or win7 doesnt matter as long as theres outlook 2003 invloved it doesnt get it

the machines are all members of the same domain yes

ill have a look at that in the morning

cheers
0
 
MegaNuk3Commented:
well, I have managed to get the same error as you on a non domain joined Outlook 2003 client, so I will let you know how I resolve it...
0
 
MegaNuk3Commented:
Do
Get-Mailboxdatabase |ft name,OfflineAddressBook

you will probably find that it is empty
0
 
MegaNuk3Commented:
My non domain joined cached mode Outlook 2003 client now works = F9 and no errors at all.

you may need to tell your "Default Offline Address Book" to update:
EMC-->Organization Configuration-->Mailbox-->"Offline Address book" Tab-->Right click on the Offline Address Book-->Update

0
 
MegaNuk3Commented:
You should then see that the OAB Version 4 has content:
EMC-->Toolbox-->Public Folder Management Console-->System Public Folders-->Offline Address Book-->/o=yourOrg.../cn=Default Offline Address Book and then in the right hand pane right click on "OAB Version 4"-->Properties and "Size(KB)" should no longer be 0
0
 
awilderbeastAuthor Commented:
it worked :D
cant tell you how relieved i am!

so i know how it happed and how to fix it in future can you tell me what the commands mean and what went wrong?

Get-Mailboxdatabase |ft name,OfflineAddressBook - means?
Get-MailboxDatabase | Set-Mailboxdatabase -offlineAddressBook "\Default Offline Address Book" - means?

thanks alot for helping me out :)
0
 
MegaNuk3Commented:
Glad to hear it worked...

Seems Microsoft left a step out when you say that you have Legacy Clients (pre Outlook 2007) because they do not assign the default offline address book to any mailbox stores, therefore the pre Outlook 2007 clients (Outlook 2003 in your case) haven't been assigned an OAB to download, hence the "object not found" error.

Get-Mailboxdatabase |ft name,OfflineAddressBook
= get all the mailbox database info and only show me the name and OfflineAddressBook values

Get-MailboxDatabase | Set-Mailboxdatabase -offlineAddressBook "\Default Offline Address Book"
= get all the Mailbox databases and then set their OfflineAddressBook values to "\Default Offline Address Book"

So effectively we have told all the mailbox databases that they must use the "\Default Offline Address Book" for legacy cached mode clients.
0
 
MegaNuk3Commented:
Are you still having issues creating Public folders? If so, do you want to open a new question (so I can get more points ;-)   )  ?
0
 
awilderbeastAuthor Commented:
Thanks alot! :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.