Joomla template display problem in IE8

My web page displays properly in Firefox, but not in IE8.  One of the divs in the main body seems to be pushing the other div that should be beside it to the bottom of the page.

Please see www.agro-k.com
mycomacAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cataleptic_stateCommented:
In the CSS you need to clear your floats properly
and check the width of both left and right columns, if there is no width add one.
0
HicanCommented:
Remove width: 25% from the CSS part listed below. The width does nothing, since it is set on an 'empty' div, though in IE the width gets applied and there is no room for a 25% div (there actually is only 6px left, because content and art-bar2 are 900px width and the container is 906px width).

Hope this helps. So remove width: 25% from this part:

/* begin LayoutCell */
.art-contentLayout .art-sidebar1
{
	position: relative;
	margin: 0;
	padding: 0;
	border: 0;
	float: left;
	overflow: hidden;
	width: 25%;
}

Open in new window

0
mycomacAuthor Commented:
I can see the problem is related to the 3 divs that make up the main body of the page - art-sidebar1, art-content, art-sidebar2.

It seems that the problem is that if art-sidebar1 is empty, like on the home page, it still sizes to 25%, forcing art-sidebar2 below the page content.  If I remove the 25% width, it sizes correctly but causes another problem.

On the Contacts page, art-sidebar1 is populated, so if I
0
mycomacAuthor Commented:
I got it figured out.  Removing the 25% does not work - that messes up the formatting on pages where there is content in art-sidebar1.

The solution was to change the parameter in the css for sidebar1 from "width" to "max-width".

That solves the display problem on the Home page and displays correctly on the Contact page
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.