Periodic Drops on VPN Connection

I would like to know if anyone has been able to get a site to site, ipsec based, VPN working without random periodic drops using AT&T/Bellsouth with a single static or dynamic WAN addresses?  I can get a VPN connection to work, but after period of time (15-60 minutes) the VPN connection drops and even though the VPN light on the router remains lit, the VPN connection is dead.  Power cycling the 851 will bring the VPN back to life….for another 15-60 minutes.

I run a similar router config file for Charter cable and Windstream DSL dynamic addressing and they work fine.  I have tried this setup in multiple locations to eliminate the possibility of line issues…without success.  I can’t figure out what is different about AT&T and their techs have no clue.  It’s almost as if AT&T is doing something to reset the connection every “x” number of minutes.  VPN connections are perfect on AT&T if I use a “block” of static IP’s.  No drops or resets.  Naturally, that requires using their more expensive business service…  :-(

Here is the basic config…
Westell or Nettopia DSL modem set to bridge mode.  The DSL Modem handles the PPPoe connection and authentication.
Cisco 851 Router handles everything else…internal 192.168.x.x network, ipsec  site to site VPN connection to Cisco ASA 5510.

If anyone has a similar config working on AT&T/Bellsouth, I love to hear about it.  Any thoughts or suggestions appreciated…
IsaacWeathersAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brain2000Commented:
What's the cisco config look like?  Maybe something as easy having a keep alive, or dead peer detection enabled, will keep the vpn open.
alewis9777Commented:
If your config does not already contain crypto isakmp keepalive command you could add this to send DPD (Dead peer detection) messages to the remote site.

One other thing to check is since your DSL modem is handling the pppoe authentication make sure its set to always on connection and not on-demand or that it does not have an idle timeout.

A link to the crypto isakmp keepalive command is below:

http://www.cisco.com/en/US/docs/ios/security/command/reference/sec_c4.html#wp1057298

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
IsaacWeathersAuthor Commented:
Thanks for the responses.

The DSL modem is set to always on.  When the VPN drops I can still ping the WAN IP address (bridged DSL modem).

A question to confirm...the keep alive is run from the ASA side, correct?  Sorry, but I'm not a CCNA or Cisco rocket scientist...  :-)

Are You Protected from Q3's Internet Threats?

Every quarter, WatchGuard's Threat Lab releases a security report that analyzes the top threat trends impacting companies around the world. For Q3, we saw that 6.8% of the top 100K websites use insecure SSL protocols. Read the full report to start protecting your business today!

Brain2000Commented:
The keep alive would be configured on either or both sides.  I would add it on the Cisco 851 side.  alewis9777 has the correct link how to set up the keepalive.

Before you set up the keepalive, try this.  Take a computer on one side, and set up a constant ping across the VPN  i.e. "ping -t 192.168.0.1".  Let the ping run for an hour.  Is the VPN still up?  This is to test if the VPN drops if there isn't any traffic for a period of time.
IsaacWeathersAuthor Commented:
Ignore my previous question...found the answer.  The keepalive settings are set on the ASA to monitor keepalives and set to default values...Confidence Interval=10 seconds, Retry Interval=2 seconds.

IsaacWeathersAuthor Commented:
Sorry Brain, I replied before I refreshed my browser...I will try your suggestion...

Thanks.
IsaacWeathersAuthor Commented:
Thanks guys.  The keepalive setting on the remote 851 seems to have solved the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.