A:hover buggy in Internet Explorer 8 (But only on some machines)

Hi, I've been working on a small site and I've been having trouble with my Navigation menu. I'm using a hidden <div> that is made visible when a user hovers their mouse over the main navigation bar. When the user the hovers over each of the options, they are supposed to change their background color and text color.

This works fine in Firefox, Internet Explorer 7 and Internet Explorer 8 on some machines. However, on two machines I've used (one which just got a fresh install to Internet Explorer 8 this morning) the first item highlights but then when the user puts their mouse over other options, the first option simple remains highlighted.

The site is available at: http://beta.iugls.org/iugls_new/default.aspx

Any help would be appreciated. Does Internet Explorer 8 cause this problem when you're using my test site?
LVL 1
vartyjAsked:
Who is Participating?
 
rbudjConnect With a Mentor Commented:
The first thing I would do is validate the page.  You have 17 CSS errors.  I have tested and in firefox the menu is functioning properly and IE8 is not.  Here is the validator: http://jigsaw.w3.org/css-validator/

Firefox may be more forgiving of CSS errors than IE8.  Fix the errors and try it again.
0
 
vartyjAuthor Commented:
Oh wow I validated HTML but was trying to move ahead too quickly and completely forgot CSS. I'll do that then let you know how it goes. Thanks!
0
 
vartyjAuthor Commented:
Haha, that was exactly it. Looks like the opacity was giving Internet Explorer 8 a whole mess of problems.
I feel stupid for not having at least tried validation first. Thanks though.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.