"Log on using Dial-Up Networking" not available on a Windows XP domain computer

I have a computer running Windows XP that is a member of a domain. I need to be able to logon to the domain via VPN using the "Log on using Dial-Up Networking" option, but it is not available. I have created a VPN connection to the site and tested that it works; I know that it works because this is how I joined the computer to the domain. When I click the "Options" button on the logon screen, there is no "Log on using Dial-Up Networking" checkbox or text. I even tried starting the VPN connection by creating a service to automatically connect, but this does not help.

I really need to be able to log into this computer as a domain user, which I cannot currently do. Any advice would be greatly appreciated.

James
LVL 3
Jm_saundersAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jm_saundersAuthor Commented:
I found a way around the problem. Starting any application using the "Run-as" option and using the credentials of a domain user apparently caches those credentials, so that you can then logon as that user. Once this is done, you can then establish a VPN connection.

It still doesn't solve the issue of the missing "Log on using Dial-Up Networking" option, but at least I can do what I need to now.

James
Netman66Commented:
This article may apply to you:

http://support.microsoft.com/kb/231426

Did you create this connection for only yourself?  You need to do it as local Admin and set it for all users.
Jm_saundersAuthor Commented:
I've got the computer for another day, so I'll leave this question open in case anybody has a solution for the missing "Log on using Dial-Up Networking" option.
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Jm_saundersAuthor Commented:
Thank you, Netman66. I have already seen that article and it did not help; the VPN connection was created as a local administrator and is set for all users, I am 100% sure of this.
Netman66Commented:
Please export and post the content of the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon

Netman66Commented:
Is this a domain-joined pc?  You won't see it on a non-domain-joined pc.
Jm_saundersAuthor Commented:
The entire key is 429 lines, do you need it all?
Jm_saundersAuthor Commented:
Netman66: The first line of my question is; "I have a computer running Windows XP that is a member of a domain" :)
Netman66Commented:
Ha!  I missed that completely!  

I see the option on our domain PCs, I wanted to compare registry keys to see where the differences are.

You can post the file as an attachment.  If there is any private info in the keys, simply replace it with a dummy value.

Jm_saundersAuthor Commented:
I have attached the requested registry key.

James
WinLogon.txt
micalkinCommented:
I see that you don't have the registry value that is talked about in this article: http://www.pctools.com/guides/registry/detail/794/
You might want to try adding the registry key in with a value to 0 and see if the option then shows up.
Netman66Commented:
I don't see anything there that stands out as being the issue.  It's pretty much the same.

You could try this:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon

New string value = RASDisable
Type: REG_SZ
Value: Decimal 0

Reboot.

If that doesn't work, then unjoin the PC from the domain, reboot and rejoin it.

Advise.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jm_saundersAuthor Commented:
I no longer have access to the computer to check this, but I assume that it'll resolve the issue. I've split the points this way as you both provided the correct answer, and Netman66 spent more time on this.

I hope that's okay.

James
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.