you must have write privileges in the registry for this device in order to modify the device's advanced settings

I'm having an issue getting permissions to modify advanced settings for Com1. From the administrative account, I go to Device Manager -> Ports (COM & LPT) -> Communications Port (COM1) -> Port Settings -> Advanced and when I click advanced I get the error message "you must have write privileges in the registry for this device in order to modify the device's advanced settings". I'm running Windows XP SP2 and i'm logged in with the administrator account.
Please help!
LVL 1
ciphronAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slam69Commented:
common issue with com potr, disable your anti virus solution and try again
slam69Commented:
if that doesnt work yu may need to repermission some reg keys but shoudlnt be that take a look here

http://forums.pcpitstop.com/lofiversion/index.php/t130918.html
johnb6767Commented:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ACPI\PNP0501\5&381fcc12&0

Try granting full rights to this subkey, for your user....

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

johnb6767Commented:
BTW, should be a standard key name, but to verify, the DeviceDesc value is "Communications Port"

ciphronAuthor Commented:
slam, i tried that and it still didn't work

john, your solution worked great!

Thank you both for your help
johnb6767Commented:
FYI, I found this using Process Monitor from Sysinternals. It would be a good thing for you to familiarize yourself with thier apps. It can make your life so much easier.....   :)

Glad youre fixed though...  :)
slam69Commented:
just to cement that from john its a really good piece of investigative kit to find out whats involved with each internal process
ciphronAuthor Commented:
i've just downloaded it and i'm a bit lost - how did you find out which key was associated with trying to change the COM1 settings?
johnb6767Commented:
yOU NEED TO PLAY WITH THE FILTERS TO FIND WHAT YOU ARE LOOKING FOR. Sorry Caps....

In  this case we were looking for permissions, so we set the filter to include a result, which was Access Denied. Then we went to try and reproduce it.....

In my case, I knew I was working for a registry value, so I used the Operation, is , RegSetValue. That way it only showed processes that were writing reg values. Since it was from teh device manager, it was rundll32.exe.....

You just need to play with them, and use the help feature.....
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.