Repeating Table in infopath not showing data when submitted to sharepoint library

I have a form which has a repeating table, this table is then populated with data and submitted to a sharepoint forms library, when I re-open the form in sharepoint the repeating table data is no longer present. why is this and how do I fix it?

InfoPath 2007
Using Forms Services Browser Form
MOSS2007 Enterprise
LVL 2
nemesis1210Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Clay FoxDirector of Business IntegrationCommented:
i am guessing you are not saving the data within the form itself.  Where is the repeating data coming from? Is it an external source?
If you want data to persist you have to save it in the main data source in the form.
Or it is getting overwritten and requeried when you open it the second time is another possibility.
You can open the xml file in Notepad and check for the raw data to see if it is there.
Sometimes people are trying to promote data to SharePoint, which SP is a flat structure by design and you cannot have repeating elements displayed  in the form library list view.

Hope that helps
0
nemesis1210Author Commented:
no promotion, table in main datasource and nothing in the XML for those fields
0
Clay FoxDirector of Business IntegrationCommented:
So when you submit you see the data in the form, the xml file date modified updates, other data shows changes but not the repeating elements correct?

Are you using a save or a submit?
0
nemesis1210Author Commented:
never mind I spent two hours getting frustrated with this and then realized I am an idiot, I need a big note on my wall "Rules before Code!!!" i was submitting the form to sharepoint then the code runs which populates the repeating table...DUH

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Clay FoxDirector of Business IntegrationCommented:
Yah that can get you.

Did not know your submit process or I could have helped better.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
InfoPath

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.