Windows 7 Logon Script Fails

Windows 2003 R2 Standard Dc sp2 server

file logon.cmd works on my vista win xp and on my old win 7 pc

just got this replacement pc from dell
windows 7 pro 64 bit

I can logon and access the network resources

my logon.cmd does not run

All it does is maps my home directory

I have it set up in the users profiles I do not use group policy

If that would be better to do please give me an example I tried to find it in the group policy but could not

Thanks
InserachofAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ks_adminCommented:
If you type:

net use x: \\servername\sharename

from a command prompt, does it map the drive properly?  

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
InserachofAuthor Commented:
no i get system error 85 has occurred

the local device name  is already in use

i did this net use h: \\nas200_ec55c6\users
0
ks_adminCommented:
Have you tried copying the logon.cmd script to your computer, and edit it to add a PAUSE statement to the end of it.

Then run it manually, and tell us what errors come out of it?


ks_admin
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

InserachofAuthor Commented:
update

just did net use x:\\nas200_ec55c6\users  and it worked

can not do H:  ???????

I only have 1 internal drive     C

2 cd drives     D  and E

wonder what is doing this
0
ks_adminCommented:
If you go into Disk Management and look, are you sure there's nothing else using H: ?


Or, if you go to dos prompt and type in just NET USE  does it say there's anything mapped to H: ?

0
Hypercat (Deb)Commented:
Is your home directory mapped to H:?  That would cause the behavior you described.
If you make a copy of the logon.cmd file and put it on your desktop, does it run? Are you logging on to this computer with an account that has local admin privileges? Both Vista and Win7 have issues running the login script in that situation.
0
Hypercat (Deb)Commented:
If you are using your login script primarily to map drives, you could use group policy Preferences instead.  On your Win7 machine, or a Windows 2008 server that is managing your group policies, go to: Users Configuration/Preferences/Windows Settings/Drive Maps. Right-click, go New/Drive Map and add your drive mapping(s) there.
0
InserachofAuthor Commented:
found tht i plugged in a jump drive to test something and it assigned the H drive as a removeable drive

after I reassigned the drive letter the logon.cmd script worked
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.