• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1346
  • Last Modified:

FTP ls, get, put etc just hang using ftp.exe from a command line

Hi,

I'm trying to automate (using VB - but that's not too important right now) the upload and download of a single file, and I'm not having much joy.

I can get to the FTP space from seemingly any GUI client, and drag/drop/transfer until the cows come home, but I can't do it from a command line.

So far, I've tried logging on, this is all ok.

I can change to a directory, this is successful.

If I try to list a directory's contents, or issue a 'get' command on a file, I just get:

"150 Opening ASCII mode data connection for file list"

This seemingly hangs until I interrupt it. I've tried entering passive mode as soon as I log on (no difference) I've tried Binary mode to no avail (the file is a CSV), I've removed any firewall from the equation, and I've tried three different connections.

Either way, I can do it with an FTP client, just not through the command line interface. Code to show exactly what I'm doing attached.

I've even tried different FTP sites - no joy. I'm running windows 7.

Thanks for any pointers, I hope it's simple!
ftp open myhost.com 2121
myusername
mypassword
literal pasv
debug
cd myftpdir
lcd mylocaldir
get myftpfile.csv

Open in new window

0
jjnet123
Asked:
jjnet123
1 Solution
 
jjnet123Author Commented:
D'oh - windows firewall.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now