IIS Remote Management

Greetings Experts!

I am trying to set up remote managment of IIS 7 on a Win2008 web server that is behind a Win2003 firewall server. I have installed IIS Management Service on the server & the manager console on my Win7 PC, and created a VPN to the firewall. I created a local windows user account on the web server (as there is no active directory) for the IIS client management console to use for connection credentials, and I also created an IIS Manager User account as I have set up the Management Service to accept both Windows & IIS credentials and gave the IIS Manager User permissions to all the sites.

The issue is that I am only able to connect to the web server from the client manager console if the local windows user on the web server has admin rights. For some reason, the IIS user credentials are not accepted. What am I missing? I need the ability to manage IIS remotely without using a local server admin account.
LVL 1
ipremiseAsked:
Who is Participating?
 
Brad HoweDevOps ManagerCommented:
Hi,

You have two options here: Windows User/Group, or IIS 7.0 Manager user.  Both have there purposes.

Take a read at this article. It might help.

http://learn.iis.net/page.aspx/155/an-overview-of-feature-delegation-in-iis-70/

IIS Manager – Creating Site and Application Administrators  
IIS Manager – Enabling Site and Application Administrators to Connect

This should be pretty straight forward. Mentioning the firewall doesn't really impact it IF you can connect with an Admin account from the client to the sever.

Let me know,

Cheers,
Hades666
0
 
ipremiseAuthor Commented:
Thanks so much! The problem was the "IP Address" setting under "Connection" options for Management Service on the server -- I had it set to the local server address. And maybe also because I was choosing to connect to as server instead of a site (in the manager console).

I had used those settings as I was following a different walk-through:
http://www.trainsignaltraining.com/iis-7-remote-administration/2008-06-11/
FYI

Cheers!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.