0X8004010F, Offline address book problems error continues

followed various answers and can not dowload oab
drewn1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
What version of Exchange are you using?
0
ashishkpandeyCommented:
The issue will continue. You need to export the mailbox into PST. Disable the mailbox. Create a new mailbox. Import back the PST and join the new mailbox back to the user
0
ComputerBeastCommented:
You need to repair the offline address book. Go here for repairing - http://www.nucleustechnologies.com/exchange-ost-recovery.html
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

drewn1Author Commented:
Exchange 2007 on indows server 2003.
0
Alan HardistyCo-OwnerCommented:
Have you setup Autodiscover in your Domain Name's DNS records (not internal DNS)?
You need to add an A record called Autodiscover pointing to the IP address of your server.
0
drewn1Author Commented:
how do i setup auto discovery,
exchange-2007-autodiscovery-fail.bmp
0
drewn1Author Commented:
alan, this machine is on the vpn and not using outlook anywhere. administrator access on the vpn
0
Alan HardistyCo-OwnerCommented:
It makes no difference how you connect - in Outlook 2007 the OAB is downlaoded via Autodiscover.
You need to add an A record in your DOmain's DNS records - call it Autodiscover and add the IP address of your server as the detail.
0
drewn1Author Commented:
can you give me an example for my domain.
0
drewn1Author Commented:
i added the following to my internal dns. restarted outlook and continue to have error
exchange-2007--dns-autodiscover.bmp
0
drewn1Author Commented:
created the dns record as shown below, can ping autodiscoover correctly; attached is get-outlook provider., can you provide exact comand line ?
Create the AutoDiscover DNS Record
- Open the DNS Manager.
- Expand Forward Lookup Zones then expand domain.com
- Now right-click domain.com then select New Host(A)
- Type autodiscover and the IP Address of the E2K7 server, then click Add
- Click OK to close the dialog box then click Done.
- Close the DNS Manager.

Configure Exchange 2007 Server
- Switch to the e2k7 server.
- Open the Exchange Management Shell
- At the command prompt, type Set-OutlookProvider –id exch –ssl:$true then press Enter.
- Now type Set-OutlookProvider –id exch –server:servername and then press Enter.


exch-2007-shell-oulook-provider.bmp
0
Alan HardistyCo-OwnerCommented:
This article should assist on the Exchange side:
http://technet.microsoft.com/en-us/library/bb201695.aspx 
0
Alan HardistyCo-OwnerCommented:
0
drewn1Author Commented:
alan, followed the exch 2007 specific, was already setup. attached is exch shell
exch2007-shell-autodiscovery-set.bmp
0
drewn1Author Commented:
when i go to ie with https://192.168.0.2/autodiscover/autodiscoverxml i get a certificate error, navigation blocked. could this be the issue?
0
Alan HardistyCo-OwnerCommented:
You will because the cert does not contain an IP address.
Try the FQDN in the URL e.g., https://ext.nassaucandy.com/autodiscover/autodiscover.xml
0
Alan HardistyCo-OwnerCommented:
It also looks like your certificate is not a SAN / UCC certificate (multi-name), which it needs to be.
You will need to change it (buy a new one) with the following names:
ext.nassaucandy.com
autodiscover.nassaucandy.com
internalservername.internaldomain.local
internalservername
Obviously change the internalservername.internaldomain.local and internalservername to match your environment.
0
drewn1Author Commented:
the result from https://ext.nassaucandy.com/autodiscover/autodiscover.xml 

asks for login and gives me:

 <?xml version="1.0" encoding="utf-8" ?>
- <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
- <Response>
- <Error Time="09:48:07.0471624" Id="2072397835">
  <ErrorCode>600</ErrorCode>
  <Message>Invalid Request</Message>
  <DebugData />
  </Error>
  </Response>
  </Autodiscover>
0
drewn1Author Commented:
already have ssl cert for ext.nassaucandy.com, do i need to purchase for the following 3, or just autodiscover , any way around purchasing a new cert., user is connected through vpn and needs gal when working off line.
0
Alan HardistyCo-OwnerCommented:
Your certificate does not allow Subject Alternative Names (SAN) and thus won't work with Exchange 2007.
It would work fine with Exchange 2003, but 2007 is a different beast.
As per the following MS article (check the limitations section), you have no choice but to buy a SAN certificate.
http://technet.microsoft.com/en-us/library/bb851554(EXCHG.80).aspx 
0
Alan HardistyCo-OwnerCommented:
Cheapest place to buy one is probably GoDaddy - www.godaddy.com
0
drewn1Author Commented:
would the certs be for the following:
the server name is ncex07.n1.nassaucandy.com

ext.nassaucandy.com
autodiscover.nassaucandy.com >    autodiscover.nassaucandy.com
internalservername.internaldomain.local  >        ncex07.n1.local
internalservername >       ncexo7
0
drewn1Author Commented:
correction :
internalservername >       ncex07
0
Alan HardistyCo-OwnerCommented:
Yes - that's what you need.
0
drewn1Author Commented:
0
Alan HardistyCo-OwnerCommented:
Not that I am aware of.
0
drewn1Author Commented:
what about this:

Method 2: Http Referral

This option allows us to redirect the client to another URL for Autodiscover. The major downside of this configuration is that users are prompted in Outlook to confirm this redirection. There is a check box on the prompt to not get prompted again for this URL to limit the impact for users.

To implement this configuration we still have to use two IP addresses and two virtual servers; but we only need one certificate.

Here is an outline of this setup process:

Create a new virtual server on the CAS server with a new IP
Create a stub Autodiscover virtual directory and Autodiscover.xml file thru IIS
Redirect the Autodiscover.xml file to mail.company.com
Configure your internal SCP to point to mail.company.com
Configure your Internal and External Service URLs to point to mail.company.com
Make sure that your configured URLs will resolve via DNS to the expected IP address of the CAS server
In this configuration, domain member clients get the SCP and connect using that URL to the Autodiscover service. External clients connect to Autodiscover.company.com over http and get a referral to mail.company.com. The external Outlook clients are prompted the first time they make this connection to verify they are being redirected to a trusted URL; once that is accepted Outlook connects to the mail.company.com for Autodiscover.
0
drewn1Author Commented:
alan:
in reference to your post:
Have you setup Autodiscover in your Domain Name's DNS records (not internal DNS)?

You need to add an A record called Autodiscover pointing to the IP address of your server.


should autodiscover external point to my mail.nassaucandy.com or ext.nassaucandy.com (used for OWA)?
0
drewn1Author Commented:
alan,
do i require the foloowing cert ?
internalservername.internaldomain.local  >        ncex07.n1.local
internalservername >       ncexo7
0
Alan HardistyCo-OwnerCommented:
Autodiscover should be an A record and A records need to point to an IP Address
Your certificate should show the following names:
ext.nassaucandy.com
autodiscover.nassaucandy.com
ncex07.n1.local
ncexo7
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
drewn1Author Commented:
thanks, i just ordered a godaddy cert

i currently have a verisign cert for ext.nassaucandy.com, do i need to replace?
0
drewn1Author Commented:
Alan is awesome, alan guided , pointed and pushed me to the solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.