Sharepoint default page not working (fresh install)

Just installed sharepoint 2007 64-bit (default values), and am already having issues. Only thing I seem to be able to get are HTTP 404 errors. After completing install, I had to go into IIS and modify assigned IP for "default web site" to be IP address of server (it was stopped and could not run simlutaneously with SharePoint - 80 site under IIS).

I have tried using various attempts to connect. Seems that using "http://ipaddress/default.aspx" gets the login screen to appear, but after that, the same HTTP 404 error.

If anyone needs screen shots, please let me know and I will attach them, otherwise, I'm utterly baffled as to why a default install won't work for this :(

Thanks in advance

Francis
francoisxiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

trax75Commented:
Hi,

normaly sharepont is not running under the default web site.

Take a look at the application pools in your IIS - > I should have some with SharePoint in the name. Look which WebSites belongs to them. The first WebSite you got is the Central Administration site.

Just to be sure: Did you start the Technology Wizards, after the SahrePoint File Installation?

cu
torsten
0
francoisxiAuthor Commented:
Hi torsten,

Yes I did start the technology wizard and after it completed and attempted to pull up the page, it displayed an HTTP 404 error. There is a SharePoint -80 in the IIS pool which is enabled. Should I leave "default web site" stopped?

Thanks

Francis
0
trax75Commented:
It's ok when the default WebSite is stopped.

Have a closer look at the SharePoint IIS AppPool -> you can open a list of the sites using this AppPool.
Or just go to the WebSite and look at the Setting (IIS7-> Basic Setting, IIS6 the HomeDirectory Tab(not sure)) -> there you see the AppPool the Site is using.

Find out which is the right SharePoint WebSite and have a look at the URL under which the site will be delivered.

cu
Torsten
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

francoisxiAuthor Commented:
HI torsten,

Not sure what you're asking. I went to home directory under "sharepoint - 80" site (right click, properties) and under "application protection" it is showing "medium (pooled)". The local path for the directory is showing:

C:\Inetpub\wwwroot\wss\VirtualDirectories\80

I have included a snapshot if it helps.. hopefully I'm in the right place

Thanks!
sharepoint80.jpg
0
florimitCommented:
When you run the Configuration Wizard and it complete, it should bring up the Central Admin Portal. This should not be on port 80 so check you IIS config there should be a website call SharePoint Central admin, or something similar.Once you identify the port it is using, the address will be http://ip Address:Port

The reason you are not seeing anything on port 80 is because you have to create an initial site collection from the Central Admin portal. By default, this will be on port 80, which is why the Default Site in the IIS Server is stopped. You are getting prompted for credentials because there is an empty placeholder from SharePoint, which is the ...\VirtualDirectories\80 folder you show above. Create the initial site collection and then after you are prompted for credentials, you will actually go somewhere.

Hope that helps!
0
francoisxiAuthor Commented:
Hi florimit,

I tried as you suggested, and oddly enough, I still get the credentials popup asking for login; however, i'm still getting the HTTP 404 error. It just doesn't seem to pull up even after I correctly type in the credentials.

Not sure what to do from here :(

Thanks!

Francis
0
francoisxiAuthor Commented:
If it helps, here's part of what I get for logfiles..

2010-04-19 02:45:53 W3SVC566271483 172.16.45.10 POST /_vti_bin/sitedata.asmx - 42862 NT+AUTHORITY\LOCAL+SERVICE 172.16.45.10 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.3603) 404 2 1260
2010-04-19 02:50:53 W3SVC566271483 172.16.45.10 POST /_vti_bin/sitedata.asmx - 42862 - 172.16.45.10 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.3603) 401 2 2148074254
2010-04-19 02:50:53 W3SVC566271483 172.16.45.10 POST /_vti_bin/sitedata.asmx - 42862 - 172.16.45.10 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.3603) 401 1 0
0
trax75Commented:
Hi,

OK, you running SharePoint on a Windows Server 2008; so you have to Disable the Loopback Check - this is a security "feature" preventing the authentication on the server.

To set the DisableLoopbackCheck registry key yourself, follow these steps:

- In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
- Right-click Lsa, point to New, and then click DWORD Value.
- Type DisableLoopbackCheck, and then press ENTER.
- Right-click DisableLoopbackCheck, and then click Modify.
- In the Value data box, type 1, and then click OK.
- Quit Registry Editor, and then restart your computer.

cu
Torsten
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
irinucCommented:
Hi,

This may not be the issue, but maybe it helps.
If your firewall is on, you need to add inbound/outbound rules for the port where SSP is running. (at least this is what I missed and got a similar error).
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/MS-SharePoint/Q_25590042.html

Hope this helps.
0
irinucCommented:
And not just SSP, but also Central Admin and the main application.
0
francoisxiAuthor Commented:
HI Torsten,

I'm running this on server 2003, and applied that check, but that didn't seem to fix the issue.

Irinuc, windows firewall isn't turned on, but I am using a cisco firewall. Would that affect this as well?
0
francoisxiAuthor Commented:
Hi folks,

I've decided to wait until we upgraded to Server 2008 / VMware environment. Thanks for everyone's help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.