Exchange 2010 Can't Receive Email

I recently installed Exchange 2010(all roles on one server) on a 2008 R2 server.  Upon initial install, I was able to bind to port 25 and issue:

mail from:<some external email>

and receive Sendor OK.  I also, via static DNS entries, send and received email just fine.  Now, 3 days later when I am ready to change the DNS, no matter what from recipient I use I get the following error from the exchange smtp service:

530 5.7.1 Client was not authenticated

Undoubtedly, it will be recommended I make sure Anonymous is checked on the inbound receive connector.  It is definitely checked.

This is on a Vsphere ESX server with all the appropriate specs outlined by Microsoft on the virtual server.

The firewall is a Cisco ASA 5505 and I have disabled any SMTP inspection.  The firewall is plugged directly into the same L3 core switch the ESX server is, and there is no ACL or upper layer protocol voodoo enabled.

I have poured through as much documentation and forums as I can, and I can't seem to find anyone else with this issue if they have Anonymous checked.

Any help would be greatly appreciated as I simply can't figure it out!!!
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Open ESM -> server config -> Hub transport

find your server and select it then in the lower hand side look for the "DEFAULT receive connector"

double click on it go to permission tab and check anonymous

Actually check ALL the connectors under server coniguration > hub transport > receive connectors, not just the default one and allow anonymous access. You might be surprized by which one of the receive connectors actually is active here!

Do NOT touch any other connector other than the Default one. if you configuration is not messed up with no need to mess it up yourself

just edit the Default receive connector again DO NOT change the client connector
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

pgp4privacyAuthor Commented:
Anonymous is definitely checked on the default connector.
If anonymous is checked there is no way to get "530 5.7.1 Client was not authenticated"

please run get-receiveconnector | fl from powershell and give us the results
pgp4privacyAuthor Commented:
I totally agree with you which is why it perplexed me enough to post here.  Here is the output of that command for the Default receive connector, as you can see AnonymousUsers group is added:

RunspaceId                              : 62b6272e-9007-4d4a-aa2c-979705cf42ed
AuthMechanism                           : Tls, Integrated, BasicAuth, BasicAuthRequireTLS, ExchangeServer
Banner                                  :
BinaryMimeEnabled                       : True
Bindings                                : {}
ChunkingEnabled                         : True
DefaultDomain                           :
DeliveryStatusNotific<domain>onEnabled       : True
EightBitMimeEnabled                     : True
DomainSecureEnabled                     : False
EnhancedStatusCodesEnabled              : True
LongAddressesEnabled                    : False
OrarEnabled                             : False
SuppressXAnonymousTls                   : False
AdvertiseClientSettings                 : False
Fqdn                                    : <internal AD FQDN>
Comment                                 :
Enabled                                 : True
ConnectionTimeout                       : 00:10:00
ConnectionInactivityTimeout             : 00:05:00
MessageRateLimit                        : unlimited
MessageRateSource                       : IPAddress
MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : unlimited
MaxInboundConnectionPercentagePerSource : 100
MaxHeaderSize                           : 64 KB (65,536 bytes)
MaxHopCount                             : 30
MaxLocalHopCount                        : 8
MaxLogonFailures                        : 3
MaxMessageSize                          : 10 MB (10,485,760 bytes)
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 5000
PermissionGroups                        : AnonymousUsers, ExchangeUsers, ExchangeServers, ExchangeLegacyServers
PipeliningEnabled                       : True
ProtocolLoggingLevel                    : Verbose
RemoteIPRanges                          : {}
RequireEHLODomain                       : False
RequireTLS                              : False
EnableAuthGSSAPI                        : False
LiveCredentialEnabled                   : False
Server                                  : <internal AD FQDN>
SizeEnabled                             : EnabledWithoutValue
TarpitInterval                          : 00:00:05
MaxAcknowledgementDelay                 : 00:00:30
AdminDisplayName                        :
ExchangeVersion                         : 0.1 (8.0.535.0)
Name                                    : Default <internal AD FQDN>
DistinguishedName                       : CN=Default <internal AD FQDN>,CN=SMTP Receive Connectors,CN=Protocols,CN=<internal AD FQDN>,C
                                          N=Servers,CN=Exchange Administr<domain>ve Group (FYDIBOHF23SPDLT),CN=Administr<domain>v
                                          e Groups,CN=First Organiz<domain>on,CN=Microsoft Exchange,CN=Services,CN=Configura
Identity                                : <internal AD FQDN>\Default <internal AD FQDN>
Guid                                    : 98d96941-14d9-4a11-ab09-5824729db6ae
ObjectCategory                          : <domain>.local/Configur<domain>on/Schema/ms-Exch-Smtp-Receive-Connector
ObjectClass                             : {top, msExchSmtpReceiveConnector}
WhenChanged                             : 4/15/2010 6:36:17 PM
WhenCreated                             : 4/12/2010 10:59:43 AM
WhenChangedUTC                          : 4/15/2010 11:36:17 PM
WhenCreatedUTC                          : 4/12/2010 3:59:43 PM
Organiz<domain>onId                          :
Origin<domain>ngServer                       : <domain>-ad01.<domain>.local
IsValid                                 : True
Are there any other receive connectors defined exepct the Default and the client connector?
We had a case where a client had a special receive connector defined for a fax appliance but that one (instead of the default connector) actually took all the traffic and needed to have anonymous to be checked.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pgp4privacyAuthor Commented:

I have a receive connector for our Kaseya server to send mail out.  It is restricted to that specific IP address and it never even crossed my mind to check this!!!

I am truly appreciative for your insight on this as it was driving me crazy.  

I have done many 2003 and 2007 installs, and this is my second 2010 install and just never thought about this.

Thank you!!!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.