Mailing problems with Plesk 9.3

Hi,

I am currently having some strange problems when some of my webhosting clients are trying to send mail out. Their outlook cleints are configured to send mail out via their webhosting over SMTP. However sometimes the mail is never delivered despite them never receiveing any bounce backs.
I was made aware of this problem because no one can send email to me! I myself dont use the webhosting for my mail as i run my own exchange.

PHPmail also doesnt not work at all anymore, so people who have this type of script in form mails in there webpage no longer work. Webmail no longer sends mail out either.

Im not sure if this is relevant but i upgraded my php, mysql, and @mail using the art repos. I heard there was none issues with this after installation. Could this be the cause of the problem

I copied this out of the running qmail log when i sent an email to myself. Any help would be great!

Apr 16 10:24:47 user1 postfix/smtpd[14127]: NOQUEUE: client=unknown[203.161.69.222]
Apr 16 10:24:47 user1 postfix/smtpd[21576]: 904C8DB38438: client=unknown[203.161.69.222]
Apr 16 18:24:47 user1 before-remote[28241]: check handlers for addr: test@fromdomain.com.au
Apr 16 18:24:47 user1 before-remote[28241]: check handlers for addr: nathan@todomain.com.au
Apr 16 18:24:47 user1 before-queue[28239]: check handlers for addr: test@fromdomain.com.au
Apr 16 18:24:47 user1 before-queue[28239]: check handlers for addr: nathan@todomain.com.au
Apr 16 18:24:48 user1 postfix/cleanup[21585]: 904C8DB38438: message-id=<000901cadd4f$1926f9a0$4b74ece0$@com.au>
Apr 16 18:24:48 user1 postfix/qmgr[13775]: 904C8DB38438: from=<test@fromdomain.com.au>, size=2946, nrcpt=1 (queue active)
Apr 16 10:24:48 user1 postfix/smtpd[21576]: disconnect from unknown[127.0.0.1]
Apr 16 18:24:48 user1 postfix-local[28291]: postfix-local: from=test@fromdomain.com.au, to=nathan@todomain.com.au, dirname=/var/qmail/mailnames
Apr 16 18:24:48 user1 postfix-local[28291]: hook_dir = '/usr/local/psa/handlers/before-local'
Apr 16 18:24:48 user1 postfix-local[28291]: recipient[3] = 'nathan@todomain.com.au'
Apr 16 18:24:48 user1 postfix-local[28291]: handlers dir = '/usr/local/psa/handlers/before-local/recipient/nathan@todomain.com.au'
Apr 16 18:24:48 user1 postfix/pipe[21946]: 904C8DB38438: to=<Nathan@todomain.com.au>, relay=plesk_virtual, delay=0.92, delays=0.91/0/0/0.01, dsn=2.0.0, status=sent (delivered via plesk_virtual service)
Apr 16 18:24:48 user1 postfix/qmgr[13775]: 904C8DB38438: removed
Apr 16 18:24:49 user1 pop3d: Connection, ip=[203.161.69.222]
Apr 16 18:24:49 user1 pop3d: IMAP connect from @ [203.161.69.222]INFO: LOGIN, user=test@fromdomain.com.au, ip=[203.161.69.222]
Apr 16 18:24:49 user1 pop3d: 1271413489.964979 LOGOUT, user=test@fromdomain.com.au, ip=[203.161.69.222], top=0, retr=962, time=0, rcvd=32, sent=1279, maildir=/var/qmail/mailnames/fromdomain.com.au/test/Maildir
Apr 16 10:24:51 user1 postfix/smtpd[14127]: disconnect from unknown[203.161.69.222]

Thank
LVL 1
fonz23Asked:
Who is Participating?
 
fonz23Author Commented:
Yes telnet was fine,

It was a problem with the configuration. The following article lead me to the solution

http://blog.rapiddg.com/2009/05/the-case-of-the-disappearing-mail/ 

Thanks for you help
0
 
LinuxGuruLinux Server AdministratorCommented:
Hi,

Are you able to telnet to port 25?

telnet localhost 25

Please refer the plesk KB at the following url.

http://kb.parallels.com/en/

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.