IP Phone does not connect to Cisco 877W

When I tried to 7921 IP Phone to Router, but I am unable for that, when i did try to conncet while connecting i saw error on router

Jan 12 18:22:53.733: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0021.27c3.1edc Reason: Previous authentication no longer valid SSID[Melbourne]

Building configuration...

Current configuration : 6261 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cisco877
!
boot-start-marker
boot-end-marker
!
enable password 7 XXXXXXXXXXXXXXXX
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2180976684
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2180976684
 revocation-check none
 rsakeypair TP-self-signed-2180976684
!
!
crypto pki certificate chain TP-self-signed-2180976684
 certificate self-signed 01
  30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32313830 39373636 3834301E 170D3032 30333033 32333535
  32375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31383039
  37363638 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100ACE9 680B5787 B21C0180 90B79055 09E133BD 7538543F C908B72F 95D7BE87
  AE12AF96 D39AA4BA F25EAF7D E439BE05 9B65F5E6 815D38CD 985046F2 E8ADC2D2
  A7B87355 F59A8510 8C4D22A1 9B2B90C5 27AC4A1D 73F21E3D 5536F62E EDD15640
  92BFCF94 ADBDD24A D791F121 2A7ECFD8 E144011D E1177E1F 8C1016B2 7A978EAE
  16750203 010001A3 68306630 0F060355 1D130101 FF040530 030101FF 30130603
  551D1104 0C300A82 08636973 636F3837 37301F06 03551D23 04183016 8014DE57
  2EA8D879 AF8A94F9 D43282DA F032F52B 16B0301D 0603551D 0E041604 14DE572E
  A8D879AF 8A94F9D4 3282DAF0 32F52B16 B0300D06 092A8648 86F70D01 01040500
  03818100 96F35831 3050A2AA 949F9D9F 55EBD8DF E8489B15 222DCB0F B601A4AC
  6776CB12 06E65496 12A22F90 271CD3BD C94AA3DF 994213AD C8E212CB 638B25DD
  E9FB0C53 E8CB06FA 92035D42 6B05A3A2 60056F50 BA25D980 4FC55C32 BE946862
  7F842811 B8CE31AF 83968847 22E342F2 2B068166 8FFD96D1 4A9BF072 4E268C26 4875D9
CB
        quit
dot11 syslog
!
dot11 ssid melbourne
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 XXXXXXXXXXXXXXXX
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.8.1 192.168.8.10
!
ip dhcp pool LAN-POOL
   network 192.168.8.0 255.255.255.0
   default-router 192.168.8.1
   dns-server 192.168.8.1
   lease 0 2
!
!
ip name-server XXXXXXXXXXXXXXXX
ip name-server XXXXXXXXXXXXXXXX
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
username admin password 7 112A160A1B130C09247B72737A
!
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
!
crypto isakmp policy 10
 encr aes 256
 hash md5
 authentication pre-share
 group 5
 lifetime 28800
crypto isakmp key coinopsolutions.com address XXXXXXXXXXXXXXXX
!
!
crypto ipsec transform-set LAB-Transform esp-aes 256 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA1 esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA2 esp-3des esp-sha-hmac
!
!
!
crypto ipsec client ezvpn XXXXXXXXXXXXXXXX
 connect auto
 group EZVPN_GROUP_1 key XXXXXXXXXXXXXXXX
 mode network-extension
 peer XXXXXXXXXXXXXXXX
 username XXXXXXXXXXXXXXXX password XXXXXXXXXXXXXXXX
 xauth userid mode local
!
!
archive
 log config
  hidekeys
!
!
!
bridge irb
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 ip nat inside
 ip virtual-reassembly
 !
 encryption vlan 1 mode ciphers tkip
 !
 ssid melbourne
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 no ip address
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1412
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Dialer0
 mtu 1454
 ip address negotiated
 ip mtu 1452
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp chap refuse
 ppp pap sent-username XXXXXXXXXXXXXXXX password 7 XXXXXXXXXXXXXXXX
38
 crypto ipsec client ezvpn AustraliaVPN
!
interface BVI1
 ip address 192.168.8.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 crypto ipsec client ezvpn AustraliaVPN inside
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 ATM0
ip route 192.168.8.0 255.255.255.0 Dialer0
!
!
ip http server
ip http authentication local
ip http secure-server
ip dns server
ip nat inside source list ToNAT interface Dialer0 overload
!
ip access-list extended ToNAT
 permit ip 192.168.8.0 0.0.0.255 any
ip access-list extended acl_vpn
 permit ip 192.168.8.0 0.0.0.255 192.168.2.0 0.0.0.255
 permit ip 192.168.8.0 0.0.0.255 192.168.4.0 0.0.0.255
!
access-list 40 permit 192.168.2.0 0.0.0.255
access-list 50 permit 192.168.0.0 0.0.255.25
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
access-list 100 permit ip 192.168.2.0 0.0.0.255 any
access-list 100 remark SDM_ACL Category=4
access-list 100 permit icmp 192.168.2.0 0.0.0.255 any
access-list 100 remark SDM_ACL Category=4
access-list 101 permit icmp 192.168.2.0 0.0.0.255 any
access-list 101 remark IPSec Rule
access-list 101 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
access-list 103 remark IPSec Rule
access-list 103 permit ip 192.168.8.0 0.0.1.255 XXXXXXXXXXXXXXXX 0.0.0.63
access-list 104 remark SDM_ACL Category=4
access-list 104 permit gre host 192.168.8.1 host XXXXXXXXXXXXXXXX
dialer-list 1 protocol ip permit
!
!
!
route-map SDM_RMAP_1 permit 1
 match ip address 100
!
!
control-plane
!
bridge 1 route ip
!
line con 0
 password 7 072C2E4342081E003743525B56
 login local
 no modem enable
line aux 0
 password 7 072C2E4342081E003743525B56
 login local
line vty 0 4
 password 7 072C2E4342081E003743525B56
 login local
!
scheduler max-task-time 5000
end

Open in new window

kavinagpurAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

prvnkumarkCommented:
Hi i feel there is some authentication problem. Have u configured your ip phone with correct psk. what u have given in router.
dot11 ssid melbourne
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 XXXXXXXXXXXXXXXX .

Regards,
Praveen
kavinagpurAuthor Commented:
Thanks for reply,

I have given you configuration of Router, can u suggest me as per my running configuration what should i enter on Wi-fi phone because i used to security type WPA & encryption type is TKIP

But I didn't get any success although we have allready running another wi-fi devices on this router & same configuration
kavinagpurAuthor Commented:
Hello Praveen,

can u suggest me as per my configuration which encryption type should i enter on phone?

Thanks
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Pro4iaCommented:
In the 7921 modes, do you see WPA as an option?  I know the earlier 7921s didn't and best bet was to use WEP..
amprantiCommented:
If you disable temporary encryption the problem continiues to appear?

kavinagpurAuthor Commented:
Can u suggest how to disable temporary encryption ?

Thanks
amprantiCommented:
Telnet/ssh to router and type:

conf t
dot11 ssid melbourne
   vlan 1
   authentication open
no    authentication key-management wpa
   guest-mode
no   wpa-psk ascii 7 XXXXXXXXXXXXXXXX

int dot 0
no encryption vlan 1 mode ciphers tkip


Change settings to 7921 and check if the problem remains.

Do you have any other access point in the same place using the same SSID?
kavinagpurAuthor Commented:
Thanks for reply,

we don't have any other access point in the same place using the same SSID.

I am doing try, then i will inform you soon, But this is temporary solution, i can this only for testing
If it will work then I can't keep configuration without encryption, It may be harmful for us.

Thanks
amprantiCommented:
If it work wihout encryption then we can isolate the problem: its a problem with encryption between the two devices.... then will focus on settings
kavinagpurAuthor Commented:
If it work wihout encryption then on which device we will need to focus.
Router or IP Phone
amprantiCommented:
both

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kavinagpurAuthor Commented:
thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.