Unable to Start VMware Host

Hi Experts,

I hope you all can help with this as it has me puzzled.

A user has reported they are no longer able to use VMware server 2.02. Upon firing it up in IE or Firefox a connection cannot be made. Upon review i found the reason being was that the VMware host was not starting and in fact would error upon trying to start with the following error

'Windows could not start the VMware Host Agent on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code -1.'

Upon reviewing the event log i find the following error

'The VMware Host Agent service terminated with service-specific error %%-1.'

A repair installation did not resolve the issue, so i tried removing Vmware and then removing the directory folder as well as the folder in the local profile in app data. I also deleted the registry keys for vmware in local computer and current user' I then re-installed the software, but still the issue is occuring

The users OS is windows 7. Vmware had been running fine on it for months up until now. Any ideas?

Kind Regards
LVL 4
Graham HirstIT EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ctpmn1Commented:
If you just need the data stored on the server, you could boot into a different VM and add that VMDK as a secondary drive. Then you could at least take a look at it, possibly run a virus scan. What OS is the VM running, is this a server or a workstation. What is it used for?
0
Graham HirstIT EngineerAuthor Commented:
Its not really an issue with an individual VM. The issue is on the clients machine and the VMware host agent not starting. This in turn prevents the use of the vmware server as you are no longer able to connect via IE or any other web browser to the VMware interface to manage and start VM's

No virus is being detected on the clients machine, the OS hosting vmware server is windows 7. The client uses vmware to host xp machine to work in and demo our own in house developed software
0
TripyreCommented:
When was the last time this worked?  You might want to try a system restore back to that point to see if a windows update could have broken something.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Graham HirstIT EngineerAuthor Commented:
Hi Guys,

I ve just this minute resolved the issue. The problem is tied to a directory called c:\ProgramData\VMware. I remove this directory after uninstalling Vmware (i had previously missed it when attempting to clear the system of all traces of vmware. Upon the re-installation it worked fine.

I found the resolution here http://communities.vmware.com/thread/156265 if anyone wants any further details. Seems to be a re-occuring issue in vista and windows 7

Cheers for your help though guys
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mariaworldCommented:
On my Windows 7 phsyical host, I had had VMWare Server running for eons. Used it last week and all was fine. Today (after installing windows updates this weekend), hostd wouldnt start. Same error as mentioned in original post.  The solution for me was like the linked post stated. I had a corrupt datastores.xml file. On my Win7 machine that file was located here: C:\Users\All Users\VMware\VMware Server\hostd.

Deleting c:\ProgramData\VMware and then reinstalling had no effect. Finding that datastores file and replacing it with the default datastores.xml file fixed my problem with no additional re-install required.

M
0
Jamie_WilsonCommented:
MariaWorld,

Thanks for the above post, that works for me :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.