Everyone can access everyones mailbox from outlook. Not Secure

Windows 2003, Exchange 2003, Outlook 2003
I found out today that an outlook user was able to get into another users mailbox by going to
File -->Open-->Other users Folders
This is the case with everyone, they can open any mailbox.
When i go to the individual users mailbox i see the everyone group has read access, when i try to delete it says:
You cannot remove "Everyone" because this object is inherting permissions from its parent.  To remove "Everyone" you must prevent this object from inherting permissions.  Turn off the option for inher

I go into the exchagne system manager and also can not remove everyone permission under the exchange server name.  I found an article on this site but it was not helpful.  I really need
LVL 1
nocturnal59Asked:
Who is Participating?
 
Hilal1924Commented:
OK Go to ADUC root, Right Click on The container and go to properties, then you can stop it from inheriting the rights (hit advanced on the security bit) and copy the rights (not remove) when it asks. then just remove Everyone and your set. if you have problems, just tell it to enherit the rights again.
 
You can also do this from Database level in Exchange, Go to Mailbox Database Security --> advanced --> remove inheriting Checkbox --> Advanced --Remove Everyone
Hilal
0
 
Hilal1924Commented:
Ah really bad situation. Do this, Go to Exchange Organization. Right Click on Exchange Organization and click on properties. There should be a security tab. if not then you will need to create one (Follow this article If it not there : http://www.computerperformance.co.uk/Registry/registry_hacks_exchange.htm). Once you are in the security tab, remove the unwanted permissions. Pay close attention to Full Control, Read/Write access. Also remove the unwanted accounts from there.
 
Hilal
0
 
nocturnal59Author Commented:
Ok,
I did that and deleted the everyone group.  But i can still access other users mailboxes.  When i go to active directory and click on a users name, and go to mailbox rights, it still shows the everyone group with read permisions.  It wont let me delete that group.  Was this supposed to propagate down to this mailbox level?
0
 
nocturnal59Author Commented:
Thank You.  Only thing i had to do first is change Active directory to administrator mode to see the security tab.  Thanks again!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.