how to route calls to the PSTN via FXO ports with IP phones and analog phone

Hello
I have attached a picture of the setup I have and am trying to accomplish
I just got my 2 cards for my cisco 2801 flash:c2801-spservicesk9-mz.124-24.T2.bin
with CME 7.1. The cards i got are 2port-vic3-2fxs/DID and 2port-vic2-2fxo. Now i can see both cards and have done a show diag and believe all to be ok.
Here is part of the output for show diag:
PVDM Slot 0:
        8-channel (G.711) Voice/Fax PVDMII DSP SIMM PVDM daughter card
        Hardware Revision        : 4.0
        Part Number              : 73-8848-05
        Board Revision           : C0
        Deviation Number         : 0
        Fab Version              : 04
        PCB Serial Number        : FOC134114JA
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 00
        Product (FRU) Number     : PVDM2-8
        Version Identifier       : V01
        EEPROM format version 4

VIC Slot 0:
        3rd generation - FXS DID Voice daughter card (2 port)
        Hardware Revision        : 1.0
        Top Assy. Part Number    : 800-30501-02
        Board Revision           : A0
        Deviation Number         : 0
        Fab Version              : 07
        PCB Serial Number        : FOC14102N7C
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Product (FRU) Number     : VIC3-2FXS/DID
        Version Identifier       : V02
        CLEI Code                : IP9IAB3CAB
        Longitudinal Calibration : 01 10 10 7C 5E 10 10 91
                                   7C
        EEPROM format version 4

 WIC/VIC/HWIC Slot 1:
        2nd generation - FXO Voice daughter card (2 port)
        Hardware Revision        : 5.0
        Top Assy. Part Number    : 800-21597-03
        Board Revision           : B0
        Deviation Number         : 0-0
        Fab Version              : 04
        PCB Serial Number        : FOC13523UZ2
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Product (FRU) Number     : VIC2-2FXO
        Version Identifier       : V02
        CLEI Code                : CNUIARTAAB
        EEPROM format version 4
Now what i want to know is if i connect my regular PSTN home phone to FXS port I receive a dial tone but cannot call anywhere. The FXO port is connected to my PSTN box going to Telco CO. (Inlcuded a picture of what it looks like)
If i understand correctly, i need to configure VoIP dial-peers for the IP phones to be able to find the analog phone and POTS dial-peers for the analog phone to point to the IP phones and MGCP gateway for the FXO port but am not sure in which direction to go or how to achieve this since it,s directly connected to PSTN and not going to another router.

My regular PSTN phone number is: 1-905-665-2212
CME_router#show voice port summary
                                           IN       OUT
PORT            CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
=============== == ============ ===== ==== ======== ======== ==
0/0/0           --  fxs-ls      up    up   off-hook idle     y  ***This is my PSTN home analog phone
0/0/1           --  fxs-ls      up    dorm on-hook  idle     y
0/1/0           --  fxo-ls      up    dorm idle     on-hook  y
0/1/1           --  fxo-ls      up    dorm idle     on-hook  y
50/0/1          1      efxs     up    up   on-hook  idle     y
50/0/1          2      efxs     up    up   on-hook  idle     y
50/0/2          1      efxs     up    up   on-hook  idle     y
50/0/2          2      efxs     up    up   on-hook  idle     y

PWR FAILOVER PORT        PSTN FAILOVER PORT
=================        ==================

Thanks very much for the help.




analog-phone-from-CME-to-PSTN.JPG
ibanez7Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
can you post your router config?
ibanez7Author Commented:
Thanks for your help lrmoore
I had to leave out of town on a family emergency and will be back hopefully by Monday and will post my configs a.s.a.p
Thanks again and sorry for the inconvenience but will definitely post my configs as soon as i get back.

ibanez7Author Commented:
Hello lrmoore

Here's my router configuration. I only have basic configs to allow the LAN phones to be able to call each other so the LAN is fully functional (i can always configure the exact features as i go no problem). Like i mentionned above i would like my home analog phone connected in there and allow all to be able to call anywhere.

Thanks very much for your help.

CME_router#sh run
Building configuration...


Current configuration : 6870 bytes
!
! No configuration change since last restart
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME_router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 $1$YQ59$nbWiZ.AwLbZIkj9.8fugE1
!
no aaa new-model
memory-size iomem 10
clock timezone TORONTO -5
clock summer-time TORONTO recurring
dot11 syslog
ip source-route
!
!
!
!
ip cef
no ip domain lookup
ip domain name rtp.cisco.com
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
 fax protocol cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
crypto pki trustpoint TP-self-signed-3212666246
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3212666246
 revocation-check none
 rsakeypair TP-self-signed-3212666246
!
!
crypto pki certificate chain TP-self-signed-3212666246
 certificate self-signed 01
  30820250 308201B9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33323132 36363632 3436301E 170D3130 30333232 31313436
  34395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 32313236
  36363234 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  810098BA 809363DB 23F81F16 0AB00B2D 24565928 D9F878EF 9C48CEC2 9BF50BA2
  B1467538 1F0F51D3 2619F87B 1789868F A297CDA4 E46E32F5 08B4E547 EE57A23A
  4844891A A2EDE126 7AE688CB 2647D320 53D0029D B6E2096E EA99C207 B61EE323
  C9A09F58 4C9AE95D 08FA6576 1AA32302 A7566115 E64A9AAD E1521D70 C4AD2BA4
  F2890203 010001A3 78307630 0F060355 1D130101 FF040530 030101FF 30230603
  551D1104 1C301A82 18434D45 5F726F75 7465722E 7274702E 63697363 6F2E636F
  6D301F06 03551D23 04183016 801415C5 CD3F5B79 A7EA592F 5E21D1F6 680DE95D
  07BA301D 0603551D 0E041604 1415C5CD 3F5B79A7 EA592F5E 21D1F668 0DE95D07
  BA300D06 092A8648 86F70D01 01040500 03818100 0FBD4C92 1C72A7AE EF06B721
  29CA84BA 7AF5E4AD 410E680C 1F1D6413 7D18EF58 66499E51 D71AFE11 02F5CB4F
  7349C9C3 A4F07402 319244E2 00D25506 A974D813 E9370239 48CA0224 25C882B2
  E126DE91 2B2665C4 6FD07E0C B511BA3F 49EF0FBA 1BE803FE 46AB7654 23CC6528
  6E5B313A D3D52D64 FDF29428 D422094F 620E5205
        quit
!
!
username xxxx privilege 15 password 0 xxxxxxxx
archive
 log config
  hidekeys
!

!
!
interface FastEthernet0/0
 description Trunk to switch A VoiceVlan 10 and DataVlan 50
 no ip address
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 description VoiceVlan 172.16.1.0 /24
 encapsulation dot1Q 10
 ip address 172.16.1.1 255.255.255.0
 ip helper-address 172.16.2.5
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet0/0.50
 description DataVlan 172.16.2.0 /24
 encapsulation dot1Q 50
 ip address 172.16.2.1 255.255.255.0
 ip access-group 103 in
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet0/1
 description DHCP client receiving address from ISP DHCP server
 ip address dhcp client-id FastEthernet0/1
 ip access-group 102 in
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
!
ip nat pool NAT_OVERLOAD 217.168.256.101 217.168.256.101 netmask 255.255.248.0
ip nat inside source static tcp 172.16.2.11 21 interface FastEthernet0/1 21
ip nat inside source static tcp 172.16.2.11 20 interface FastEthernet0/1 20
ip nat inside source list 101 pool NAT_OVERLOAD overload
!
access-list 101 permit ip 172.16.2.0 0.0.0.255 any
access-list 101 permit ip 172.16.1.0 0.0.0.255 any
access-list 102 remark ACL allowed entry into router fa4 WAN
access-list 102 permit tcp any any eq smtp
access-list 102 permit tcp any any eq www
access-list 102 permit tcp any any eq ftp
access-list 102 permit tcp any any eq ftp-data
access-list 102 permit tcp any any eq pop3
access-list 102 permit tcp any any eq 443
access-list 102 deny   tcp any any eq 3389
access-list 102 deny   icmp any any echo log-input
access-list 102 permit ip any any
access-list 103 deny   icmp 172.16.2.0 0.0.0.255 172.16.1.0 0.0.0.255 echo log-i
nput
access-list 103 permit ip any any
!
!
tftp-server flash:/apps11.8-4-1-23.sbn alias apps11.8-4-1-23.sbn
tftp-server flash:/jar11sccp.8-4-1-23.sbn alias jar11sccp.8-4-1-23.sbn
tftp-server flash:/cnu11.8-4-1-23.sbn alias cnu11.8-4-1-23.sbn
tftp-server flash:/cvm11sccp.8-4-1-23.sbn alias cvm11sccp.8-4-1-23.sbn
tftp-server flash:/dsp11.8-4-1-23.sbn alias dsp11.8-4-1-23.sbn
tftp-server flash:/SCCP11.8-4-2S.loads alias SCCP11.8-4-2S.loads
tftp-server flash:/term06.default.loads alias term06.default.loads
tftp-server flash:/term11.default.loads alias term11.default.loads
tftp-server flash:/apps41.8-4-1-23.sbn alias apps41.8-4-1-23.sbn
tftp-server flash:/cnu41.8-4-1-23.sbn alias cnu41.8-4-1-23.sbn
tftp-server flash:/cvm41sccp.8-4-1-23.sbn alias cvm41sccp.8-4-1-23.sbn
tftp-server flash:/dsp41.8-4-1-23.sbn alias dsp41.8-4-1-23.sbn
tftp-server flash:/jar41sccp.8-4-1-23.sbn alias jar41sccp.8-4-1-23.sbn
tftp-server flash:/SCCP41.8-4-2S.loads alias SCCP41.8-4-2S.loads
tftp-server flash:/term41.default.loads alias term41.default.loads
tftp-server flash:/term61.default.loads alias term61.default.loads
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
mgcp fax t38 ecm
!
!
!
!
!
telephony-service
 em logout 0:0 0:0 0:0
 max-ephones 24
 max-dn 35
 ip source-address 172.16.1.1 port 2000
 load 7906 SCCP11.8-4-2S.loads
 load 7961 SCCP41.8-4-2S.loads
 time-zone 12
 max-conferences 4 gain -6
 moh music-on-hold.au
 web admin system name AAAAAAAAA secret 5 $1$Jhxy$zRuKi8Q.jCoBd8.1zxkEg.
 dn-webedit
 time-webedit
 transfer-system full-consult
 create cnf-files version-stamp 7960 Apr 17 2010 12:33:57
!
!
ephone-dn  1  dual-line
 number 1001
 name John Doe
!
!
ephone-dn  2  dual-line
 number 1002
 name Jane Doe
!
!
ephone-dn  3  dual-line
 number 1003
 name Night-Time receptionist
!
!
ephone-dn  4  dual-line
 number 1004
 name Day-Time Receptionist
!
!
ephone  1
 mac-address 9CAF.CA84.375F
 type 7906
 button  1:1
!
!
!
ephone  2
 mac-address 0027.0D3D.0E24
 type 7906
 button  1:2
!
!
!
ephone  3
 mac-address 0017.E0AE.51C1
 type 7961
 button  1:1 2:2 3:3 4:4
!
!
!
ephone  4
 mac-address 0018.19B9.35BE
 type 7961
 button  1:1 2:2 3:3 4:4
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server 128.100.100.128
ntp server 128.100.102.201
end

Thanks again for your help
ibanez7Author Commented:
ok i added this to the config and i can now call my analog phone from my IP phones and my analog phone can call my IP phones.
I still can't call over the PSTN can anyone help me out with this?

CME_router#show run | sec dial-peer
dial-peer voice 6097 pots
 destination-pattern 6097
 port 0/0/0

Thanks
ibanez7Author Commented:
Ok ...here's where i'm at now

i can either receive an incoming call to my analog phone or to my IP phone line 1004 depending on the plar command i use but cannot get both phones to ring at smae time.

voice-port 0/0/0
 cptone CA
 description FXS port 0/0/0 connected to analog_phone 17052676097
!
voice-port 0/0/1
 cptone CA
 description FXS port 0/0/1 connected to analog_fax
!
voice-port 0/1/0
 cptone CA
 connection plar opx 6095   ****this makes my analog phone work...NOTE: if i change to 1004 then my IP phones ring but the analog phone stops ringing and cannot answer outside calls.
 description FXO port 0/1/0 connected to PSTN rj11 wall jack to TELCO CO
!
voice-port 0/1/1

dial-peer voice 6096 pots
 destination-pattern 6096  ***going to my fax not working yet
 port 0/0/1
!
dial-peer voice 100 pots
 description FXO port 0/1/0 connected to PSTN wall jack
 destination-pattern 91..........
 port 0/1/0
!
dial-peer voice 6095 pots
 destination-pattern 6095   ****pointing to my PSTN analog phone connected to fxs port
 port 0/0/0


Can anyone help me out with this please...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.