Installing XenServer and cannot load the LSI SAS driver!

I am trying to come up to speed on XenServer and I have a Supermicro with a X8DA3 motherboard that has the LSI SAS 1068E on board. It is on the Xenserver hcl list but once the install program loads it is not seeing it.  I have the LSI configured for Raid 0 and intialized the drives.  Did I do something wrong in that or do I need to provide a driver?  If I need to provide a driver how can I do that because it is too big to fit on a floppy and when I put it on cd and use the local media option the installation program still cannot see it.  
bergm57Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

P0lT10nCommented:
Try to buy a better pc
bergm57Author Commented:
Thanks that was really helpful...
Jacob78Commented:
What version of XenServer are you trying to install?
SolarWinds® IP Control Bundle (IPCB)

Combines SolarWinds IP Address Manager and User Device Tracker to help detect IP conflicts, quickly identify affected systems, and help your team take near instantaneous action. Help improve visibility and enhance reliability with SolarWinds IP Control Bundle.

bergm57Author Commented:
Version 5.5.0 Update 2
ToxicPigCommented:
Sure enough, it is on the HCL and compatible with 5.5:

http://hcl.xensource.com/ProductDetails.aspx?ProductType=HBA&ProductName=1068E+8-port

Had a look at the specs on Supermicro's site, and you did get yourself a good board.  Can you download and try the 5.6 beta to see if you get a different result?  How about configuring the drives in a different way, say just two as a raid 1 as a test?

Normally, I'd say that with on-board (fake-raid) controllers, you're just out of luck, but that certainly does NOT seem to be the case here.
bergm57Author Commented:
Yes, I made sure it was on the hcl before I bought it but I am afraid I may have to buy another controller. The bad thing about that is the backplane is setup for the imbedded controller only.  I did manage to the a Megaraid SAS version from Citrix and it allowed me to load the driver but I keep getting the same error.
" An unrecoverable error has occurred.  The details of the error can be found in the log file which has been written to /tmp/install.log (and root/installlog if possible). "  I will try the 5.6 beta and see what I get.
bergm57Author Commented:
Similar problem with 5.6 it doesn't see the drives.
bergm57Author Commented:
I checked the install-log and it seems to be bombing on selecting the primary drive for installation.  I went back and configured it for Raid 1 and same news when I try again.  
ToxicPigCommented:
OK, so if 5.6 doesn't see it, then it's not a driver issue.  Does another OS see it?  is it a known good card?  Can you see the boot messages (Alt-F3 during install, I think) and do they report seeing anything in terms of storage during the kernel boot?  The more I hear, the more (frustratingly, I know) that I just want to say that it SHOULD work.
bergm57Author Commented:
I agree it should work. I must not be finding the correct driver because I took your suggestion and tried it with W2k3 and it sees the drive just fine after loading the windows driver.   I have not tried to see the boot messages. I will give that a shot too.  Thanks for your input on this!
bergm57Author Commented:
I finally figured out that the XenServer could not see the onboard raid controller because it was in software mode SR.   A jumper change to HT mode and a firmware update from Supermicro and the hard drives were working.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ToxicPigCommented:
Outstanding.  Good to know.
Casey WeaverManaged Services Windows Engineer IIICommented:
Thanks for posting that answer. Very good to know. Something I would look over in frustration.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.