How to force FireFox to choose right application for Word/Excel

I administer our company's intranet and we force our users to use FireFox for their browser.

I've had many complaints about the way FireFox handles different file types we link to on the site. Most of the complaints are relating to Word/Excel documents. For example, say they click on a Word document. FireFox will ask you what to open the document with. You hit the dropdown and select "other". Choose winword.exe and check the checkbox for "do this automatically". Then you do the same process for an Excel document on the site. So now you've told FireFox to open both word and excel documents with their respective programs. Well then if you go back in and try to open a Word document, FireFox will suggest Excel to open it and Word won't be in the dropdown. You have to go back to the "other" option again and re-locate Word...basically repeat the process each time. The only thing it does automatically is remember the last file extension association you used.

How can I make it so if a user downloads a Word or Excel document, FireFox opens it up in the correct program automatically? Or at least have the correct program in the dropdown list and not have to re-locate it each time you go from one file type to another?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

It sounds like the file type association may be wrong on the machines. Are you sure that the word and excel programs are correctly associated with their respective extensions?

What version of firefox is everyone using?
Nenad RajsicCommented:
in firefox go to tools>options>applications tab and see what is set to open word and excel files. if they are not associated properly you can change the settings on that screen (click once and you will get a dropdown box to select which program you want to use)
joeschuhAuthor Commented:
Thank you both for your responses.

I'm using v3.6.3.

Yeah, I'm familiar with the applications tab. That was the first thing I tried. I have application/ set to use Excel, text/html to Word (although they both have the same description text in the dialog...which is weird to me). No change in result though. Still if you open a Word doc after opening an Excel doc, assuming you selected Excel to open the Excel doc, FireFox will try to default to Excel to open the Word document and vice versa. It's like it remembers the association you used last, but nothing afterwards. So constantly switching back and forth between file types results in always having to manually select the .exe's to use to open the documents.
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

Nenad RajsicCommented:
I use ff 3.6.3 and office 2007 - and although I can't give you an answer this info might help
just did a quick search for doc and xls with my Firefox and tried to open them 5-6 times and my FF always selects the right program?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Marc ZCommented:
joeschuh, I think mziter was asking about the Windows File Association and wanted you to confirm they were set properly to the respective Word and Excel programs.  That should be your First step. Let's confirm those are set properly. What version of Windows? Either way, typical route to check, open Windows Explorer, hit the Tools->Folder Options->File Types and find .doc, .docx, .xls, .xlsx and make sure they are set to Word and Excel.
If on Win7, a little different route.

And then, we might have to look at the MimeTypes that they are coming across as,
I'm on a MAC at the moment so I don't have Office installed. I'll check on my other machine a little later to see what we can figure out.
Marc ZCommented:
Also, this page has LOTS of info we may have to  look through.
Marc ZCommented:
Have you actually sat down at one of their machines as them, and confirmed that it works as you are describing?  Very good possibility of them not seeing the Always Do this for this type checkbox.

One other thought just occurred to me. Do these users have read/write permissions to their Firefox Profile folder?  Are you wiping any of their preferences?

I just ran a test in Firefox 3.6.3 and Office  2007, after confirming my own defaults, then running samples, it 's working and staying as requested. But my Firefox profile is local to my machine, not on work's network.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.