Permissions issue using Commvault 6.1 on a file share

I have some shares set up on some non-ndmp compatible storage, and I'd like to be able to use Commvault to backup the files.  I've installed a windows idata agent on my commserve, and have set up subclients pointing to the shares.  Things seemed OK, and the jobs were finishing, but no data was being backed up.  I tracked it down to some kind of permisions error preventing CV from scaning the folders/files.  I then tried adding the CV user to the domain admins group but had the same results.  As a test, i created a brand new volume and share and left the permissions defaulting to everyone=full on the share and file system.  I put some test data in there and was able to back it up with no errors.  I add CV user with full permissions and remove everyone from the file system permissions (leaving the share permissions as they were) and the backup fails.  I did narrow down the the everyone group has to have file scan, read, read permissions, etc. to work, but doesn't need full access.

I'm not seeing anything in the logs, other than in a "failed to scan directory due to error 5" in a report I can run on the jobs, but it doesn't tell me what user/service does not have permissions.  I don't know if CV is using some other service with different credentials, or if it's on the storage end, but I've run out of ideas.

comserve is W2k3 standard.  Any suggestions would be appreciated.
BamstickAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Psy053Commented:
What happens if you map the volume to a drive letter on the CommServe and back it up that way?
BamstickAuthor Commented:
I've tried mapping the share to a drive letter, but in the subclient policy I still have to use the unc.  Mapping and then using the drive letter fails instantly.  I wonder if it has anything to do with the Commserve not being in the domain?  It was around before we went with AD and never has been joined.  I'm using domain credentials, but if it is some local machine account that is getting denied...  

I think I will join the commserve to the domain as soon as the current jobs are done running and see what results I get.  

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BamstickAuthor Commented:
After joining the Commserve to the domain, my test job ran without a hitch, so I'm guessing it was something like what I stated above, or perhaps it was timing out when trying to authenticate on each file since it wasn't on the same domain.  Not 100% sure.
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Psy053Commented:
Hmm, I thought the older versions of Commvault allowed for backing up mapped volumes - apparently not.

Glad you got it working though.


Psy053Commented:
Bamstick, are you ready to close of this question or do you require further assistance?
BamstickAuthor Commented:
Yes, this question can be closed.
Psy053Commented:
Hi Bamstick,  you will need to close the question off. See here for help: http://www.experts-exchange.com/help.jsp#hs=29&hi=407
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.