Apache Error after installing VisualSVN Server - Too many errors in select loop.

Hi there,
I have installed VisualSVN Server v2.1.1 on our 2003 Small Business Server so that we can store our development code and have it backed up regularly.

While I seem to be able to intall it fine on all of our development PC's, it will not run correctly on our 2003 server.

The install goes through fine, the Visual SVN Server starts ok but when you browse to the URL all you get is a blank screen.

Looking through the even viewer I found the following event in the VisualSVN Server event log :


Event Type:      Error
Event Source:      VisualSVN Server 2.1
Event Category:      Apache
Event ID:      1002
Date:            17/04/2010
Time:            1:39:43 p.m.
User:            N/A
Computer:      ServerName
Description:
Too many errors in select loop. Child process exiting.
(OS 10038) An operation was attempted on something that is not a socket.


I have read all sorts of things about this problem on the internet but nothing that I have tried has seemed to work.

The VisualSVN service is set to run with the "Network Service".

I have verified the permissions on the VisualSVN installation folder as well as the repositories folder.  I even granted it full permission to these folders to see if that would help.

I have it set up to run on it's one IP address.

I have tried running on different ports. 8080, 443, 9000, 9090

I have disabled the antivirus on the server.

I have stopped the IIS service.

Nothing has seemed to work.

I have included the httpd.conf file that VisualSVN generates in case that helps.  It is worth nothing that the included "httpd-custom.conf" file referred to at the end of the file is empty.

Does anyone have any experience with this issue or could help point me in the right direction?
#
# This is configuration file for Apache HTTP server which is
# part of VisualSVN Server.
#
# DO NOT EDIT THIS FILE IT WILL BE REGENERATED AUTOMATICALLY BY VISUALSVN SERVER
#
# Contact with VisualSVN Ltd. (support@visualsvn.com) if you have suggestions and
# improvements.
#

ThreadsPerChild 64
MaxMemFree 100
MaxRequestsPerChild  0
Win32DisableAcceptEx
LimitXMLRequestBody 0
LimitRequestFieldSize 12392

ServerRoot "D:/Program Files/VisualSVN Server"
ServerName "gotham.AmVia.local:443"
ServerSignature Off
ServerTokens Prod
DocumentRoot "htdocs"

PidFile "E:/SVN_Repositories/server.pid"

Listen "172.25.48.201:443"

LoadModule auth_basic_module bin/mod_auth_basic.so
LoadModule authn_file_module bin/mod_authn_file.so
LoadModule authn_visualsvn_module bin/mod_authn_visualsvn.so
LoadModule authz_visualsvn_module bin/mod_authz_visualsvn.so
LoadModule alias_module bin/mod_alias.so
LoadModule dir_module bin/mod_dir.so
LoadModule deflate_module bin/mod_deflate.so
LoadModule mime_module bin/mod_mime.so
LoadModule setenvif_module bin/mod_setenvif.so
LoadModule rewrite_module bin/mod_rewrite.so

LoadModule dav_module bin/mod_dav.so
LoadModule dav_svn_module bin/mod_dav_svn.so
LoadModule ssl_module bin/mod_ssl.so

<Directory />
  Options FollowSymLinks
  AllowOverride None

  RewriteEngine on
  RewriteCond %{REQUEST_URI} ^/svn$
  RewriteRule ^(.*/svn)$ %1/ [R=301,L]
</Directory>

<Location /svn/>
  DAV svn

  SVNListParentPath on
  SVNParentPath "E:/SVN_Repositories/"
  SVNIndexXSLT "/svnindex.xsl"

  AuthName "Subversion Repositories"
  AuthType VisualSVN
  AuthzVisualSVNAccessFile "E:/SVN_Repositories/authz-windows"
  AuthnVisualSVNBasic on
  AuthnVisualSVNIntegrated off
  AuthnVisualSVNUPN Off

  BrowserMatch "(\s|^)neon/0.\d+.\d+(\s|$)" AuthnVisualSVNIgnoreReauth
  BrowserMatch "(\s|^)neon/0.\d+.\d+(\s|$)" AuthnVisualSVNDisableNegotiate

  require valid-user
</Location>

Alias /web-ui-static htdocs/web-ui-static

<IfModule dir_module>
    DirectoryIndex index.html
</IfModule>

ErrorLog nul

LogLevel error

TraceEnable off

DefaultType text/plain

<IfModule mime_module>
    TypesConfig conf/mime.types
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz
    AddType application/x-x509-ca-cert .crt
    AddType application/x-pkcs7-crl    .crl
</IfModule>

<IfModule ssl_module>
SSLEngine on

SSLRandomSeed startup   builtin
SSLRandomSeed connect   builtin
SSLPassPhraseDialog     builtin
SSLSessionCache         "shm:E:/SVN_Repositories/ssl_scache"
SSLSessionCacheTimeout  300
SSLMutex                default
SSLCertificateFile      certs/server.pem
SSLCertificateKeyFile   certs/server.pem
SSLProtocol             -ALL +SSLv3 +TLSv1
SSLCipherSuite          ALL:!aNULL:!ADH:!eNULL:!LOW:!EXP:RC4+RSA:+HIGH:+MEDIUM

SetEnvIf User-Agent ".*MSIE.*" ssl-unclean-shutdown

</IfModule>

Include conf/httpd-custom.conf

Open in new window

LVL 5
SoLostAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SoLostAuthor Commented:
I have finally solved my problem.

For those that have this problem and are looking for the answer, hopefully this will solve it for you too.

It appears that my servers winsock must have become corrupt somewhere along the line.  Running the following command fixed the winsock and after a reboot VisualSVN began to run without any problems.


Open a command prompt and execute the following : 

netsh winsock reset

Then, restart your computer.

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Version Control

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.