DNS Not Working

I am working on a client's computer running Windows Vista. DNS doesn't seem to be working on the computer. I cannot access web pages using website name/URL. I can access pages using IP address both locally and on the internet. Proxy settings are not set in Internet Explorer. DNS server on LAN is functioning properly and other computers have no issues with same IP settings. From a command prompt, I can ping any live IP address successfully, but cannot ping any website by domain name. I've checked the HOSTS file and there are not improper entries there. I've tried resetting Internet Explorer back to defaults. The "Network and Sharing Center" shows that I'm connected locally and to the internet. Network diagnostics indicate a problem with DNS. Again, DNS server is functioning correctly and this problem reproduces itself when connected at different locations using DHCP settings given by local routers/DHCP servers. Malware scans have come up clean.
gerbiljayAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dgwareCommented:
try using 4.2.2.2 as dns server and see if that works. Is it just this computer out of many that is not working or are all computers in the lan not able to access site via domain names?
0
Nenad RajsicCommented:
check you dns client service.it looks like your dns client service is not running
0
gerbiljayAuthor Commented:
I already checked the DNS client service and forgot to mention it. It was already running but I tried restarting it with no resolution. I also tried the ipconfig /flushdns command as administrator which also didn't help.

This is the only computer I have the problem with. There are many other computers in this network and other networks I've connected the problem computer to and only this computer has issues. It's not the DNS server.
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

nole172Commented:
ipconfig on a command line shows your valid DNS servers.
0
gerbiljayAuthor Commented:
ipconfig shows 192.168.0.1 as my DNS server currently with the network I'm connected to currently with the DNS sever address being given via DHCP just like all other computers in this network. I have manually programmed other valid DNS server addresses in to the network configuration and they still don't work. I tried the suggested server 4.2.2.2 and that doesn't work either. I can ping the 4.2.2.2. Again, IT IS NOT the DNS server at this location or the other locations I've done troubleshooting from. It's NOT a router in my network or the other networks I've connected to. It IS something to do with this particular computer. I get the same results connected to wireless networks as well as wired through the ethernet cable.
0
nole172Commented:
what about nslookup?  do you get any messages when you try to look up addresses?
0
gerbiljayAuthor Commented:
When I did nslookup, it showed:

Default Server: UnKnown
Address: 192.168.0.1

I typed server 192.168.0.1 afterwards and it showed:
Default Server: 192.168.0.1
Address: 192.168.0.1

I've never had to use that command before so I don't really know what else to do with it. According to other troubleshooting steps I found that told me to try nslookup, those are correct results.
0
gerbiljayAuthor Commented:
nslookup server 4.2.2.2 yields: can't find server: non-existent domain
nslookup server 192.168.0.1 yields: Unknown can't find server: No response from server
0
gerbiljayAuthor Commented:
nslookup server 68.94.156.1 yields: can't find server: non-existent domain

This server address is the address programmed directly into the router as the DNS server and this address was given to my router via DHCP from AT&T DSL.

The nslookup commands all yield the exact same results from other computers in my local lan. These other computers are functioning fine in all areas.
0
BilBagsCommented:
Have you checked the windows firewall to see if that is the problem?  
0
BilBagsCommented:
Also, how many DNS servers do you have defined on the workstation?  have you tried changing them to use an external DNS server temporarily to see if that resolves the issue or not?
0
nole172Commented:
Just type nslookup by itself.  Then type in any web site like www.cnn.com and see if the dns lookup returns an IP address.
0
gerbiljayAuthor Commented:
I checked the Windows Firewall. It was on, but configured correctly. I shut it off temporarily and tested several things with the same results.
The only DNS defined on the workstation is what was given by DHCP from my router. Yes, I have tried external DNS such as 4.2.2.2 and the DNS from AT&T 68.94.156.1.

From previous post from nole172:
I tried that and every address I try yield the same results: ***Unknown can't find www.cnn.com: No response from server

Same command from other workstations yield much different results showing the server name and several different IP address. This seems pretty conclusive that it is something definitely tied to this particular machine.
0
Justin MaloneSystem AdministratorCommented:
have you attempted to reset your winsock? from command prompt (assumeing at least winxp SP2)

netsh winsock reset
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gerbiljayAuthor Commented:
The 'netsh winsock reset' was something I was going to try about 6 hours ago, but didn't think it fit the problem. I've worked on other computers in the past with similar, but not the same symptoms and it fixed the issues. The other computers were able to ping by domain name, but couldn't connect through a web browser so I didn't think it was applicable in this scenario since I couldn't ping by domain name in this situation. But I'll try it and see.

Great suggestion "squallkill99" it worked! I guess I should have tried that at the beginning of my troubleshooting when I thought about it before.

 
0
gerbiljayAuthor Commented:
Thanks for everyone's suggestions. Hopefully this post comes in handy for future users. I did a lot of searching for this problem on the internet and found several users with the same scenario, but no solutions were posted in other research.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.