help installing dashcommerce

Hi all,

I'm trying to get dash commerce working on our dedicated cloud server.

I've not used this before, so I have uploaded the webready files to test location and to have a look at it. Now whenever i try to view the site i get following error and i dont know why;

Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 
now from looking in the web.config it should be redirecting to a custom error page anyway? does anyone know this could be happening?
flynnyAsked:
Who is Participating?
 
eguilhermeCommented:
well for first, do as the message says and set the customErrors mode to off that way we can know whats the error
0
 
flynnyAuthor Commented:
Hi,

I just realised i overlooked something entirely.

because i was testing the program in a rooted directory on the webspace it couldnt find the web.config and hence i got that error.

sorry guys.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.