No DNS found at child. Extra DNS listed at parent.

I'm trying to set up a DNS with BIND. I've purchased a book but won't have it until after the weekend, and I'm eager to get started :)

I've read large parts of: http://www.zytrax.com/books/dns/ (DNS for Rocket Scientists)
which is also from where I've gotten most of these configuration files.
1 )
When I start bind, I get two error messages that I find myself unable to correct:

17-Apr-2010 13:45:53.315 general: error: zone 0.0.127.in-addr.arpa/IN: has no NS records
17-Apr-2010 13:45:53.316 general: error: zone localhost/IN: NS 'localhost' has no address records (A or AAAA)

2 )
Despite the above errors bind starts, and when I run an "undelegated test" from my TLD (.se) to see if everything is ok, I get back (translated from swedish):
"No DNS-servers were found at child.
No DNS-servers were found at the child. This normally means that the child is not configured to answer queries about the zone"

"Extra DNS-server listed at parent: letharion.se
A DNS-server is listed in the parentzone but not in the childzone. This is likely an administration error. You should update the parent zone so that it lists the same DNS-servers that the child zone does as soon as possible."

3)
A related question. Is there anything in the below configuration files that need to be kept secret and should be altered now that I've published them? There may be security implications that I don't yet understand.
named.conf
options {
        directory "/var/bind";
        version "get lost";
        allow-transfer {"none";};
        pid-file "/var/run/named/named.pid";
};

logging{
        channel example_log{
                file "/var/log/named/named.log" versions 3 size 2m;
                severity notice;
                print-severity yes;
                print-time yes;
                print-category yes;
        };
        category default{
                example_log;
        };
};
// required zone for recursive queries
zone "." {
        type hint;
        file "/var/bind/named.ca";
};
zone "letharion.se" in{
        type master;
        file "master/master.letharion.se";
};
// required local host domain
zone "localhost" in{
        type master;
        file "master.localhost";
};
// localhost reverse map
zone "0.0.127.in-addr.arpa" in{
        type master;
        file "localhost.rev";
};

master/master.letharion.se

$TTL 2d    ; 172800 secs default TTL for zone
$ORIGIN letharion.se.
@             IN      SOA   ns1.letharion.se. hostmaster.letharion.se. (
                2003080800 ; se = serial number
                12h        ; ref = refresh
                15m        ; ret = update retry
                3w         ; ex = expiry
                3h         ; min = minimum
                )
                        IN      NS      ns1.letharion.se.
                        IN      MX  10  mail.letharion.se.
mail.letharion.se.      IN      A       85.227.195.30
ns1.letharion.se.       IN      A       85.227.195.30
www                     IN      A       85.227.195.30

master.localhost
$TTL    86400 ; 24 hours could have been written as 24h
$ORIGIN localhost.
; line below = localhost 1D IN SOA localhost root.localhost
@  1D  IN        SOA @  root (
                2002022401 ; serial
                3H ; refresh
                15 ; retry
                1w ; expire
                3h ; minimum
                )
@  1D  IN  NS @
1D  IN  A  127.0.0.1
$TTL    86400 ;
; could use $ORIGIN 0.0.127.IN-ADDR.ARPA.
@       IN      SOA     localhost. root.localhost.  (
                1997022700 ; Serial
                3h      ; Refresh
                15      ; Retry
                1w      ; Expire
                3h )    ; Minimum
        IN      NS      localhost.
1       IN      PTR     localhost.

Open in new window

LVL 6
letharionAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

scrathcyboyCommented:
Please explain what it is you are trying to do.  It seems to me your DNS issues can be solved fairly easily.
0
mikebernhardtCommented:
In my own configuration, I do not have a forward zone called localhost. I would put the following near the top of master/master.letharion.se (first A record):
localhost    A       127.0.0.1

In your zone file localhost.rev, do this:
                 NS      ns1.letharion.se.
1               PTR     localhost.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mikebernhardtCommented:
Also, there's nothing in that config that needs to be kept secret- there are no passwords or view configurations that would give someone insight into private data.

You might consider getting on the BIND users list. It's extremely useful! If you sign up for the digest then you won't get so many messages.
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

Jan SpringerCommented:
Your records in the localhost.rev file looks good.

Your master.localhost should have these records:


                IN NS           @
                IN A            127.0.0.1
                IN AAAA         ::1

These are the authoritative servers that I get when querying letharion.se:

letharion.se.           604740  IN      NS      ns1.everlast.se.
letharion.se.           604740  IN      NS      ns2.everlast.se.
letharion.se.           604740  IN      NS      ns3.everlast.se.

I do not get a valid address record when querying ns3.everlast.se.

When querying ns1 and ns2.everlast.se, I do not get an address record for ns1.letharion.se.

So, if your goal is to take over DNS for your own domain, get everlast.se to configure an address record for ns1.letharion.se for you.  Either ask them to configure ns3.everlast.se to also be authoritative or remove that entry from your registrar records.
0
letharionAuthor Commented:
scrathcyboy:
My intention is to set up my own dns master server for my private domain.

mikebernhardt/_jesper_:
Thank you both. :) I've got my book now, so I'm gonna read up on the advice you gave.
Maybe I will sign up to the BIND list aswell :)
0
letharionAuthor Commented:
I should mention that after posting this question, but before I got any replies, I started over with a clean install, and read gentoo's installation instructions instead of the "dns for rocket scientists" and got it working :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.