activex control not registered

Hi,

I am trying to run a program that when runned it gives you an entire dialog, and it uses MFC.

The problem is that I get this error when trying to see the resources and the dialog of the project...i will post a picture with the error so you will see..that says and activexcontrol is not registered.
But I've already registered one .ocx file that came with the project, but still I have the same problem.
i've used regsvr32 to register the .ocx file and it said that it is succesfully registered but still I don't know what seems to be the problem.
activexcontrolnotregister.bmp
Gabriela1Asked:
Who is Participating?
 
Gabriela1Connect With a Mentor Author Commented:
I've got it resolved...I had to move the .ocx in system32 folder and it seems to work just fine now. Anyways thank you for your help.
0
 
jkrCommented:
Try the Dependency Walker (www.dependencywalker.com) to see if a file that your control relies on might be missing.
0
 
Gabriela1Author Commented:
I've tried the  dependency walker..and open the .ocx file and it said that 2 dll files are missing ....ieshims.dll and wer.dll so i downloded the dll and copy it to system32...but the it says abot an ncrypt.dll and i've down that one and now a bcrypt.dll... how long it will take? or maybe i am not using it the right way ?
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
Gabriela1Author Commented:
I've installed the bcrypt also..and now it does not say what it is missing but still i get a warning that

Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.
and i've checked again the program and I still have the error.

and also when trying to run the whole project i get a debug assertion failed..so i think it is related with the  unregistered file.
0
 
Subrat (C++ windows/Linux)Software EngineerCommented:
If using VISTA OS, you need to launch command prompt with adminstrative previllage. Then use regsvr32.
start->run->cmd->right click on cmd icon->Run As Admin->Handle UAC prompt
 
Hope this may help!
 
0
 
Subrat (C++ windows/Linux)Software EngineerCommented:
For me, images aren't visible. So written VISTA OS......Now I saw u r using XP
0
 
jkrCommented:
>>At least one module has an unresolved import due to a missing export
>>function in a delay-load dependent module.

Which modules exactly are mentioned in that warning?
0
 
Gabriela1Author Commented:
Which modules exactly are mentioned in that warning?

The software does not say anything about the module...so that is why it is a little bit strange.
0
 
Gabriela1Author Commented:
the project also needed the Microsoft Directx june2008. I've installed it but on D:\ partition of the computer , an dot on C:\ but Visual C++ is on C: partition....do you think that maybe the problem?
0
 
lucky_jamesCommented:
Does it point about directX?. if you want to test if it is becoz of directX or not, just copy those files in the same folder where your module is located.....if its becoz of your directX installation then this should start working....then, as a resolution, we will discuss on having a feasible and elegant solution ...

As already asked by jkr, could you provide us some more data points....like screenshots of dependency walker...that may help us in a better fashion. I understand you might be frustrated Gabriela, but there appears to be no short cut for us while helping you out.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.