How to configure Cisco 827 Router to replace Linksys ADSL Router for internet connection

Hi,

I have internet connection with one ISP which I have configured with Linksys ADSL router which is working fine . I want to replace my Linksys router with Cisco 827 Router.
What information I need to get from linksys router to configure Ciso 827 router .

As I know my   ISP Account information

ADSL  username / password
VPI /VCI  information
I am getting IP address from ISP
My Local network interface rannge is 192.168.1.0/24
DHCP Range   192.168.1.10 to 100

Please let me know How I can configure Cisco 827 Router for above information .
gukhanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin MaloneSystem AdministratorCommented:
most of what you have will do it.
you need your ADSL user-name / password
you need to know how your getting your IP from your ISP (STATIC, DHCP or other weird config)
you need to know your VPI/VCI information
you need to know what type of connection it is (most likely PPPoATM)
you dont need to know what your local network and local dhcp range is if you dont have any static addresses
you need to know if your ISP uses the inner pair or outer pair for ADSL
and the last thing you need to make sure is configured on your router includes NAT/DHCP (if your connection is not static)

gukhanAuthor Commented:
ok


Please let me know the steps to configure the router .
Justin MaloneSystem AdministratorCommented:
does it have a web interface or is it all programed from the command line? and if its command line what IOS are you useing?
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

gukhanAuthor Commented:
no it is not having web interface and its ios ver 12.1


i have to configure

pppoe setting
pvc  1/100
username
password
dynamic ip address

on atm port
felixresourcesCommented:
First off you will need to get yourself a cisco console cable. (if you dont have one you can learn how to make one here http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a008010ff7a.shtml or just buy one off ebay they are pretty cheap.

Then connect it to the console port on the back of the 827.

Then connect it to the serial connection on the back of your computer.

Then get a terminal emulator application eg Putty (google it)

The default serial speed is 9600bps with 1 stop bit and no hardware flow controll I think it is.

If it already has a configuration I would suggest you use the write erase command to clear anything out.

If you have it secondhand of Ebay and need to clear the password on the device because you cant get into it you can follow the instructions here http://www.cisco.com/en/US/products/hw/routers/ps221/products_password_recovery09186a0080094773.shtml

After that you should be right to get into the business of configuring it

My 827 has a whole bunch of port forwarding in the config and an IPv6 tunnel so I am just going to post the basics of the config that will get your system running if you put the correct details in for your ISP.

You will need to replace some of the config to match your ISP's settings and your enable password (MAKE SURE YOU DO THIS PART)

Make changes to the config below to match your ISP settings then copy and paste it into the router in configuration mode (configure terminal command below)

I have filled in most of the details including the DHCP stuff for you, all you should have to do is go through it and where I have put things in in brackets () you will just need to put in your info and make sure you remove the brackets.

To get into where you can configuer this router turn it on and connect with the console cable in Putty then once it comes up type in enable then type in configure terminal.


!
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname (PUT THE NAME OF YOUR ROUTER HERE)
!
boot-start-marker
boot-end-marker
!
enable secret (PUT YOUR PASSWORD HERE)
!
no aaa new-model
ip subnet-zero
ip name-server (PUT ADDRESS OF DNS SERVER 1 HERE)
ip name-server (PUT ADDRESS OF DNS SERVER 2 HERE)
ip dhcp excluded-address (PUT RANGE OF EXCLUDED ADDRESS'S HERE IF YOU WANT THEM EG. 192.168.0.1 192.168.0.15)
!
ip dhcp pool 192.168.1.0/24
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.254
   dns-server ( PUT YOUR DNS SERVER HERE AGAIN)
!
!
!
!
!
!
bridge irb
!
!
!
interface Ethernet0
 description Inside Network
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 ip flow ingress
 ip policy route-map clear-df
 no keepalive
 hold-queue 100 out
!
interface Virtual-Template1
 bandwidth (UPLOAD SPEED HERE IE. for a 256kbps upload put in 256)
 no ip address
!
interface Virtual-Template2
 bandwidth (UPLOAD SPEED HERE)
 no ip address
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.3 point-to-point
 description (PUT YOUR ISP NAME HERE)
 bandwidth 256
 ip flow ingress
 pvc (PUT YOUR VPI/VCI HERE)
  encapsulation aal5mux ppp dialer
  dialer pool-member 3
 !
!
interface Dialer1
 no ip address
!
interface Dialer3
 description (ISP NAME HERE)
 bandwidth (download speed here eg 256kbps you put in 256)
 ip address negotiated
 ip nat outside
 ip flow ingress
 encapsulation ppp
 dialer pool 3
 dialer-group 1
 ppp chap hostname (PUT YOUR ISP USERNAME HERE)
 ppp chap password (PUT YOUR ISP PASSWORD HERE)
!
!
ip nat inside source list 11 interface Dialer3 overload
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer3
no ip http server
no ip http secure-server
!
access-list 11 permit 192.168.1.0 0.0.0.255
!
route-map clear-df permit 10
 match ip address 5
 set ip df 0
!
bridge 1 protocol ieee
!
line con 0
 password (PUT YOUR ENABLE PASSWORD HERE AGAIN)
 login
line vty 0 4
 password (ENABLE PASSWORD AGAIN)
 login





I will also give you an extra tip.
When you need to do port forwarding you need to go back into configuration mode and enter

ip nat inside source static (tcp OR udp) (internal IP address to forward to) (Internal port number to forward) (external IP address of your router) (External port to forward) extendable

ie. ip nat inside source static udp 192.168.0.1 5060 222.222.222.111 5060 extendable

That command would forward all UDP traffic on port 5060 from the external router IP address of 222.222.222.111 to port 5060 to the device on the inside network at address 192.168.0.1

 

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.