I can get to my router, but not my server... although I can ping both of them.

In my house, on my regular network, I have a Linksys WRT150N router running DD-WRT and controlling the 192.168.2.0 network with my main desktop and my file server.  Branching off of the Linksys, I have a Cisco 871W router running my lab subnet, and directly attached to this router I have a client computer.

The client computer in the lab subnet can access the internet (which is on another subnet beyond the linksys router), and it can EVEN access the web-based setup page of the Linksys Router, but for some reason it can't go through it and access the file server in my room.

Going the other direction, the file server can access the client just fine across the subnets.

Here are a few IP addresses just so we're clear:

Linksys WRT150: 192.168.2.241
File Server: 192.168.2.20
Cisco 871W WAN: 192.168.2.201
Cisco 871W LAN: 192.168.3.1
Client Computer: 192.168.3.20

I've attached the running-config of my router.

As I said in the title, I can ping the file server just fine. I've tried turning on WINS and it sees the file server and its IP. I've tried creating a DNS entry for the file server and nothing works. I find it strange that it works in reverse direction though.

Please help. Thanks.
Building configuration...

Current configuration : 4948 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname MaestroROUTER1
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5 *EDIT*
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local 
!
aaa session-id common
!
resource policy
!
clock timezone PCTime -5
ip subnet-zero
no ip source-route
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip tcp synwait-time 10
no ip bootp server
ip domain name MaestroNET.com
ip name-server 192.168.1.1
ip name-server 192.168.3.20
ip ssh time-out 60
ip ssh authentication-retries 2
ip port-map user-RDP port tcp 3389 description Remote Desktop
no ip ips deny-action ips-interface
!
!
crypto pki trustpoint TP-self-signed-3065917022
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3065917022
 revocation-check none
 rsakeypair TP-self-signed-3065917022
!
!
crypto pki certificate chain TP-self-signed-3065917022
 certificate self-signed 01
  *EDIT*
  quit
username DT privilege 15 secret 5 *EDIT*
!
! 
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
 description MAIN TRUNK TO SWITCH1
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet2
 description S-THRU TO SERVER1
!
interface FastEthernet3
!
interface FastEthernet4
 description WAN TO NEXT SUBNET$FW_OUTSIDE$$ES_WAN$$ETH-WAN$
 ip address dhcp client-id FastEthernet4
 no ip redirects
 no ip unreachables
 ip directed-broadcast
 no ip proxy-arp
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
!
interface Dot11Radio0
 no ip address
 !
 encryption key 1 size 40bit 7 *EDIT* transmit-key
 encryption mode wep mandatory 
 !
 ssid MaestroNET
    authentication open 
    guest-mode
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 channel 2462
 station-role root
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
 no ip address
 ip tcp adjust-mss 1452
 bridge-group 1
!
interface BVI1
 description $ES_LAN$$FW_INSIDE$
 ip address 192.168.3.1 255.255.255.0
 ip virtual-reassembly
 ip tcp adjust-mss 1412
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.2.241 2 permanent
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat pool Main 192.168.3.150 192.168.3.155 netmask 255.255.255.0
!
logging trap debugging
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner login ^C|----------------------------------|
|------Welcome to MaestroNET!------|
|-This network is used for testing-|
|-and experimental lab purposes.---|
|-Please leave it alone unless you-|
|-feel like impeding my learning.--|
|**********************************|
|--Current Device: MaestroROUTER1--|
|**********************************|
^C
!
line con 0
 privilege level 15
 logging synchronous
 login authentication local
 no modem enable
 exec prompt timestamp
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

Open in new window

LVL 8
MaestroDTAsked:
Who is Participating?
 
OnityCommented:
When you say access do you mean through \\(file server ip)? or do you mean through remote desktop?

can you gain access to your file server from other computers on the same subnet as your file server?
are there any firewalls on either your server or the client?
0
 
deibelCommented:
hi maestro,

did you get the ATM stuff running?
i posted a new config.

you wrote here:
The client computer in the lab subnet can access the internet (which is on another subnet beyond the linksys router), and it can EVEN access the web-based setup page of the Linksys Router,

!!!!but for some reason it can't go through it and access the file server in my room.!!!!

and you wrote:
I can ping the file server just fine

so the first quote let me think you have a routing problem
but the second quote say, no routing is OK, if ICMP works.

can you post a network diagram?
i am a bit confused about your 4 eth-interfaces

what is switch1, what means to server1, whats that wan subnet?
0
 
sidetrackedCommented:
u need to add a route in the linksys router

ip route 192.168.3.0 255.255.255.0 192.168.2.201

0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
deibelCommented:
if the server answers the icmp request, the routes might be ok

there is not only a ping
there is a pong as well

and the pong seems to find its route back to the pc
0
 
deibelCommented:
but sidetracked is right so far, as you need always two routes
one for the request and one for the reply

there are constellations where you dont need to configure exactly every route.
this is, when NAT and default routes are used somewhere

so to check your routing, please post a network diagram and your routing tables
0
 
Brain2000Commented:
Sidetracked is on the right track.  The server probably has a default gateway to go to the Linksys.  So the Linksys needs to redirect back inside, or you need to put a static route on the server for 192.168.2.0 255.255.255.0 to go to 192.168.2.201.

You also need to assign 192.168.2.201 to the Cisco router.  You mentioned this was the IP address for the Cisco's WAN side, but it isn't in the config.

interface FastEthernet4
 ip address 192.168.2.201 255.255.255.0
0
 
Brain2000Commented:
Oh, nevermind.  You're DHCP'ing that address.
0
 
deibelCommented:
but routing is at L3

so if icmp works fine,  my first thought was->routing OK
why should another protocol above L3 have a problem?

he wrote:
the file server can access the client

same thing:
if the file server can get to client, routes might be ok

maybe hes filtering some protocol

i think he has to explain the problem more detailed.
what's now the problem?
reaching the network...routing and stuff
or accesing the shares.....authentication/filtering and so on
0
 
MaestroDTAuthor Commented:
sorry guys i was working really late (or early) and couldn't respond.

how do i do an ICMP request in windows?

to answer your question about the IP address, the WAN address is dynamically assigned with a static reservation on the linksys router. that's why it isn't shown in the config.

i was about to say "no firewalls"  and then i double-checked and for some reason it was turned ON for server2, which explains everything.

here's my network diagram deibel just because you asked and are helping my with my ATM problem, but i do believe this issue is fixed now. thanks!


Home.png
0
 
OnityCommented:
just so you know ICMP is the protocol used to ping. It is also used with tracert and if my memory serves me right is a "best attempt" protocol basically it will attempt to send the packet but not provide feedback if it fails.

have a wiki link :) http://en.wikipedia.org/wiki/Internet_Control_Message_Protocol it will probably explain it alot better than me and my memory. Glad that you manage to get you problem sorted without to much hassle
0
 
OnityCommented:
ps. love your network layout i wish i could have that many switches to play about on :)
0
 
MaestroDTAuthor Commented:
onity, you know what? i totally knew that haha i am just so tired i was thinking "is there a switch on ping that lets me change it to ICMP" and i was sitting here staring at a command prompt with ping /help very very puzzled

i've got all these switches and routers (and a couple more routers and switches) so that i can study for my CCNA... and i'm trying to cram asap because I just went to pick up the second MC3810-V (MaestroVOICE1, where I'm trying to config an ATM link) with an AVM and FXO/FXS so that i can sneak a peak at CCVP material too - but i met the previous owner off of craigslist and happened to work for a large IT company... he kept asking me questions and finally said hurry up and get my CCNA, then come back so he could give me a job better than the one i have now.

the only thing i ever paid more than $50 for was my 871w router - that was the first piece of cisco equipment i ever bought. craigslist and ebay are pretty amazing for used stuff, it wouldn't be that hard to get a bunch of "toys" of your own.... and that's exactly what they are to me haha i always feel like a kid buying toys when i buy cisco stuff... so nerdy.

thanks guys!
0
 
MaestroDTAuthor Commented:
Turned off Windows Firewall and everything is peachy!
0
 
OnityCommented:
Ah i am a student at the moment and so i have next to no money but when i get a job i shall have a play as well :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.