• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 533
  • Last Modified:

Symantec mail security for Lotus Domino on AIX

i have lotus notes installed & running on AIX 5.3 on this server there are 2 volume group
rootvg
lotusvg
with these file systems
/dev/fslv00     --         /usr/domino            jfs2  10485760 rw         yes no
/dev/fslv02     --         /serverl               jfs2  46137344 rw         yes no
and other filesystem for rootvg, I want to install symantec mail security on this server i have the software but each time i start installation, iget this error "Unable to find Domino in the default location"
Please specify the location of the Domino binaries, based on the
path chosen when installing Domino. If you installed Domino to the
default directory, press <RETURN> to accept the default location.

although i write the path which i start lotus server by
"/usr/domino/lotus/bin/server"

i tried this path and not working also so how can i get the correct path for lotus domino or is there any other way to install this antivirus



0
medoamer
Asked:
medoamer
  • 9
  • 4
  • 4
1 Solution
 
woolmilkporcCommented:
Hi,

the correct location should be in your case

/usr/domino/lotus/notes/latest/ibmpow

The path /usr/domino/lotus/bin only contains links to
/usr/domino/lotus/bin/tools, and this path only contains
some few links to files in the above directory.

The default path is /opt/ibm/lotus/notes/latest/ibmpow, btw.

wmp



0
 
medoamerAuthor Commented:
I tried all these pathes

/opt/lotus
/usr/domino/lotus
/serverl/domino/html/lotus
/serverl/usr/domino/lotus
/usr/domino
/serverl/domino
/serverl/usr/domino
/usr/domino/lotus/notes/ibmpow
/usr/domino
/serverl/domino
/serverl/usr/domino
/serverl/usr/domino/lotus/bin
/serverl/usr/domino/lotus/notes/65050/ibmpow/jvm/bin
/serverl/usr/domino/lotus/notes/latest/ibmpow/jvm/bin
/usr/domino/lotus/notes/latest/ibmpow/_uninst/_jvm/jre/bin
/usr/domino/lotus/notes/latest/ibmpow/jvm/bin
/usr/domino/lotus/notes/80010/ibmpow/_uninst/_jvm/jre/bin
/usr/domino/lotus/notes/80010/ibmpow/jvm/bin
/usr/domino/lotus/bin
0
 
woolmilkporcCommented:
And my suggestion

/usr/domino/lotus/notes/latest/ibmpow (literally, without anything following "ibmpow")?

I can't find it in your post.

wmp


0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
medoamerAuthor Commented:
the same errot when i trying your suggestion

"/usr/domino/lotus/notes/latest/ibmpow"
0
 
woolmilkporcCommented:
So we need a closer look at your installation.

You wrote that you use to start the server by
"/usr/domino/lotus/bin/server".

This is most probably a link. Please check this link using
ls -l /usr/domino/lotus/bin/server

At my servers it points to "tools/startup". What do you find?

Issue ls -l /usr/domino/lotus/bin/tools/startup or whatever the link above does point to in your case.

You should find that this is itself a link.
Again at my servers, it's "../../notes/latest/ibmpow/startup". At yours?

The directory part of this last target should be the path you need,
in my case it's the default "/opt/ibm/lotus/notes/latest/ibmpow".

I built the path I recommended above by replacing "/opt/ibm" with "/usr/domino",
which seemed sensible because of the location of your start command.

OK, what do you actually find by following all the links?

wmp





0
 
Sjef BosmanGroupware ConsultantCommented:
Open your notes.ini file on the server and look for the line with NotesProgram=

Example:
NotesProgram=/opt/ibm/lotus/notes/85010/linux

Use that path.
0
 
medoamerAuthor Commented:
I tries your command
"ls -l /usr/domino/lotus/bin/server"
output
lrwxrwxrwx    1 notes    notes            35 Apr 14 16:48 /usr/domino/lotus/bin/
server -> /usr/domino/lotus/bin/tools/startup
-----------------------------------------------------------------------------------------------
ls -l /usr/domino/lotus/bin/tools/startup
output
lrwxrwxrwx    1 notes    notes            44 Apr 14 16:48 /usr/domino/lotus/bin/
tools/startup -> /usr/domino/lotus/notes/80010/ibmpow/startup
-----------------------------------------------------------------------------------------------
then i tried these paths

/opt/ibm/lotus/notes/latest/ibmpow
/usr/domino/lotus/notes/latest/ibmpow
-----------------------------------------------------------------------------------------------

I also tried sjef_bosman: solution
find in notes.ini this path and it also fail
/usr/domino/lotus/notes/80010/ibmpow

sorry for this but it is critical issue for me

0
 
woolmilkporcCommented:
OK,
"latest" is a link to "80010", thus no real difference between the two, although "latest" should be preferred, as it will remain valid across upgrades.
Did you try to point the symantec installer to the directory where "notes.ini" is in?
wmp
 
0
 
medoamerAuthor Commented:
The same error
Although the mail server is running and working well
0
 
medoamerAuthor Commented:
i restore old rootvg for the same server it was installed on it before & i tried to uninstall the antivirus i get this
Checking for user id  ...

Checking for Symantec AntiVirus/Filtering for Domino...

Checking for Installation/Uninstall Process.

Checking for Domino server running ...
Server is not running.

Checking for LiveUpdate running ...
LiveUpdate is not running.

Searching for Lotus Notes partitions ...
It may take a few minutes, depending on the machine's speed
Keep existing savdefs.nsf database confirmation
Do you wish to keep  /serverl/sav/savdefs.nsf ?
              (  Press y or n  )
                  Option : [n]
 Keep existing savlog.nsf database confirmation
Do you wish to keep  /serverl/sav/savlog.nsf ?
              (  Press y or n  )
0
 
Sjef BosmanGroupware ConsultantCommented:
Ask Symantec for their assistance...
0
 
medoamerAuthor Commented:
i tried before they didn't give me any solution
0
 
medoamerAuthor Commented:
I tried a new solution i restore old RootVG on the server with old installation of symantec but when i check it's status i get this
Server UNIXLOTUSSERVER/AIIC-EG
Status Updated At 29/09/2009 ¿ 01:36:53
Auto-Protect Settings
EMail Scanning Off
Write Scanning Off
Virus Definitions 10/08/2008
-----------------------------------------------------------------------------------------------
So is that mean that Symantec Installed and not start yet
and if that how can i start it on
0
 
Sjef BosmanGroupware ConsultantCommented:
Could you make a new path to Domino's directory, using symbolic links, so that the symantec installation procedure uses that path to install its stuff?

Anyway, do you really think it's very useful to install an anti-virus utility on a server? What hole are you trying to close? I assume all users have AV-software installed on their systems. The server is an AIX server, running little risk. Were it a Windows server I'd immediately agree with you, but on a Unix-based system??
0
 
medoamerAuthor Commented:
Do you have on your own mail server antivirus/antispam and if what kind of it
because as iwrote last i have old rootvg with symantc but how can i start it
is there any command to start syamntec service as i start lotus server
"/usr/domino/lotus/bin/server"
0
 
Sjef BosmanGroupware ConsultantCommented:
I suppose the Symantec solution is supposed to run inside the Domino environment, but I'm not sure: I never used it.

The anti-spam I personally like best is kSpam, an all-Domino solution, but I don't know whether there is an AIX version available. See http://www.openntf.org/Projects/pmt.nsf/ProjectLookup/kSpam

A partner of mine uses ClamAV: see http://www.clamav.net and http://en.wikipedia.org/wiki/Clam_AntiVirus
For anti-spam: SpamAssassin, see http://spamassassin.apache.org/ and http://en.wikipedia.org/wiki/SpamAssassin
0
 
medoamerAuthor Commented:
after a lot of trying i finally purchased a the latest version of "Symantec Mail Security for Domino Multi-Platform Edition v8.0.5" and asked for an on-site support person and he uninstalled the old one which i guess it turned out to be incomplete installation or something like that and installed the newer version.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 9
  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now