SSRS 2005 Permissions Problem

I am running SQL Server 2005 Developer Edition on a Windows 7 Laptop.

I am unable to deploy an RS solution.  It builds fine but when trying to deploy, I get the following error message: "Error The permissions granted to user 'SERVER\User' are insufficient for performing this operation."

If I try to go directly to the URL (http://localhost/Reports/Pages/Folder.aspx), I get this error: "The request failed with HTTP status 401: Unauthorized"

RS Configuration Settings are as follows:
Windows Service Identity: LocalSystem
Web Service Identity: NT Authority\LocalService
Database Setup: Credentials Type: Service Credentials

In IIS, for both the Reports and ReportServer, the followingAuthentication methods are enabled:
Anonymous
ASP.NET Impersonation
Windowa Authentication

I have spent many hours on this and I am not getting anywhere.  Help.
jw1741Asked:
Who is Participating?
 
Alfred A.Commented:
Have you configured your Report Server?  Check your configuration through "Reporting Services Configuration".  You see the status of each item if configured properly or not.
0
 
Alfred A.Commented:
Hi,

For the "Error The permissions granted to user 'SERVER\User' are insufficient for performing this operation."

In report manager, create another Group or User SERVER\User for your report under Properties -> Security and Role as "Publisher".
0
 
Alfred A.Commented:
Hi,

By the way, from my previous post, the report manager should be http://localhost/Reports/Pages/Folder.aspx

For "The request failed with HTTP status 401: Unauthorized" error by the way, untick Anonymous Access in the Authentication Methods and you should have this in web.config -> <identity impersonate = "true" />

0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Alfred A.Commented:
Oh, I didn't noticed that you allow Anonymous Access, just don't untick the checkbox for Anonymous Access.  However, if you want to remove anonymous access and you use forms authentication you should untick that checkbox and have this in web.config.

<authorization>
      <deny users="?"/>    
</authorization>

I hope this helps.
0
 
jw1741Author Commented:
I tried the suggestions - now when I try to go to the Report Manager (http://localhost/Reports/Pages/Folder.aspx), I get the following error message:
HTTP Error 401.3 - Unauthorized
You do not have permission to view this directory or page because of the access control list (ACL) configuration or encryption settings for this resource on the Web server. Detailed Error Information
Module IsapiModule
Notification ExecuteRequestHandler
Handler PageHandlerFactory-ISAPI-2.0
Error Code 0x80070005
Requested URL http://localhost:80/Reports/Pages/Folder.aspx 
Physical Path c:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportManager\Pages\Folder.aspx
Logon Method Negotiate
Logon User Server\Guest

 Here is the web.config file:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
 <configSections>
  <section name="MicrosoftWebControls" type="System.Configuration.NameValueSectionHandler,  System, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL" />
  <section name="RStrace" type="Microsoft.ReportingServices.Diagnostics.RSTraceSectionHandler,Microsoft.ReportingServices.Diagnostics" />
  <section name="UIConfig" type="Microsoft.ReportingServices.UI.UIConfigSectionHandler,ReportingServicesWebUserInterface" />
 </configSections>
 <system.net>
  <defaultProxy enabled="false" />
 </system.net>
 <system.web>
  <pages validateRequest="false" />
  <compilation defaultLanguage="c#" debug="false" />
  <customErrors mode="Off" />
  <authentication mode="Windows" />
  <identity impersonate="true" />
  <trace enabled="false" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true" />
  <sessionState mode="InProc" cookieless="false" timeout="20" />
  <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
  <httpRuntime executionTimeout="9000" />
  <securityPolicy>
   <trustLevel name="RosettaMgr" policyFile="rsmgrpolicy.config" />
  </securityPolicy>
  <trust level="RosettaMgr" originUrl="" />
  <httpHandlers>
   <add verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, ReportingServicesWebUserInterface, Version=9.0.242.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />
  </httpHandlers>
 </system.web>
 <appSettings>
  <add key="ReportViewerServerConnection" value="Microsoft.ReportingServices.UI.WebControlConnection, ReportingServicesWebUserInterface, Version=9.0.242.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />
  <add key="ReportViewerTemporaryStorage" value="Microsoft.ReportingServices.UI.ReportViewerTemporaryStorage, ReportingServicesWebUserInterface, Version=9.0.242.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />
 </appSettings>
 <RStrace>
  <add name="FileName" value="ReportServerWebApp_" />
  <add name="Prefix" value="tid, time" />
  <add name="TraceListeners" value="debugwindow, file" />
  <add name="TraceFileMode" value="unique" />
  <add name="Components" value="all" />
 </RStrace>
 <system.diagnostics>
  <switches>
   <!-- 1 = error, 2 = warning, 3 = info, 4 = verbose -->
   <add name="DefaultTraceSwitch" value="3" />
  </switches>
 </system.diagnostics>
 <runtime>
  <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
   <dependentAssembly>
    <assemblyIdentity name="Microsoft.ReportingServices.Interfaces" publicKeyToken="89845dcd8080cc91" culture="neutral" />
    <bindingRedirect oldVersion="8.0.242.0" newVersion="9.0.242.0" />
   </dependentAssembly>
  </assemblyBinding>
 </runtime>
    <system.webServer>
        <security>
            <authorization>
                <remove users="TARAH\User" roles="" verbs="" />
            </authorization>
        </security>
    </system.webServer>
    <connectionStrings>
        <add connectionString="Server=TARAH;Database=Reports;User ID=Tarah;Password=pandemonium" name="RS" />
    </connectionStrings>
</configuration>

This is relly frustrating, I hope that you can see the error.
 
Thanks.
0
 
Alfred A.Commented:
Hi,

The report manager you are accessing, that is installed in your local machine, right?
0
 
jw1741Author Commented:
Yes it is on the local machine.
0
 
Alfred A.Commented:
OK.  Let us start with Report Manager first.  Since this is in your local machine, can you set in IIS under your Reports virtual server the authentication control (Properties -> Directory Security -> Edit) to allow anonymous access and remove the tick in integrated windows authentication and try accessing the report manager after this.  What I am trying to do here is make sure we can access your Report Manager.  If later on this will work, I suggest using Integrated Windows Authentication and not allow anonymous access for a remote server.

0
 
jw1741Author Commented:
I get the header only and an error message: "Unable to connect to the remote server"
0
 
jw1741Author Commented:
Current Reporting Services Configuration
Windows Services Identity:
Server name:  ReportServer
Service Account:  Local System
Built-in Account:  LocalSystem
Web Service Identity:
ASP.NET Service Account:  NT Authority\System
Report Server:  Classc .NET AppPool
Report Manager:  ReportServer
Database Connection:
ServerName:  Server Name
Database Name:  ReportServer
Credentials Type:  Service Credebtials

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.