RPC over http keeps prompting for password

Hi

I have been called out to a School as they are having issues with RPC over HTTP.

They connect to a centralised government data centre to get email, this means that the local domain at the school is not a member of the domain that hosts the exchange mailboxes.

Is there any way to change this on the client side so they do not keep getting prompted or s that not possible in this setup

Thanks

Nick
LVL 5
ncomperAsked:
Who is Participating?
 
deibelCommented:
i forgot the domain issues:

maybe this helps:
http://www.andreasroom.com/blog/archive/2005/06/17/RPCHTTP.aspx
0
 
deibelCommented:
i have my outlook in german, so the tabs may differ
i dont know if i translate them correctly

check "security-tab" in the account settings
unmark "always prompt for logon information"

check "connection-tab" -> proxy-settings -> authentication settings
0
 
deibelCommented:
and see the postings below this article at andreasroom.com
they give more hints there, like: http://support.microsoft.com/default.aspx?scid=kb;en-us;820281
0
 
oztrodamusCommented:
Hi ncomper,

The reccomended client configuration for RPC over HTTPS is to use Basic Authentication, in the proxy configuration settings, therefore it's always going to ask for your user name and password.

It is possible to use NTLM Authentication, which would then have the ability to transparently pass the users authentication credentials, but it would require the reconfiguration of the back-end infrastructure to support it, and it would require the client PC to a memebr of the domain the user account is in. Depending on the situation that may not be practical.
0
 
ncomperAuthor Commented:
Thanks all
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.