Startmenu GPO for 2008R2 Remote Desktop

I'm trying to lock down a Server 2008R2 with GPO. I'm getting stuck trying to remove some Start Menu items. Classic Start Menu has been discontinued in 2008R2. I need to remove the "Control Panel\User Accounts" link and the "Administrative Tools" from the Start Menu.

I can't use "User Configuration\Administrative Templates\Control Panel\Prohibit access to the Control Panel", because some left handed mouse users need to be able to have access to "%windir%\system32\control.exe mouse" to set it to left handed.

I can't find the GPO to remove these items, "Control Panel\User Accounts" link and the "Administrative Tools". Also the "Show only specified control panel applets" GPO setting doesn't really do the job in 2008R2.

I'm looking for tips to get this solved
RDP1.jpg
rdp2.JPG
NicoNLAsked:
Who is Participating?
 
r_panosCommented:
You must go the the Group Policy Preferences at the User Configuration level, that is GP Preferences\User Configuration\Preferences and dig into Windows Settings and Control Panle Settings
0
 
JarrodCommented:
In some cases ive used classic shell to bring back the old start menu for certain clients, its a workaround not really a fix though

http://classicshell.sourceforge.net/

Hope this helps
0
 
NicoNLAuthor Commented:
I added a Windows Vista Start Menu in User Configuration\Preferences\Controol Panel Settings with for all items Don't Display This Item selecteted. But for some reason 2008R2 doesn't execute this GP setting. I added it in a separate GP to check GPresult. The policy is listed in GPresult, I selected authenticated users. But without the result I was hoping for. Administrative tools is still listed.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
NicoNLAuthor Commented:
http://classicshell.sourceforge.net looks like a nice worl around.

Have you used this on a 2008R2 Remote Desktop server? Is the Classic Menu automatically active for all users on the server, or do I first need to build an msi to ad to the login script?
0
 
NicoNLAuthor Commented:
I have tested http://classicshell.sourceforge.net on a 2008R2 remote desktop test server. After installing the classic menu it is active for all users. But when using desktop / start menu redirection, I get an Application crash on explorer.exe which constantly keeps restarting. That;s a pitty, I am not going to try this on our production server.

Still I can't get rid of the Administrative tools in my menu................
0
 
JarrodCommented:
Classic shell by default should be active as you said, but i cant say i had tried it yet with redirected start menus turned on. There were a few other apps out there that were pay for ones that might do a similar function and might support the redirections. I just googled 2008 r2 classic start menu and found the classic shell app but there were others that you might see do whats required. Hope this helps
0
 
NicoNLAuthor Commented:
I found a ADM created by M. Mills that did the job for me to hide the Administrative Tools :-))))

CLASS USER
CATEGORY "Start Menu Administrative Tools(CustomADM)"
  POLICY "Remove Administrative Tools from Start Menu"
  EXPLAIN !!ADMHelp
  KEYNAME Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    PART !!ADM_Configure DROPDOWNLIST REQUIRED
    VALUENAME "Start_AdminToolsRoot"
    ITEMLIST
      NAME !!ADMoff VALUE NUMERIC 0 DEFAULT
      NAME !!ADMon VALUE NUMERIC 1
    END ITEMLIST
    END PART
  END POLICY
END CATEGORY

[strings]
ADM_Configure="Set the Administrative Tools to:"
ADMoff="Hidden"
ADMon="Visible"

; explains
ADMhelp="Set Administrative Tools to be shown or hidden on the Start Menu. No need to delete the folder off your TS now! MMills - 30/03/10"
0
 
NicoNLAuthor Commented:
The solution provided wasn't what solved it for me. I found a ADM somewhere on an other forum that solved it. So I close the case and share the points to all who has replied.
0
 
NicoNLAuthor Commented:
Even better:

User Configuration/Preferences/Windows Settings/Registry/Registry item: NoSetFolders
PropertiesHive HKEY_CURRENT_USER
Key path Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Value name NoSetFolders
Value type REG_DWORD
Value data 0x1 (1)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.