Converting from WE8ISO8859P1 to UTF8 character set Oracle 10g

Hi ,

below is the query iam using to convert from the WE8ISO8859P1 character set to UTF8 character set. When I do that i get different characters . Can any one guide me whether the below output is correct if not can you guide me on how to go abt it.

SQL> select business_name, dump(business_name, 1016), convert (business_name, 'UTF8', 'WE8ISO8859P1') from customers where vid = 931402;
 
BUSINESS_NAME
----------------------------------------------------------------
DUMP(BUSINESS_NAME,1016)
--------------------------------------------------------------------------------
CONVERT(BUSINESS_NAME,'UTF8','WE8ISO8859P1')
--------------------------------------------------------------------------------
t¿s¿sstt¿
Typ=1 Len=9 CharacterSet=US7ASCII: 74,e9,73,e9,73,73,74,74,e9
t¿¿s¿¿sstt¿¿

Thanks in advance

Swaminathan_KAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Franck PachotOracle DBACommented:
Hi,

The output depends on the client characterset setting, and the client OS characterset.
you can check if the conversion is good with:
dump(convert (business_name, 'UTF8', 'WE8ISO8859P1'),1016)

Then you can check if:
- client characterset (as defined by NLS_LANG) is UTF8
- client (sqlplus, OS, telnet if it goes through telnet, ...) supports UTF8

Regards,
Franck.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Swaminathan_KAuthor Commented:

Hi , here are my findings... I still get a ? character when i convert , pls guide..


If I keep the NLS_LANG environment variable as .UTF8, the dump displays the correct values. However the string does not display correctly, it shows question marks.


Then you can check if:
- client characterset (as defined by NLS_LANG) is UTF8
Yes

- client (sqlplus, OS, telnet if it goes through telnet, ...) supports UTF8
I tried connecting to our  database which is UTF8, and tried reading some special characters, and that displays fine. So I amthat assuming  sqlplus supports UTF8 along with SecureCRT and our OS.
0
Franck PachotOracle DBACommented:
Can you confirm that
- client is UTF8
- you can read text from UTF8 database (and you know that thext in database is UTF8 because you checked the dump)
- the convert to UTF8 is fine (you checked it with dump)
- but that converted text is not display properly in the same client
?

0
Swaminathan_KAuthor Commented:
Thanks a lot for all inputs. I got it done
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.