OWA stopped working after SPoint 3 Crawler "fix"

We were having the 2424 and 2436 errors every 5 minutes in the logs of a relatively new SBS 2008 box. I used this URL to attempt a fix: http://mysharepointblog.com/post/2007/01/Windows-SharePoint-Services-(WSS)-30-Search-Setup-Notes.aspx

Now my OWA and RWW are inaccesible and I can't seem to get them back. Can someone please tell me how to revers what I did, as the webpage that offers a fix doesn't have a repair for the fix!

Now I get the following errors in the logs:

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 19/04/2010 10:11:24
Event time (UTC): 19/04/2010 09:11:24
Event ID: f136f73104884536be6e77af3fe2e9e2
Event sequence: 2
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/3/ROOT/Autodiscover-4-129161418846131695
    Trust level: WSS_Minimal
    Application Virtual Path: /Autodiscover
    Application Path: C:\Program Files\Microsoft\Exchange Server\ClientAccess\Autodiscover\
    Machine name: ***SERVER
 
Process information:
    Process ID: 11080
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: FileLoadException
    Exception message: Could not load file or assembly 'Microsoft.Exchange.Diagnostics, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. An error relating to security occurred. (Exception from HRESULT: 0x8013150A)
 
Request information:
    Request URL: https://mail.xxxxxxxxx.co.uk:443/Autodiscover/Autodiscover.xml 
    Request path: /Autodiscover/Autodiscover.xml
    User host address: 192.168.1.24
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: NT AUTHORITY\NETWORK SERVICE
 
Thread information:
    Thread ID: 3
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at Microsoft.Exchange.Autodiscover.Global.Application_Start(Object sender, EventArgs e)
 
 
Custom event details:


LVL 1
quadraspleenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
quadraspleenAuthor Commented:
We are also getting the following error:

Log Name:      Application
Source:        ASP.NET 2.0.50727.0
Date:          19/04/2010 10:06:08
Event ID:      1310
Task Category: Web Event
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      TSGSERVER.tsg.local
Description:
Event code: 3008
Event message: A configuration error has occurred.
Event time: 19/04/2010 10:06:08
Event time (UTC): 19/04/2010 09:06:08
Event ID: 65673551e4424ad09ec810612b14b110
Event sequence: 1
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/3/ROOT/owa-2-129161415683436381
    Trust level: WSS_Minimal
    Application Virtual Path: /owa
    Application Path: C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\
    Machine name: TSGSERVER
 
Process information:
    Process ID: 11080
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: HttpException
    Exception message: Could not load file or assembly 'Microsoft.Exchange.Data, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. Failed to grant permission to execute. (Exception from HRESULT: 0x80131418) (C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\web.config line 51)
 
Request information:
    Request URL: https://mail.technicalservicesgroup.co.uk:443/owa/default.aspx 
    Request path: /owa/default.aspx
    User host address: 85.95.105.245
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: NT AUTHORITY\NETWORK SERVICE
 
Thread information:
    Thread ID: 3
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
   at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
   at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
 
 
0
 
quadraspleenAuthor Commented:
Also, it is imprtant to note here that I have not deleted anything. I have only chaged a configuration of SharePoint and its links to the websites. http://companyweb still works fine and Exchange is still working. It is only the OWA and RWW that have stopped, probably because I got the fix wrong for the crwaler errors.

Any SharePoint gurus out there?
0
 
Shreedhar EtteCommented:
Hi,

Does the OWA and RWW working internally?

What is the error you getting while browsing OWA and RWW?

- Check Default Web Site and it should run on ports 80 and 443.

- Rerun the Connect to Internet Wizard once.

Hope this helps,
Shree
0
 
quadraspleenAuthor Commented:
Hi Shree,

We are way, way beyond this, I'm afraid. We eneded up having to call PSS who fixed it by the following:

Resolution :
=================
# To resolve the issue, We re-Installed Rollup 9 for Exchange 2007 over the top to correct any wrong permissions on Virtual Directories of IIS "

# The SBS web applications website has been extended as a SharePoint site

# web.config was all modified..with entries for SharePoint

# We corrected the Web.config file

# Rebooted he server

# Able to browse OWA and Remote now

# Issue Resolved
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.