When I right click on my table and select 'Script table as' the 'Alter' option is greyed out.

When I right click on my table and select 'Script table as' the 'Alter' option is greyed out.

Why might that be.

here is the ddl of the table.

create TABLE [Audit].[Executed_Reports](
      [Exec_ID] [int] IDENTITY(1,1) NOT NULL,
      [Report_Name] [varchar](500) NULL,
      [Date] [datetime] NULL,
PRIMARY KEY CLUSTERED
(
      [Exec_ID] ASC
)WITH (PAD_INDEX  = OFF, STATISTICS_NORECOMPUTE  = OFF, IGNORE_DUP_KEY = OFF, ALLOW_ROW_LOCKS  = ON, ALLOW_PAGE_LOCKS  = ON) ON [PRIMARY]
) ON [PRIMARY]
Mr_ShawAsked:
Who is Participating?
 
Om PrakashConnect With a Mentor Commented:
This is a normal behavior and Alter To /Execute To is not applicable to Table... it is only applicable to objects like sp/function/views

http://social.msdn.microsoft.com/Forums/en-US/sqltools/thread/2be6116d-41e8-43be-99a0-502bb84dcdd0/
0
 
Christopher GordonConnect With a Mentor Senior Developer AnalystCommented:
I normally alter a table one object at a time. I don't believe there is a global Alter option for a table (at least in the version of SQL Server I'm using, just create and drop.  Alter scripts need to be handled individually at the Column, constraint, table property level.
0
 
Mr_ShawAuthor Commented:
thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.