ACT Network Sync unable to accept incoming sync


as per screens attached, i cant accept incomign syncs, get those errors when i try, the sync service is running (see screen) i have the sync service running as admin and act running as admin too

the accept incoming syc port is a rule i added for 65100 tcp to see if that helped

anyone help me out?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


Can you check that the application sync is turned off, as if that is turned on the sync service will not start.

Check under tools -> Synchronize -> Accept incoming syncs, it will have a tick on the left of the menu option if turned on... just click to turn off.

Actually Just looking at the second screen shot, the button says stop sync service which suggests its allready running.

You can't "accept incoming syncs" inside the application if the sync service is running - its either the application or the sync service that runs.

If you have the "accept incoming syncs" checked then the application needs to remain open in order for users to sync.
If the sync service is running then act does not need to be open in order to sync - just the sync service running.
awilderbeastAuthor Commented:
yeah its off  the sync log tells me to turn it on though :S

======== SYNC SESSION - 19/04/2010 13:10:52 ========

[ Info | 19/04/2010 13:10:52 ]Message: Sync remote client created.
[ Info | 19/04/2010 13:10:55 ]Message: Checking if schema changes are available for sync.
[ Info | 19/04/2010 13:11:03 ]Message: Client establishing synchronisation with server database: CW60
[ Error | 19/04/2010 13:11:08 ]Message: Synchronisation has failed. ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network.

i have created some rules on DC2 to allow inbound and outbound UDP/TCP on 65100 on the firewall
do i need to add anything else?

PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

awilderbeastAuthor Commented:
i turned the firewall off for domain enviroments for both machines and the sync still failed with same error

any ideas?
So It does, but as far as I'm aware only one needs to be on. Either Application sync (Accept incoming syncs) or service sync (Act sync service).

Try turning off the sync service and choosing accept incoming syncs from the application, then make sure you keep act open and logged in on the server whilst performing the tests.

You'll need to add the following possibly to both the client and server to prevent the firewall blocking SQL,
C:\Programs Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe
C:\Programs Files\Microsoft SQL Server\90\Shared\sqlbrowser.exe
Add Ports,
                TCP – 1433
                UDP - 1434

If the Windows firewall is running on the client the exceptions will also need to be added to that, turning it off doesn't always work - for what ever reason.

Can you just supply the following information:
1. Server OS
2. Server Act Version (Help -> About Act from server) ... I.E
3. Client OS
4. Client Act Version (Help -> About Act from client)

Also on the client under "Tools -> Sync Panel" and under "Manage main database location" and  "Manage connection information" can you check that they are the relevant server name/IP and let me know what there set as (IE either IP or Name).

awilderbeastAuthor Commented:
ok i stopped the act netowrk sync service, checked the accept incoming syncs in ACT and its accepting connections through the application, that means i will have to have ACT open all the time on the server though?

how can i get the network sync service accepting?

That suggests that the sync service version is a different version to your application, can you check the server and client version of Act.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
awilderbeastAuthor Commented:
it was!

updated it now, all good :)

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.