• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 467
  • Last Modified:

Logitech MX 5500 interrupted service with windows 7

I have Logitech MX 5500 and mouse , I ve installed it in windows 7 32 bit (using run as administrator), during the installation it was working fine both(detected the mouse and the keyboard) , after installation when the wizard appears to configure the mouse and the keyboard , stops working at all, I press connect on the mouse and keyboard,not connecting at all!,the wizard is saying ensure that the bluetooth is powered on to discover the both keyboard and mouse, any help
0
i_harfoush
Asked:
i_harfoush
  • 2
  • 2
1 Solution
 
Craig BowmanIT Services ManagerCommented:
once your devices are discovered try right clicking on them and selecting properties then put a check in the box for HID devices.  See if this helps your issue.
0
 
i_harfoushAuthor Commented:
you mean in the device manager?
0
 
Craig BowmanIT Services ManagerCommented:
yes
0
 
i_harfoushAuthor Commented:
the pc was old I replace it with new machine dell, and it is working without driver also
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now