Internet Explorer 8 ALWAYS logs me out of Sites now

a couple weeks ago my internet explorer started doing the MOST annoying thing! Ever site that I select to stay logged into, I am always logged out of now when I visit them.

Many forums I have selected to keep me logged in forever... no longer am I.. I have to enter my username and password always. Granted, when I begin to enter my username, it autocompletes and then my password automatically pops up into its window... so its saved my usernames and passwords and other autocomplete form fields...

i have tried everything I know of..
I have reset IE8s settings half a dozen times. Everywhere I could find a reset button in IE8 I pressed it.

I am so tired of being logged out or every site I visit and always having to log back in.

I am not sure what to do now...

Please help?

by the way I have windows 7 ultimate 64 bit

Jared867Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jared867Author Commented:
3.5 hours and not a single response? Did I stump everyone???
0
Jared867Author Commented:
hmm over 12 hours and not any response?
0
_Commented:
I mostly use Firefox anymore, so the only things I can think of are:
- go through the Privacy setting on the right side of the Toolbar and see if something is over-riding this.
- nuke your Cookies, and redo them.
- do a Repair of IE8
- uninstall and reload IE8
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

MereteCommented:
Hi Jared867,
Are you a full administrator on your Windows 7?
What you are referring to is called "AutoComplete" in Internet Explorer.
At some point windows may have asked you if you would like it to remember your password etc, with Windows 7-IE8 say yes.
If you don't allow windows to do this you have log on everytime
In Tools Options>Content>AUTO Complete>Settings>>Tick>> User Names and Passwords..
Enable everything
Try also>>Delete auto Complete History then add the Tick to the above
0
Davis McCarnOwnerCommented:
Actually, I have the same gripe with IE8 and the problem is with your cookies.  IE8 seems to like trashing the index to its cookies and, no matter what I do, I periodically have to log back into every website that needs it, including this one.
I have inspected the cookies folder and seen hundreds be there; but, have none of them recognized so I deleted everything and started fresh.  I have tried moving them to a custom location.  I have wiped every IE8 temporary, autocomplete, index.dat, etcetera; all to no avail.
It is, BTW, those cookies that let the website know you are a returning visitor, followed by an automatic authentication.
The best way to achieve the longest period of stability is to delete the cookies using IE's internet options and then manually delete the files left behind.
To see where IE 7 & 8 stores its Cookies in Windows Vista or 7 :
Open Explorer > Organize > Folder Options > Views > Check 'Do not show hidden files and folders' and Uncheck 'Hide protected OS files' > Apply > OK.
Now you will be able to see the two real locations of Vista or 7's Cookies folders.   C:\Users\username\AppData\Roaming\Microsoft\Windows\Cookies C:\Users\username\AppData\Roaming\Microsoft\Windows\Cookies\Low
0
Jared867Author Commented:
Actually I did some research on the internet this afternoon and found this:

http://support.microsoft.com/kb/923737

I ran the small file that you can download from  this page and it fixed everything. It did reset EVERYTHING but it did fix my problem completely.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
_Commented:
That's one way to do it.   ; )
Thanks for the feedback.
0
Davis McCarnOwnerCommented:
You'll need to reinstall flash player, java, and acrobat reader, at least and, I hate to be a pessimist; but, I think it'll be back.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.