Linking one LAN segment with another LAN segment through Cisco routers

I have  02 domains in a forest. These domains are at 02 different sites interconnected thru T1. Domain A uses 100.100.101.0/16 subnet and domain B uses 100.100.103.0/16 subnet. Domain A has Cisco1700 router with 100.100.100.253/23 ip address for e0 and 10.10.1.2/30 for s0 interface. This router connects to domain B thru T1 on Cisco 2611 router on s0/1 with ip address 10.10.1.1/30. e0/0 interface on Cisco 2611 router has ip adress 100.100.103.1/24.

We have decided to move domain A to the same physical site as domain B eliminating T1 between Cisco 1700 and Cisco 2611 routers. How should I configure the s0 interface on 1700 router and s0/1 interface on 2611 router to ensure un-interrupted data flow. Thanks.
TajammalwAsked:
Who is Participating?
 
JeffSchaperCommented:
Only on 1 s/0

dce
clocking 1554000 (note: you can make this higher if you want)
0
 
atlas_shudderedSr. Network EngineerCommented:
How many hosts do you have on domain A and B respectively at the moment?
 
0
 
TajammalwAuthor Commented:
45 on A and 25 on B
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
JeffSchaperCommented:
Change 1 of the s0 to a DCE and use a DCE serial cable. This will connect to your other router via it's DTE cable.
0
 
TajammalwAuthor Commented:
1700 router has a WIC port currently used by T1. Likewise, 2600 router has the WIC port currently used byT1. Only RJ-45 cable can be used to connect the two routers between these two ports.
0
 
JeffSchaperCommented:
Oops my apologies, saw s/0 and assumed serial WICs. Have you tried a cross-over rj-45 cable?
0
 
TajammalwAuthor Commented:
I am going to try that today. Here are the current configs of 2611 and 1700 routers. Could you suggest modifications in these configs to suite the new environments with T1 removed? Thanks.

2611 Router ( s0/1 config will be modified)

User Access Verification

Password:
Barclay-Hub-Router>enable
Password:
Barclay-Hub-Router#show running-config
Building configuration...

Current configuration : 1493 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname Barclay-Hub-Router
!
logging buffered 4096 debugging
enable secret 5 $1$GuUE$M9bmyH/2l8pduzpB1FLCV0
!
memory-size iomem 10
clock timezone EST 0
ip subnet-zero
ip name-server 199.170.121.15
ip name-server 208.249.42.9
ip name-server 206.79.240.10
ip name-server 206.79.240.11
!
interface Ethernet0/0
 description Barclay LAN
 ip address 100.100.103.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0/0
 description Data connection from Barclay to Calhoun
 bandwidth 512000
 ip address 10.10.1.9 255.255.255.252
 no ip route-cache
 no ip mroute-cache
!
interface Ethernet0/1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Serial0/1
 description Barclay to Kinston Court
 bandwidth 1554000
 ip address 10.10.1.1 255.255.255.252
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 service-module t1 timeslots 1-24
!
ip classless
ip route 0.0.0.0 0.0.0.0 100.100.103.2
ip route 100.100.100.0 255.255.254.0 10.10.1.2
ip route 100.100.104.0 255.255.255.0 100.100.103.10
ip route 100.100.106.0 255.255.255.0 10.10.1.10
no ip http server
!
line con 0
 exec-timeout 30 0
 password 7 141B1D040724272E
 logging synchronous
 login
line aux 0
 password 7 050709002A6C430C
 login
line vty 0 4
 exec-timeout 30 0
 password 7 050709002A6C430C
 login
!
end

1700 Router ( s0 config will be modified)
User Access Verification

Password:
ATCO-KINSTON>enable
Password:
ATCO-KINSTON#show running-config
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname ATCO-KINSTON
!
logging buffered 4096 debugging
enable secret 5 $1$ar3x$tcqYOeMXykaaU3vcMomXM1
!
clock timezone EST 0
ip subnet-zero
ip name-server 199.170.121.15
ip name-server 208.249.42.9
!
interface Serial0
 description T1 id 38/HCFU/660666 SB Kinston to Barclay
 ip address 10.10.1.2 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 service-module t1 timeslots 1-24
!
interface FastEthernet0
 description Kinston LAN
 ip address 100.100.100.253 255.255.254.0
 no ip directed-broadcast
 no ip route-cache
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.1.1
no ip http server
!
line con 0
 exec-timeout 30 0
 password 7 060A002E476E041C
 logging synchronous
 login
 transport input none
line aux 0
 password 7 082D434102390812
 login
line vty 0 4
 exec-timeout 30 0
 password 7 151E04030F0A2621
 login
!
no scheduler allocate
end
0
 
TajammalwAuthor Commented:
You mean I have to only add clockrate in s0 config of 1700 router, and no change whatsoever in rest of the configuration of both routers. This way you are simulating the current T1 link? Am I right?
0
 
JeffSchaperCommented:
That's correct. I usually run this type of setup on my test bench. Try it if you have spare routers
0
 
TajammalwAuthor Commented:
Do I need to make a special RJ-45 crosscover cable for T1 simulation. If so, can you give me the pin connections?
0
 
JeffSchaperCommented:
The standard
1 -> 3
2 -> 6
3 -> 1
4 -> 4
5 -> 5
6 -> 2
7 -> 7
8 -> 8
0
 
TajammalwAuthor Commented:
It didn't work. I could not ping 2611 router from 1700 router after entering the clock rate in s0 of 1700 router as suggested by you.
Secondly, the 1700 router did not accept 1554000 clock rate saying that no such clock rate exits. So I entered a clock rate of 125000 which was taken, but this clock rate won't show itself in the running-config.
0
 
JeffSchaperCommented:
post your show interface s/0 of both routers
0
 
JeffSchaperCommented:
also when in the interface config mode, enter, clock rate ? this will tell you what you clock rate options are.
0
 
JeffSchaperCommented:
Also confirm you are entering the clocking in the DCE interface and not the DTE? A show interface will tell you which is a DCE or DTE
0
 
TajammalwAuthor Commented:
Here are the results of show interfaces for both routers:
1700 Router:

User Access Verification

Password:
ATCO-KINSTON>enable
Password:
ATCO-KINSTON#show interfaces
FastEthernet0 is up, line protocol is up
  Hardware is PQUICC_FEC, address is 0050.0f02.2827 (bia 0050.0f02.2827)
  Description: Kinston LAN
  Internet address is 100.100.100.253/23
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliablility 255/255, txload 2/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 1/75, 0 drops
  5 minute input rate 100000 bits/sec, 87 packets/sec
  5 minute output rate 1112000 bits/sec, 131 packets/sec
     1815633 packets input, 851501382 bytes
     Received 100748 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast
     0 input packets with dribble condition detected
     2027597 packets output, 1616414085 bytes, 2 underruns
     2 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0 is up, line protocol is up
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Description: T1 id 38/HCFU/660666 SB Kinston to Barclay
  Internet address is 10.10.1.2/30
  MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
     reliablility 255/255, txload 16/255, rxload 182/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  LCP Open
  Open: IPCP, CDPCP
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 1/75/0 (size/max/drops); Total output drops: 787
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/787 (size/max total/threshold/drops)
     Conversations  0/39/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 1100000 bits/sec, 132 packets/sec
  5 minute output rate 100000 bits/sec, 87 packets/sec
     2015330 packets input, 1593612149 bytes, 0 no buffer
     Received 2015330 broadcasts, 0 runts, 0 giants, 0 throttles
     14 input errors, 2 CRC, 8 frame, 0 overrun, 0 ignored, 4 abort
     2006858 packets output, 1614854321 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up



2611 Router:

User Access Verification

Password:
Barclay-Hub-Router>enable
Password:
Barclay-Hub-Router#show interfaces
Ethernet0/0 is up, line protocol is up
  Hardware is AmdP2, address is 00d0.589e.9600 (bia 00d0.589e.9600)
  Description: Barclay LAN
  Internet address is 100.100.103.1/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 3/255, rxload 31/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 12w6d
  Input queue: 6/75/49037/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 1226000 bits/sec, 129 packets/sec
  5 minute output rate 120000 bits/sec, 74 packets/sec
     304535728 packets input, 1186179502 bytes, 185 no buffer
     Received 3357049 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     263910746 packets output, 513449059 bytes, 0 underruns
     5 output errors, 17968997 collisions, 0 interface resets
     0 babbles, 0 late collision, 6458695 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0/0 is up, line protocol is up
  Hardware is PowerQUICC Serial
  Description: Data connection from Barclay to Calhoun
  Internet address is 10.10.1.9/30
  MTU 1500 bytes, BW 512000 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:04, output 00:00:03, output hang never
  Last clearing of "show interface" counters 12w6d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 29604
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/29604 (size/max total/threshold/drops)
     Conversations  0/29/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 11000 bits/sec, 6 packets/sec
  5 minute output rate 67000 bits/sec, 9 packets/sec
     14942123 packets input, 3072563431 bytes, 0 no buffer
     Received 922202 broadcasts, 0 runts, 4 giants, 0 throttles
     4125 input errors, 537 CRC, 3226 frame, 0 overrun, 0 ignored, 359 abort
     16272597 packets output, 3779812444 bytes, 0 underruns
     0 output errors, 0 collisions, 87 interface resets
     0 output buffer failures, 0 output buffers swapped out
     40 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Ethernet0/1 is administratively down, line protocol is down
  Hardware is AmdP2, address is 00d0.589e.9601 (bia 00d0.589e.9601)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 12w6d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial0/1 is up, line protocol is up
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Description: Barclay to Kinston Court
  Internet address is 10.10.1.1/30
  MTU 1500 bytes, BW 1554000 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  LCP Open
  Open: IPCP, CDPCP
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 12w6d
  Input queue: 2/75/5165/0 (size/max/drops/flushes); Total output drops: 40068
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/40068 (size/max total/threshold/drops)
     Conversations  0/35/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 188000 bits/sec, 90 packets/sec
  5 minute output rate 1225000 bits/sec, 136 packets/sec
     256665897 packets input, 1135830519 bytes, 2 no buffer
     Received 0 broadcasts, 0 runts, 11 giants, 0 throttles
     578522 input errors, 277871 CRC, 269772 frame, 0 overrun, 0 ignored, 30878
abort
     295026676 packets output, 818162258 bytes, 0 underruns
     0 output errors, 0 collisions, 11 interface resets
     0 output buffer failures, 0 output buffers swapped out
     22 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

0
 
TajammalwAuthor Commented:
I had to replace the RJ-45 interfaces with serial DCE/DTE interfaces on both routers. Now I can ping one router from the other and vice versa. I believe the solution will work when put in a production environment.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.