XP Computer slow preparing network connections on startup

I have one XP computer that is part of a Server 2003 network that uses active directory / domain. 24 out of 25 computers boot up fine but I have one that is for some reason booting very slow and takes around 2 minutes to get past the preparing network connections screen before the user attempts to log in. The user can login after preparing network connection finishes.

Computer is set on DHCP and DNS Is also obtained automatically.

Things I have went through after reading past replies / answers to similar posts:

-Confirm that DNS was not set to ISP dns. (I've also entered the server dns but it does not make a difference)
- Removed computer from server via server management console, renamed computer, added computer back to server via servername/connectcomputer
- Desktop only has one network card
- I have bypassed the switch in the office and plugged directly into wall jack.
- Removed shared folders
- IPCONFIG / FLUSHDNS

The network settings are all the same to to the other two computers on the network that are identical to this one hardware wise. Once I get logged in, everything works great it is just the slow bootup process.

If I look at the event log I do have DCOM errors but I do not think that pertains to this error as the date was from a few days ago not when I have been working with this slow bootup. Here is that event error message just incase it would help.

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{5F36DC27-B076-4D0C-BD8C-7AEE14022193}
 to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20).  This security permission can be modified using the Component Services administrative tool.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
ZephyrMAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian PringleSystems Analyst II, SCM, ERPCommented:
I've had this problem before.  It is caused by logging.  You need to disable that "feature".

http://www.tweakxp.com/article37007.aspx
0
mcsweenSr. Network AdministratorCommented:
You might have the GPO setting "Always Wait for Network on Startup set"

Start, Run, rsop.msc

Drill down to Computer Config\Admin Templates\System\Logon

Check that "Always Wait for Network at Computer startup and Logon is not enabled"

If it is you will have to see where it is coming from (Domain GPO or Local Policy).  Look under the GPO name column to the right.  This will tell you the GPO object name or Local Policy.
0
ZephyrMAuthor Commented:
mcsween: When I go to Computer Config\Admin Templates\System\Logon ; The only thing listed is "Don't display the getting started screen at logon.

Is there something I can look into as far as local group policy? We really aren't running group policies on the actual sbe server.
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

ZephyrMAuthor Commented:
btpringle: I tried doing that but after going through the steps and rebooting it did not solve the issue. I went back and removed the setting after it did not work.
0
mcsweenSr. Network AdministratorCommented:
If you don't see it there in rsop.msc then it is not configured (off).  RSOP only shows policies that have been configured.

Does this computer have multiple NICs?  If so go into the bindings and unbind Client for MS Networks from the one that is not connected to the same LAN as the server.  If there are 2 and they are both connected to the same network segment that would cause issues too.
0
ZephyrMAuthor Commented:
mcsween, computer does only have one nic and it is onboard. I have also removed the nic from device manager, and let it detect back but that didn't change anything.

0
kamalp123Commented:
Hi ZephyrM,

Using static IP (instead of DHCP) will greatly reduce waiting time during "preparing network connections".

Also, go to the following registry path:
HKLM\Software\Policies\Microsoft\Windows NT\CurrentVersion\Winlogon\
Modify/create the DWORD with the name "SyncForegroundPolicy" to value "0".

Above steps will definitely slash down the waiting time to normal. Hope this will resolve your issue.

-Kamal
0
ZephyrMAuthor Commented:
@kamalp123: I do not have a CurrentVersion inside of my Windows NT folder. Should I create that folder as well as the Winlogon  and create teh dword "SyncForegroundPolicy" entry?

In our current setup other pc's are logging in fast with DHCP so I'd rather keep it that way then switch everything over to static ip's.

Thanks
0
ZephyrMAuthor Commented:
@kamalp123 I went ahead and created the keys and also the dword entry and rebooted the system. System still took between 2 minutes and 2:30 minutes to get by the preparing network connections
0
scrathcyboyCommented:
I assume this computer is running MS word, yes?  If so, tell the user to open MS Word, and open 20 files on the LOCAL hard drive.  This will clear MS Word's links to network drives which causes major network failures, and slow network booting.  IF this does not solve it, go into file manager (explorer) and delete all network connections on that system.  Reboot, then remake any network connections that are needed to run network apps, by manually browsing for the files (delete the old icons, don't use them).  In the remaking of new network links, the problems or errors you see in not being able to find the computers/folders/apps will lead you to the source of the problem.  You may also have to remove and reinstall networking on that sys.
0
kamalp123Commented:
Hi ZephyrM,

creating that key in registry is fine. but still as your system is slow in preparing network connections try the below things:
-> go to the following key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\
add here a dword with name "DisableDHCPMediaSense" and with value "1"
-> go to run, type "services.msc", double click "WebClient" service and change the startup type to "disabled"

If the above also don't help, change the ip to static and do few reboots and the change back the ip to DHCP. hope this would definitely help your problem.

-Kamal
0
ZephyrMAuthor Commented:
@scrathcyboy: Tried everything except removing / reinstalling networking which did not solve the issue.

@kamalp123:  Disabled the webclient service but that did not help. Set static ip / dns and that did not help either.

In the end I removed CA Internet Security and the system booted just fine. Took 30 seconds rather than over 2 minutes. I'm going to try re-installing the CA software and see if the issue comes back. I've been wanting to get rid of that crappy software on our network for a while and I think now is a good time to show management why.

Thanks everyone for the replies.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.