• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 466
  • Last Modified:

How to stop a 2008 Cluster running Exchange 2007 SP1 from failing over

Where is the setting to keep a Cluster from failing over if the Passive node experiences a network issue. Here is what happened. I have a two node CCR Cluster. Windows is 2008 SP2 and Exchange is 2007 SP1, update rollup 9. Node 1 is the Active node and Node 2 is the Passive node. We are running on ESX 4.0 and all the servers are virtual. I decided to update the NIC drivers on the Passive node only. I figured because it was the Passive node, I could without an issue. Well, the drivers installed just fine but caused a brief network connectivity problem on Node 2 which was to be expected. This caused Node 1 to fail over all its resources to Node 2. We are up and running on Node 2 now without a problem but if I try to update the NIC drivers on Node 1, I am sure the same thing will happen. I have been poking around in the settings but wasn't sure what to do. I did not know if there was any special process to follow to keep this from happening or is there is some check box that would prevent this.
0
osiexchange
Asked:
osiexchange
  • 5
  • 5
1 Solution
 
Jamie McKillopIT ManagerCommented:
Hello,

Where is your file share witness located?

JJ
0
 
osiexchangeAuthor Commented:
My file share witness is located on my Hub Transport server which of course is separate from my Cluster server
0
 
Jamie McKillopIT ManagerCommented:
Open Failover Cluster Management and click on your cluster name. Beside "Quorum Configuration" what does it say?

JJ
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
osiexchangeAuthor Commented:
Node and File Share Majority: \\servername\share
0
 
Jamie McKillopIT ManagerCommented:
You have it configured incorrectly. It should say "Other (File Share Witness unc path)". Under your current configuration, a failure of any single node will cause a fialover. Click More Actions - Configure Cluster Quorum Settings and set it up correctly.

JJ
0
 
osiexchangeAuthor Commented:
Well, that is exactly what I want in most situations but I was just wondering if there was a setting, besides this particular one, that would prevent that from happening. I don't want to mess with this setting because it supposed to be this way according to this article.

http://www.msexchange.org/articles_tutorials/exchange-server-2007/high-availability-recovery/deploying-exchange-2007-sp1-ccr-cluster-windows-server-2008-failover-cluster-part1.html

0
 
Jamie McKillopIT ManagerCommented:
Sorry, you are correct. I read your post as just "Node Majority" for some reason. Under your current configuration, your cluster should not have failed over. When you say you updated the NIC drivers, do you mean on the ESX host or did you update the virtual drivers in the guest?

JJ
0
 
osiexchangeAuthor Commented:
On the virtual Exchange server (guest), not the ESX host. I though I could do this also so I was surprised to see if failover like it did. What I am guessing happened is the NIC tempoarily lost connection with the network because of the driver upgrade. The host being upgraded took this as the other node going offline because it lost contact with it and requested a failover of resources even though the other node was perfectly fine. Not sure how to appoach this particular problem.
0
 
Jamie McKillopIT ManagerCommented:
In Failover Cluster management, I would validate your configuration to make sure there aren't any issues with your file share witness. When doing work on the passive node, it is best to suspend replication and stop the cluster service beforehand.

JJ
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now