gmail and leave messages on server iPhone 3g

I have an iphone 3g connect to my gmail account.  If my phone downloads an e-mail it's pulled off of the g-mail server.  I know it was possible to leave them on the server although I can no longer find the setting.  

Any ideas?

JOe K.
ClaudeWalkerAsked:
Who is Participating?
 
francrlCommented:
I assumed you were using POP, as IMAP syncronizes with your device. Sounds like that is not the case. To be honest now I'm not sure what the problem is. Do the mssages stay in your Google All Mail folder? Using imap in google deleting from the inbox usually just removes the Inbox "label" and puts it in all mail
0
 
csupaCommented:
You should use imap instead of pop3. Imap leaves all the messages (except the messages you delete), pop3 delete all the downloaded messages.
0
 
francrlCommented:
I love the pushmail feature when you set gmail to synchonize like this:
http://www.google.com/support/mobile/bin/answer.py?hl=en&answer=138740
That wiill leave them on the server, unless you delete the messages, and sychonize read vs unread.

If you want to use POP and leave messages do this:
On the phone go to Settings>Mail>Your account > advanced > delete from  server > never
0
 
francrlCommented:
Sorry, you need to also do this within the Gmail settings. Log into Gmail Go to Settings > Forwarding IMAP & POP > select When messages are accessed with POP Leave in Inbox
0
 
ClaudeWalkerAuthor Commented:
For my GMail I have:

IMAP Access Enabled

POP (nothing select out of enable for all mail, enable from this point forward, or disabled)

Should I enable POP for all mail?

Because this "On the phone go to Settings>Mail>Your account > advanced > delete from  server > never"  setting is not available.


0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.