How to pass a VLAN across a Point to Point T1

I have 2 locations connected to each other by a pair of Point to Point T1s and I would like to know how to have a VLAN span between locations without having to use different subnets on each side. (If this is even possible?!?)

I have a HP ProCurve 5412zl switch and 7102zl router at each location. The switches & routers use the default vlan to talk to each other and we have assigned 10.100.0.0/24 to this vlan. We also have VLAN 200 which has been assigned 10.200.0.0/24. I can telnet to a switch on the other side of the network so I am assuming that at least the default vlan is passing across the PtoP.

I would like to have VLAN 200 on both sides of my network use 10.200.0.0/24 addresses but I can't figure out how to configure the switches to do this properly. I don't want to use 10.200.0.0/24 on one side and use 10.200.1.0/24 on the other.

P.S. I know it's not recommended to do this over a WAN connection but we are planning on improving our connectivity to include a fiber-optic connection and we want to plan for the future. If we find our PtoP is flooded with huge amounts of unnecessary traffic we will rethink our strategy.
YPIT-Experts-Exchange.jpg
System EngineerSystems EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

francrlCommented:
I don't expect any points for this, but in short yes its possible. Its reffered to QinQ or 802.1Q tunnelling. I have very limited ProCurve experience so I don't know the commands , but I have done this in Cisco.

Do you have the Premium license for your switches?:

"ProCurve has implemented QinQ in the Switch 8200zl, 6200yl, 5400zl, and 3500yl series. In the 5400zl and 3500yl series, this feature is included in the Premium License"
http://h20430.www2.hp.com/other/procurve/cn/zh/network/pdfs/QinQWhitePaper_Nov_07_WW_Eng_Ltr.pdf
0
System EngineerSystems EngineerAuthor Commented:
I don't know. The way HP enables features on it's switches is very confusing. We have both 5400's and 8200's in our network. There are some features that are free with 8200's that you have to license in the 5400's. I also understand that there are some features on an 8200 that enable the same features on every other ProCurve switch even if they are not 8200's themselves.

I looked around on my 5412zl and didn't see anything that looks like QinQ so I guess I will have to call my HP rep and ask about the feature.

Thank you for putting me on the right path.
0
Don JohnstonInstructorCommented:
>I would like to know how to have a VLAN span between  locations without having to use different subnets on each
> side. (If  this is even possible?!?)

You can do it, but it's not easy. It can be done using L2TP (Layer 2 Tunneling Protocol) .

And I'd be surprised if the 5400 supports L2TP.

To be honest, the correct answer is: while it may be possible, you really shouldn't.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

System EngineerSystems EngineerAuthor Commented:
I am aware that what I am asking is not a recommended method.

The reason I am looking into this is because there is a very good probability that we will have fiber-optic between our two locations someday soon.

I already have multiple HP ProCurve switches connected to each other via F-O and everything works well and is easy to understand.

I am attempting to create a network configuration that will "upgrade" to take advantage of F-O without having to reconfigure one of my two locations with new IP addresses.

I am willing to put the effort into an unusual network design for the short run if it pays a big dividend in the long run.
0
Don JohnstonInstructorCommented:
What are the two devices that are connecting to the T1?
0
sidetrackedCommented:
your routers can tunnel your layer 2 lan traffic between sites using mpls, i have done it a few times using 1800 routers over the internet.

u can have a look at my old lab config below

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!        
!
!
!
pseudowire-class PW1
 encapsulation l2tpv3
 protocol none
 ip local interface Loopback0
!
!
!
!
!
!
interface Tunnel1
 ip address 172.16.0.2 255.255.255.252
 tunnel source 10.0.1.1
 tunnel destination 10.0.0.1
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.255
!
interface FastEthernet0
 ip address 10.0.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
 no cdp enable
 xconnect 192.168.0.1 1 encapsulation l2tpv3 manual pw-class PW1
  l2tp id 1 1
  l2tp cookie local 4 1
  l2tp cookie remote 4 1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!        
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
 no ip address
!
interface Async1
 no ip address
 encapsulation slip
!
router eigrp 1
 network 172.16.0.0 0.0.0.3
 network 192.168.1.1 0.0.0.0
 no auto-summary
 eigrp router-id 192.168.1.1
!
ip route 0.0.0.0 0.0.0.0 10.0.1.254
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
line con 0
line 1
line aux 0
line vty 0 4
!
!
webvpn context Default_context
 ssl authenticate verify all
 !
 no inservice
!
end      

-------------------------------------------------------------------------------------------------

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!        
!
!
!
!
class-map match-all PW1
!
pseudowire-class PW1
 encapsulation l2tpv3
 protocol none
 ip local interface Loopback0
!
!
!
!
!
!
interface Tunnel1
 ip address 172.16.0.1 255.255.255.252
 tunnel source 10.0.0.1
 tunnel destination 10.0.1.1
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface FastEthernet0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
 no cdp enable
 xconnect 192.168.1.1 1 encapsulation l2tpv3 manual pw-class PW1
  l2tp id 1 1
  l2tp cookie local 4 1
  l2tp cookie remote 4 1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
 no ip address
!
interface Async1
 no ip address
 encapsulation slip
!
router eigrp 1
 network 172.16.0.0 0.0.0.3
 network 192.168.0.1 0.0.0.0
 no auto-summary
 eigrp router-id 192.168.0.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.254
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
line con 0
line 1
line aux 0
line vty 0 4
!
!
webvpn context Default_context
 ssl authenticate verify all
 !        
 no inservice
!
end

Router2#
0
rxhangoCommented:
You can use        Ethernet over T1 Converters (IP over TDM). These converters exists and you can find it on the web from a lot of providers.

Hope it Helps
0
System EngineerSystems EngineerAuthor Commented:
Letting me know about L2TP put me on the right path to a solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.