Load Mozilla Firefox in normal mode

I have used Mozilla Firefox for years in XP. Recently I changed to Windows 7 and reinstalled Mozilla. Each time I start the program, a screen flashes up and says that it will run only in Safe mode.

I tried uninstalling and reinstalling Firefox. No luck.

I posed a question on Mozilla Firefox. No answer after a couple of weeks.

Is the only solution to forget about Mozilla Firefox and run Windows Explorer instead?

    --John Robin
JohnRobinAllenRetired professor of FrenchAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Thomas Zucker-ScharffSolution GuideCommented:
My suggestion is to use Chrome or chromium.  It is a faster better browser.  I was a FF user for years and really, really didn't want to change, but I finally installed it (if you use the portable version it won't demand to install in the users folder, but also you won't be able to use all of the browsers abilities).  It's a dream to use and since I use delicious for bookmarking anyway it didn't make much of a difference.  You do have to use unchrome to get rid of the spyware if you use chrome.
0
jameskeagieCommented:
I've had to do this once with Firefox on Win7 - usually on x64 versions.

Right click on the Firefox shortcut.  Select Properties.  Go to the "Compatibility" tab and select "Run this program in compatibility mode" and then select "windows XP SP3" from the drop down menu.  

Let me know if that allows firefox to run in normal mode.


If not, undo the previous settings and do the following:

Close Firefox.

Click on the Start Button >> Computer >> C:\  >> Users >> %Username%

Make sure hidden folders are visible. (Tools >> Folder Options >> View Tab >> Select "Show hidden files, folders etc...)  If you can't see the Tools menu in the FIle menu - press the "Alt" key and it will show momentarily.  

Now select App Data >> Roaming >> Mozilla  

Delete both folders in here - the Extensions & Firefox folder.  You will lose any Firefox settings or bookmarks etc. so back them up first if you need them.    

Restart Firefox.  

Let me know which solution helps - FF works great in Win7 - your installation must have just run into a problem.  
0
JohnRobinAllenRetired professor of FrenchAuthor Commented:
I suspect that jameskeagie's advice will lead to a solution, but I also suspect that I will end up using Chrome instead of Firefox.

However, I cannot work the solution proposed. It asks me to right click on the Firefox shortcut and select Properties. I right-clicked on the only shortcut I have for running Firefox and it presented only two choices: Run Firefox in Safe Mode or Remove Firefox from the Task bar.

I looked for a Firefox shortcut in All Programs and found none. Maybe that is why I cannot run Firefox.

I will try the second solution Mr Keagie proposed tomorrow morning or possibly later tonight.

In the meantime, since I want to get some work done, I have installed Chrome and it seems to work just fine.

That does not mean I have given up on Firefox.  I will report on my pilgrim's progress in the near future.

        John Robin
 
0
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Marc ZCommented:
John,
Two suggestions I might make, when trying to get Firefox fixed up for you.  There should be no reason to run Firefox in XP mode on Win 7.
Before  i give my thoughts, when you installed Firefox on Win7, is this a new machine or an upgraded win7?  Did you have Firefox previously installed or did you move a Firefox Profile to this machine?
Hopefully this one will fix, if not we go to Option 3.
Option 1.  Right-click the icon you use to start Firefox and choose Properties.
   2. Click on the Shortcut tab.
   3. Make sure the Target: box doesn't include -safe-mode at the end. It should only read "C:\Program Files\Mozilla Firefox\firefox.exe" for default installations of Firefox.

Option 2 - Windows will list in the Start Menu the applications you have most recently opened. Firefox in Safe Mode may be one of these applications. Try starting Firefox from another shortcut, for example the one under All Programs.


Option 3 - If old profile, we may need alternate suggestion, but if new profile and new Win7 (not an upgrade), lets start by downloading a Fresh Install of Firefox program, then locate the download, right click it, select Properties,  and hit the Unblock this program near the bottom of it.  Next you need to Uninstall Firefox.  Reboot machine.  IF you don't need any of your existing bookmarks, or passwords, you can delete your Profile folder, typically found here.
The default location of the Firefox profile folder is %APPDATA%\Mozilla\Firefox\Profiles\xxxxxxxx.default\.

    * %APPDATA% is shorthand for the C:\Users\<username>\AppData\Roaming\ folder (Windows 7/Vista)

If you need them, I recommend moving them until we can insure the program runs properly.
Before you reinstall Firefox a couple things to consider, do you have any security programs running that might block the install? Either disable or make sure you Allow it if the security program asks you.

Next what you want to do is find the Install program again, this time right clicking it and selecting Run as Administrator.  Let it install and run it, test it out a little bit. Close it, give it some time to confirm that it's closed and then restart it.
Safe Mode?
0
Marc ZCommented:
John, by the way, in Win 7, to locate any Firefox programs, simply hit the Start button, and type Firefox in the Search Programs and Files text box.  You should get 2 results under the Programs list. One will be simply Mozilla Firefox
and the other will be Mozilla Firefox (Safe Mode)

chances are you accidentally Pinned the Mozilla Firefox  (Safe Mode) shortcut
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnRobinAllenRetired professor of FrenchAuthor Commented:
The last comment by mtz1of4 solved my problem very quickly and easily.
I still have to work out whether to switch to Chrome or stay with Firefox. I will try to determine point allotment tomorrow.

Since both Firefox and Chrome work perfectly, I would like to know why one should use one of those in preference to the other. Since that was not my original question, I should not award points for the answer to that, but I am still curious about what others think of the two programs. Perhaps I will post that as a related question.
     John Robin (Allen)
0
JohnRobinAllenRetired professor of FrenchAuthor Commented:
The problem is solved in several ways.
0
JohnRobinAllenRetired professor of FrenchAuthor Commented:
The suggestion to use Chrome instead of FF is good, but does not really address the problem. I am still trying that.

I was unable to follow James Keagie's solution, but that is probably my fault.

mtz1of4's first comment is excellent, but his second comment is by far the easiest solution and works perfectly.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.