Microsoft Exchange Search Indexer Service is not running... OWA

My search indexer will not start in my 2007 environment. When I try to start it through PS, it get the following:
Test-ExchangeSearch : The Microsoft Exchange Search Indexer Service is not runn
At line:1 char:19
+ test-exchangesearch <<<<

I have also run "resetsearchindex.ps1 -force -all" and cleared the databases

I dont seem to have an issue with regular uses, but OWA isnt working.

What do I need to do to get the service to start?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


Running the resetsearchindex.ps1 -force -all only deletes the catalog files that are created with each exchange database.

Have you checked if the Exchange Search service is started on the exchange server?

outlook if in cached mode will continue to work as it uses the windows seach or the local client search.

if the service is not started try starting it and giv e me the corresponding event id in the application log.

Satya PathakLead Technical ConsultantCommented:
we need to reinstall Exsearch to see whether the issue could be solved.
Besides, msconfig.exe is not a published application from Microsoft, sorry for my carelessness. So we may guide you to find the ExchSearch Instance GUID from Registry or use some coding resource.
1.    The location is :
2.     You can use MsiConfigureFeature Function to get the product code. Besides, you can refer to the article to help you to get the product code for ExSearch.exe

SeeSpotLearnAuthor Commented:
Here is a screen shot of an error.
Satya PathakLead Technical ConsultantCommented:
Please try to follow the steps below to solve the problem.
1. In Windows Explorer, navigate to BIN folder of Exchange program.
2. Check if file msfte.dll exists. If so, continue proceeding step 3 or else step 6.
3. Reregister required DLL files
a. Load command window, navigate to BIN folder of Exchange installation path.
b. Run command
regsvr32 MapiProtocolHandlerStub.dll
regsvr32 msfte.dll
4. Restart service Microsoft Search (Exchange).
5. Try to start Microsoft Exchange Search Indexer. If the service still can't be started, continue proceeding step 6.
6. Remove Microsoft Full Text Indexing Engine For Exchange
a. Stop service Microsoft Exchange Search Indexer and Microsoft Search (Exchange).
b. Click Start -> Run, type Installer in the textbox and click OK.
c. Right-click header of the Name column, and then click More in the menu.
d. Select Subject and click OK.
e. Locate the item with subject Microsoft Full Text Indexing Engine for Exchange
Setup, right click it and select Uninstall.
f. Finish the uninstall process.
7. Install Microsoft Full Text Indexing Engine For Exchange
a. Find the installation package msfte.msi on the Exchange installation CD. The
default location is \Setup\ServerRoles\Mailbox\.
b. Run command
msiexec /i "<path>\msfte.msi" TARGETDIR="<Exchange installation path>"
c. Start service Microsoft Search (Exchange) and Microsoft Exchange Search

8. Wait for rebuilding the search index, and then try to search in OWA.
Note: The rebuild process will take up to 24 hours.

After that, we can get search index status with command
GetSearchIndexForDatabase -All > C:\index.log


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
the above mentioned Error  is an indication the at the search indexer service is unable to find the required dll

best option will be to only reinstall the componenet

Uninstall MSFE
- Go to the location in the Exchange CD Setup\ServerRoles\Mailbox.
- Right Click on mffte.mis and uninstall

this will uninstall the search indexer service from the server

Install MSFTE
msiexec /i "(loaction from excahange CD)Setup\ServerRoles\Mailbox\msfte.msi" TARGETDIR="C:\Program Files\Microsoft\Exchange Server"
then try restarting the service......
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.