Very slow access (abnormal) to shared application XP Pro

This is a very simple system with 2 computers - one acting as an application workstation AND as an application server to the other computer.
The app .exe is instantiated on the 2nd computer with the .exe resident on the "server".
This may be done directly by opening the C: drive on the server from the "client", by mapping the C: drive from the 1st onto the second and executing out of that "drive", by putting a shortcut on the Desktop of the 2nd computer pointing to one or the other as above.

Lately the "client" computer has started running this one app very slowly and sometimes appears to hang.  It looks like a network access issue.  
- It appears that the network is fine.
- Internet access is fine
- One can open files on the "server" from the "client" at normal speeds.
- However, opening this one app takes 30-60 seconds I'd guess and interactions sometimes appear to hang the "client".

I note that the arrangements stated above are all "standard" for this app - a commercial small office business application - namely Avimark for veternarian clinics.

I've tested the client computer:
- cleaned it of parasites
- extensive hard drive test
- extensive memory test
It works fine until it's on this network and trying to use this one app.

Norton firewalls are set up to allow the subnet and the program and I've done some experiments with turning off the firewall on the client at least.....

Also, if I right-click on the app's Desktop icon on the "client", I can't get properties up in any reasonable time at all.  It just seems to hang.
At the same time, I've had a Wireshark capture runnning on the client and the right-click generates lots of 2-way packets referring to SMB but I've not been able to analyze them yet.  Thus it may be that there's some unsuccessful handshaking going on??

I don't think this is getting anywhere fast.  Any suggestions?

LVL 27
Fred MarshallPrincipalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

naburtonCommented:
how big is the app?  ??MB  What is your network speed? 10/100/1000 Mbps?  Who makes the switch the computers are tied to....?  Make and model!
Fred MarshallPrincipalAuthor Commented:
The computers are connected via an ISP-provided modem/router.  100Mbps.
Note that this is a "normal" setup that used to work just fine .. is supposed to work just fine.
So, I'm looking for something a bit unusual I'd think.

I can run a set of pings all day with no dropouts.
Fred MarshallPrincipalAuthor Commented:
The app isn't *too* big and we're used to the time it takes to "normally" load.  It's not normally "instantaneious" by any means but surely quick enough.  Maybe a few seconds at most - certainly less than 10 and more likely 1.
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

naburtonCommented:
Network switch port can go bad. Try different port or a different switch all together.
Fred MarshallPrincipalAuthor Commented:
Please note that other files open with no trouble......
It doesn't seem that this would happen if there were a network physical issue....
scrathcyboyCommented:
You solve this kind of NW link by (1) deleting the icon on the client machine, and trying to reconnect to the "server" machine using the windows network client browser.  If you cannot find the "server" on network browser, you know you have an issue with TCP networking.  You can solve this fairy easily by reinstalling the client for MS Networks, breaking the mapped network drives, and reestablishing them by browsing.

(2) once you have done this, remake the icon by actually browsing the network from the client machine to refind the path on the "server" machine to the application EXE file -- as well as the data files.

(3)  If this does not work, you can either delete the app from the client and reinstall it, or delete networking protocols from the client and reinstall them all again, reboot, and go through step 1 again.  It will work ....
Fred MarshallPrincipalAuthor Commented:
I've likely done all of these things.  The app is not installed on the client.  The client instatiates the .exe resident on the server.

There is no problem finding the path or the .exe file.  
The problem is that the .exe file does not respond in any reasonable time, including right clicking and selecting Properties.

Yet, it does work, in time....... but not any time soon enough nor in comparison to opening other files on the same "server".
Fred MarshallPrincipalAuthor Commented:
Also, when the app is running, the client becomes sluggish with all apps.  
This feels like when an app is waiting for some networked resource
Fred MarshallPrincipalAuthor Commented:
More information:

I installed a switch between the ISP modem/router and the rest of the network - just to make sure.

There are actually two clients and one of them works just fine although it should be a slower computer.  

The slowdowns appear to only have to do with that one .exe file and its associated app when it's running - i.e. sometimes the one client computer appears to hang up for a time as if it's trying to interact on the network and gets preoccupied with that task.

So, it seems to be about one client and the one file on the server.....  very odd.
Fred MarshallPrincipalAuthor Commented:
It appears this was caused by Norton Internet Security.  I recently introduced two new client computers into the network and brought all computers up to date with Norton Internet Security.  Once done, *none* of the clients would work with the server.  And, I was unable to find settings in the firewall software that would allow it.  So, I changed over to Trend Micro Internet Security and now all clients work fine and with normal delays.

At the time of the original post, one client that worked was using an antivirus program with Windows firewall.
The other client that worked very poorly was using a different version of Norton than the server - and the server was using Norton.

I *must* have "turned off" the firewall during testing.  I can't imagine not doing so.  
So, this has been a long and expensive exercise!!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
File Sharing Software

From novice to tech pro — start learning today.