Exchange 2007 Autodiscover not working - OOO and Free/Busy info

Here's the situation:

We are running E2007 (moved from E2003) and no one can turn on their out of office from within Outlook 2007 (only OWA). Now, someone has come to me and I have confirmed that no one can see free/busy info on a meeting request.

I have been up and down the internet and believe that there is an issue with my autodiscover.

If I test the autoConfig I see:

Attempting URL https://mail.vv.com/autodiscover/autodiscover.asmx found through SCP
Autodiscover to https://mail.vv.com/autodiscover/autodiscover.asmx starting
Autodiscover request completed with http status code 404
Autodiscover to https://mail.vv.com/autodiscover/autodiscover.asmx FAILED (0x80004005)

I have added a host record in DNS for mail.vv.com to point to the internal ip of the exchange server and a host record for autodiscover.vv.com as well.

Can anyone point me in the right direction?
LVL 12
michaelgoldsmithAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Satya PathakLead Technical ConsultantCommented:
I would suggest you please verify once as per this KB.
http://www.exchange-genie.com/2007/07/exchange-2007-autodiscover-service-part-1/
0
michaelgoldsmithAuthor Commented:
AutoDiscoverServiceInternalUri shows:
Name: VVMAIL
https://mail.vv.com/autodiscover/autodiscover.xml

test-outlookwebservices -identity user |fl returns:
ID 1013 Error
The remote server returned error: (401) Unauthorized.

get-webservicesvirtualdirectory |fl name,internalurl,externalurl returns:
Name: EWS (default web site)
internalurl: https://mail.vv.com/ews/exchange.asmx
externalurl: (blank)

Get-OabVirtualDirectory ¦ fl Server,Name,internalurl,externalurl returns:
Server: VVMAIL
name: OAB
internalurl: https://mail.vv.com/oab
externalurl: (blank)

Get-UMVirtualDirectory ¦ fl Name,Server,Internalurl,externalurl returns:
Server: VVMAIL
name: UnifiedMessaging
internalurl: https://mail.vv.com/unifiedmessaging/service.asmx
externalurl: (blank)

0
Satya PathakLead Technical ConsultantCommented:
Some users have been recieving 401 Error when attempting to run Test-OutlookWebServices from the CAS server. The below articles talks about why IIS returns this error.

http://support.microsoft.com/?id=896861

You can test this by attemtping to access the server in the following way:

https://netbiosname/Autodiscover/Autodiscover.xml :
It will prompt for credentials. After prompting a couple of times we get the following error:Error: Access is Denied.-

Use https://localhost/Autodiscover/Autodiscover.xml :
It will work fine and give an output.

DisableLoopbackCheck can be disabled but then the system is left open to an attack and I would not recommend disabling this function unless you will enable once testing is completed.

: Disable the loopback check
Follow these steps:
1.Click Start, click Run, type regedit, and then click OK.
2.In Registry Editor, locate and then click the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
3.Right-click Lsa, point to New, and then click DWORD Value.
4.Type DisableLoopbackCheck, and then press ENTER.
5.Right-click DisableLoopbackCheck, and then click Modify.
6.In the Value data box, type 1, and then click OK.

Reff:   http://www.exchange-genie.com/2007/07/401-error-when-attempting-test-outlookwebservices/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

michaelgoldsmithAuthor Commented:
Disabling the Loop Check in the reg did the trick. But, what about the "disclaimer" - is this less secure?
0
michaelgoldsmithAuthor Commented:
Also, that solved the free/busy information, but Out Of Office Assistant still comes up as "Your Out Of Office settings cannot be displayed, because the server is currently unavailable. Try again later."
0
Satya PathakLead Technical ConsultantCommented:
0
michaelgoldsmithAuthor Commented:
The autodiscover is working. The outlook clients successfully pass the Test Autodiscovery.

I have migrated the public folders from the old 2003 server to the new 2007 server and dismounted the old public folder store.

Still getting the same error.
0
michaelgoldsmithAuthor Commented:
Update: Applied a patch for .NET 3.5 that is supposed to fix. Did not reboot the server yet, but I will update once I do.
0
Satya PathakLead Technical ConsultantCommented:
Allright @michaelgoldsm…!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.