Net Terminals are having connection problems with SCO after lowering MTU on the host

We use Net Terminals 200 to connect to a SCO OpenServer Release 5 host.  For purposes of one application, I had to lower the MTU on the host to below 1400.  After that, sometimes Net Terminals have problem logging in (they freeze); sometimes they can log in, but some functionality in the software is limited; and sometimes only black-and-white connection is available.

I set up one Windows PC to connect via telnet to the SCO server, and that connection is working fine.  I am remote from that business location and not familiar with net terminals very much.  What is wrong with them, and can it be corrected?
LVL 2
MashaCPAAsked:
Who is Participating?
 
MashaCPAAuthor Commented:
I think we narrowed down the problem - I logged in to each location and viewed the etc/hosts files.  At some locations, the IP addresses for net terminals were shown incorrectly.  Is it possible to change the hosts file remotely via telnet?  We have some SCO OS 5 and some Linux EntServer 9.
0
 
giltjrCommented:
Changing MTU is a touchy issue.  Typically the MTU should be the same for all hosts/devices within the same subnet.

So you may need to change the MTU to 1400 for all of your net  terminals.

However, what was wrong with the one application?  Typically applications should not have an issue with MTU.  Now, network paths may, say you were going across a VPN tunnel.

0
 
MashaCPAAuthor Commented:
How do I change the MTU on net terminals?  Do I telnet to them in the same way I telnet to the host?

Yes, the application works over a VPN, and large packets would not go through.
0
WEBINAR: 10 Easy Ways to Lose a Password

Join us on June 27th at 8 am PDT to learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees. We'll cover the importance of multi-factor authentication and how these solutions can better protect your business!

 
giltjrCommented:
I'm not sure.   You may need to set the default MTU back to 1500 or 1492 which ever you were using.

What you may want to try it set a route specific MTU for the other side of the VPN.  I am assuming Unix can do this and it would be something like

route add -net x.x.x.x/yy gw a.a.a.a MTU 1400

Where x.x.x.x/yy is the ip subnet and mask that is the target and a.a.a.a is the router.  I know you can do this in Linux and so I am assuming you can do this in Unix.

0
 
MashaCPAAuthor Commented:
I do not manage the other side of VPN - it is at the software company site.  I was advised to change MTU on the originating side.
0
 
giltjrCommented:
This would be a change on your side.  You need to lower the MTU you use when sending data to them.  Or they need to lower the MSS they advertise to you.
0
 
MashaCPAAuthor Commented:
You mean to add the route on the SCO host?
0
 
giltjrCommented:
Yes.  You may need to verify that SCO supports this.  Athough Linux is Unix like, its not Unix.  Although Unix is Unix, not all Unix's are the same.

So SCO may or may not support setting route based MTU sizes.

Even doing that will not change the MTU that the remote side uses.  They may need to do the same thing.

Typically it is a bad id to change a hosts MTU to support VPN setups because it normally causes local problems, as you have found.

What are you using for the VPN connectivity? You might be able to configure it to handle the MTU issue.
0
 
MashaCPAAuthor Commented:
Our VPN is managed by the ISP, so we have no access to configuration.  Between the ISP and the software company, they came up with the solution to change the MTU on the server.  I'll try adding the route instead, thanks!
0
 
gheistCommented:
1280 looks more like VPN MTU

Behind the scenes:
Your net admins use BROKE VPN system which disregards DF packets, to get over it you have to completley disable PMTU-related features.
0
 
giltjrCommented:
Do you know what VPN solution they are using?
0
 
giltjrCommented:
Yes, as long as you have the proper authority.  Typically you have to be root.
0
 
MashaCPAAuthor Commented:
When I log in as root and type cat /etc/hosts, I can see the content of the file.  How do I remove an unnecessary line or change one?  If I type edit /etc/hosts, I cannot use my arrow keys or move anywhere inside the file.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.